summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild')
-rw-r--r--gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild
new file mode 100644
index 000000000000..fac4406caa6b
--- /dev/null
+++ b/gnome-extra/gnome-user-share/gnome-user-share-3.34.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson multilib systemd xdg
+
+DESCRIPTION="Personal file sharing for the GNOME desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-share"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# FIXME: could libnotify be made optional ?
+# FIXME: selinux automagic support
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3:3
+ >=gnome-base/nautilus-3.27.90
+ >=www-apache/mod_dnssd-0.6
+ >=www-servers/apache-2.2[apache2_modules_dav,apache2_modules_dav_fs,apache2_modules_authn_file,apache2_modules_auth_digest,apache2_modules_authz_groupfile]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Upstream forces to use prefork because of Fedora defaults, but
+ # that is problematic for us (bug #551012)
+ # https://bugzilla.gnome.org/show_bug.cgi?id=750525#c2
+ "${FILESDIR}"/${PN}-3.18.1-no-prefork.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ -Dhttpd=apache2
+ -Dmodules_path=/usr/$(get_libdir)/apache2/modules/
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}