summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild')
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
new file mode 100644
index 000000000000..e4ff024c6df4
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? ( dev-libs/libxml2 )
+"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}