summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild')
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
new file mode 100644
index 000000000000..c0d96a974619
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-3.24.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://git.gnome.org/browse/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ test? ( dev-libs/libxml2 )
+"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}