summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extensions-topicons-plus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/gnome-shell-extensions-topicons-plus
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/gnome-shell-extensions-topicons-plus')
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/Manifest3
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild44
-rw-r--r--gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml11
3 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
new file mode 100644
index 000000000000..3e4f267208f7
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-shell-extensions-topicons-plus-21.tar.gz 2756641 BLAKE2B 39414711365a9c68fa2b0172859e9969a7f71eae5e7498abee9ff05e4c215df09419cdad99192c60892b1bd6e8b27724c81c5d3da9a3d8ca3072d984824cb950 SHA512 f85db46f20c24f0b11ce2c79c0548b88262faf059d674073e328917dc8497de0e07ccd6f3613f45aa9e49109468d78293f3a8f0f4fea5a24a7c5254666cda5df
+EBUILD gnome-shell-extensions-topicons-plus-21.ebuild 1327 BLAKE2B b8d030527a7364996f2258e5543344930ec64e2d4ff62d826f6e983c718521556f04789d9db36e121868e7227f983a473b9c53d700231470a71d9322c48b30ff SHA512 f18583531b6721b92fed2ac2b81c3ca3137331464196a05c4fad7ff02c21f33dbade7ecc657a1ed7274c5b231253f549f80b16013b8ece623773b06a3b14409e
+MISC metadata.xml 339 BLAKE2B 0fff96ce59c258cfb52c0616844df2bad11bf14fa283831d608ab862d2ac4fc26af0c4445d906d174290f0abee98149f12b24c85de79adfe2b959c17f14c3b42 SHA512 6bd54fe410561f215eba59872c742b9a11016cede62ddaf0aa8f899bf2c2abffde29cb63c9b819486a750be66b3dadd72257f6e26dcd87798aece31e0a752b40
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild
new file mode 100644
index 000000000000..852ec51263a1
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/gnome-shell-extensions-topicons-plus-21.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="Moves legacy tray icons to top panel"
+HOMEPAGE="https://extensions.gnome.org/extension/1031/topicons/"
+SRC_URI="https://github.com/phocean/TopIcons-plus/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.16
+"
+DEPEND="${COMMON_DEPEND}"
+
+#src_compile() {
+ # It redoes this with "make install" later due to a dumb Makefile, so don't bother
+ #make build
+#}
+
+src_install() {
+ # TODO: Figure out if we can get the schemas to standard location, in a way that works properly runtime too
+ make install INSTALL_PATH="${ED}usr/share/gnome-shell/extensions/"
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/README.md" || die
+ # Assuming it needs only compiled gettext catalogs at runtime
+ rm "${ED}/usr/share/gnome-shell/extensions/TopIcons@phocean.net/locale"/*/LC_MESSAGES/*.po || die
+ dodoc README.md
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
diff --git a/gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml b/gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml
new file mode 100644
index 000000000000..725b4746cbef
--- /dev/null
+++ b/gnome-extra/gnome-shell-extensions-topicons-plus/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phocean/TopIcons-plus</remote-id>
+ </upstream>
+</pkgmetadata>