summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-weather-in-the-clock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /gnome-extra/gnome-shell-extension-weather-in-the-clock
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'gnome-extra/gnome-shell-extension-weather-in-the-clock')
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest3
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild49
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml8
3 files changed, 60 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
new file mode 100644
index 000000000000..150cd7862bc6
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-shell-extension-weather-in-the-clock-20211108.tar.gz 127000 BLAKE2B 9c884b7bf093ef29fcd1cf3aa58accb4d5f70fa38bf9bd0cc0cfb81564952de9c6b9f1dbead26dd3902cc09d3be42f30c8e813a8fecb33c3753f45abe833974e SHA512 bb16b470f9d0d7fdcd90d5ec4a2723a97d808d8341c816aacd973390201c5e63a71aec51efc9953903a70ad964e406a104b9029c3c08b25b7a333de3e673dd6e
+EBUILD gnome-shell-extension-weather-in-the-clock-20211108.ebuild 1084 BLAKE2B cf62a95327ef71c7145b0221cc824cf5d8eb03929b18f2d42813676aa6a0db5a6123d5ffe8b0ecefe91b9ca7e65cf841b2eb67e2fa8a21a60c160f393e4f9115 SHA512 44d74474d9964601609a8d5352a161e379efc13614a5ee3258f0d239a2a5eae9f2cdd1fc99461998eb4f0b2e66069eb67a5e30f2c97ca98c60481ca41fae0e70
+MISC metadata.xml 241 BLAKE2B cb0374238d11e2a3f28f23b7049da09babd4310a99862738acfb7ba554f7758ac68cd09d1eb7a29068195c27010a846a540ed2c09b88fd043b37fb4f0762150f SHA512 b2c1d3e2cb6760ed4682da82af5370adcacd48afd558efa1abf84d955067b2ad32eda034af8cef95c71409622f97fa0113f2e07bee328f2d03512908ae931050
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild
new file mode 100644
index 000000000000..1d7cf088c5ac
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20211108.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Display the current weather in the clock"
+HOMEPAGE="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
+COMMIT="b36cc55bf41af1a4c801ddeb0fd71d1294892c4c"
+SRC_URI="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+ gnome-extra/gnome-weather
+"
+DEPEND=""
+BDEPEND=""
+
+extension_uuid="weatherintheclock@JasonLG1979.github.io"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/gnome-shell/extensions/
+ doins -r "${extension_uuid}"
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml b/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
new file mode 100644
index 000000000000..3947e1bf6d57
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>