summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-weather-in-the-clock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 17:55:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 17:55:42 +0100
commitb481b54b8432c46df354eedc3532b0420a38fd5a (patch)
tree02cc62a183cabccf4aa944e0d15b047b383abf16 /gnome-extra/gnome-shell-extension-weather-in-the-clock
parent7288c6e5fa05acddbf692a5187d925ef85662b46 (diff)
gentoo auto-resync : 18:04:2023 - 17:55:41
Diffstat (limited to 'gnome-extra/gnome-shell-extension-weather-in-the-clock')
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
index b9282233ccb0..5977575cb462 100644
--- a/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/Manifest
@@ -1,3 +1,4 @@
DIST gnome-shell-extension-weather-in-the-clock-20221024.tar.gz 127100 BLAKE2B daf0feb6730351c35bc0c66e54a39df78095eb284774c1689ffe7918afee329e1ab32a54657635ba6758f25fdee0de6d1ec39e007653925da87b3f967a1c4934 SHA512 7ebc1c7368b6e07e9186a3b2a19ee4aaedb0f897b31ad37d33153d58e961dfb9b6249bac287aa51fb110ad28c4858739b7ebc7a82a1301971f3c95891591a417
+EBUILD gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild 1276 BLAKE2B 09191f086f46f80747332076ace1a126aad08a4074ed73525df9a730fca732ae58c075f18ddeab9bf3916a658d55bd2befedd43bb3835dae6cf1aebfc913fc08 SHA512 fadb452563a4537484492df52a4683e93370e7490fa4585dfbf67ed1cb57da6d9d3d163b9a2548ef58531e6dabdb304f56c802973f998ede6c898eca59feb915
EBUILD gnome-shell-extension-weather-in-the-clock-20221024.ebuild 1082 BLAKE2B b03d1aedb0f3c7b5ed56f334626def372be828e9676cef0bbe145cd6275526bad2adcaa289bcea9c1a0bde77ce396c179afa6b991b8a79384442372e458e7f33 SHA512 6c6974850d32370ae7d0f96388c2273e969b800ce60205837e1ebdb674ccad73d61166c1fa13acd8f168d82a206e0a91fafd55e55c74abe5696352c84fdd220d
MISC metadata.xml 317 BLAKE2B ed39479ce5dd8dacc6091575826c37509f00e28cd3a59ea7147e09e142d263ce5e3b27e7e74995ba0fd4a7559f9e47b96ab64a39114c079d87e80b9d0fd3d7cf SHA512 a04383c0ba503df6fd72aac11a833baea2a175d449b9f5b64a2b6a709fe52ef46210e37870b77cb36efb4e30506ddb9ebe5d831bd5f209f241bbff59ba3e4fa3
diff --git a/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild
new file mode 100644
index 000000000000..d3210bf84483
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-weather-in-the-clock/gnome-shell-extension-weather-in-the-clock-20221024-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Display the current weather in the clock"
+HOMEPAGE="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock"
+COMMIT="38ba36090961a37260215ae04f4a7e0a1377da95"
+SRC_URI="https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.38
+ gnome-extra/gnome-weather
+"
+DEPEND=""
+BDEPEND=""
+
+extension_uuid="weatherintheclock@JasonLG1979.github.io"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ # https://github.com/JasonLG1979/gnome-shell-extension-weather-in-the-clock/issues/30
+ sed -i -e 's/"43"/"43", "44"/' \
+ "${extension_uuid}"/metadata.json || die
+}
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/gnome-shell/extensions/
+ doins -r "${extension_uuid}"
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}