summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest2
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200901.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
index 2abe1af06505..cf4143c5a395 100644
--- a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
@@ -1,3 +1,5 @@
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.tar.gz 3431 BLAKE2B 6355135f9027d53b10ba1f02f2fdf90dc0acbd090be8905addc78f22f7b136464831985152d8a112febc8891bbd18ea42aedd8009c7db4afc52ba48b6d502511 SHA512 322da0bc511bbb6943713fd3fc3d75d8f32b9872ced9eeb611acc77756392d0b9c9dc1311bdb4e255d131637de6a17a3d0a76f1cebcc71218d67d2ef6078a4d1
+DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20200901.tar.gz 15697 BLAKE2B e689b1cb09dd7a84b8c542a78fcc45dcf09af16725f44aa325d68009f189d4cd72ee435b8b66989cd18c6d1d33cda5d7a2408533f32a8da93a9b8cdd2f4f0bd0 SHA512 db29ea4ad68ed945857e2aef3c5afcc8449b5eb5163a7940487fa2fe174ab036a2a436a35dac345e3a3d96ec075460afe3ba48f5f460f14ed033ad5307ae5969
EBUILD gnome-shell-extension-control-blur-effect-on-lock-screen-20200713.ebuild 1330 BLAKE2B 5fa31ccac489303a350c07a479310b22c18a1cdb18d3946b8f2345b72ac6a6c46ec9d2e6b6d8a41db5a54d8fa0095b181661cde21049a0565dca57e35ed2e716 SHA512 71643acd4848f8432bf80d199ac8e13e560e571d9d60edb608ccd98eaf82059909a74321e90ae39ba3bd25493bfce5437faf34f27badd675ec97bafa10fc67da
+EBUILD gnome-shell-extension-control-blur-effect-on-lock-screen-20200901.ebuild 1332 BLAKE2B 00489b78e1bffebf5c01404fc01212ca13da07581d262797d1dc0d26f7d2026f3fa2dbd202aea6b1c028f3c6a1f8f547f92cc26412a05a8c3a72f284538f0f07 SHA512 c3c4c3cafc30b73d4977f6ba96a7a02f06972cbe7047ba53f3dbb03ec8512a6dcc108af9d6622e30fc1d0e7d01ab99d3f9a593dc52159661061b3b561bfd8e1f
MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200901.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200901.ebuild
new file mode 100644
index 000000000000..8d72170e4b9e
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20200901.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="df16335b2b7f4bbbd22b9e95a16f074ae405b3a3"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.36.4
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/Control_Blur_Effect_On_Lock_Screen-${COMMIT}"
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ cd "${extension_uuid}"
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}