summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
commitb0378783c1929d283116fe183089c123dba5869c (patch)
treeefe69bfa7e38c36238f6e5a9341f6194b949e6f5 /gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild
parente374e165c2ee372e9c6d10860ea6ef47f180f6b2 (diff)
gentoo auto-resync : 02:10:2022 - 13:12:50
Diffstat (limited to 'gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild
new file mode 100644
index 000000000000..a485c63f1867
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-bluetooth-quick-connect/gnome-shell-extension-bluetooth-quick-connect-30.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Allow to connect bluetooth paired devices from gnome control panel"
+HOMEPAGE="https://github.com/bjarosze/gnome-bluetooth-quick-connect"
+SRC_URI="https://github.com/bjarosze/gnome-bluetooth-quick-connect/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ net-wireless/bluez
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/shell-extension-}"
+extension_uuid="bluetooth-quick-connect@bjarosze.gmail.com"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md LICENSE Makefile schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+ dosym ../../../../../usr/share/glib-2.0/schemas /usr/share/gnome-shell/extensions/"${extension_uuid}"/schemas
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}