summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-applications-overview-tooltip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest2
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-7.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index 2fa59ce00aad..7d0be0a40663 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1,3 +1,5 @@
DIST gnome-shell-extension-applications-overview-tooltip-6.tar.gz 79354 BLAKE2B f9e6aee73c742a080ad82434c3741087a2db1d9ad91ed377d380267edaadc4754a7e2621f228ebcac7c3eed1fcdd83960bbc949f38b07e38dfffeac4452f3a9e SHA512 1c12434944e8803dfd6e5e95fd932386345c4632214059070c56d1640a7c13a88240f225fdf6efe2fd1deb0c8d0a07009e01dedd4f56f029303fbd5e33faa116
+DIST gnome-shell-extension-applications-overview-tooltip-7.tar.gz 79965 BLAKE2B f7698bdad46837f1ae736bbb2d9b376a28946df5f8a00d2e9b19d48bc4c2f4e742030f952d14bf5816ca1aae9b172a2639e2170d6bd87f373ff23c7ce9bd8912 SHA512 1cfaf23fefe5a940ae448658e176c69da9bb319f6200983b4ac14f65e76f5e449b9a235e6c1ccaf9b6d6db0fda9576e963fa1273b776dbfb5a72c608961e2d48
EBUILD gnome-shell-extension-applications-overview-tooltip-6.ebuild 1257 BLAKE2B 10d0f9276023a390dcf219620e7047fcf5439dd3b2c0dc7495303578c78eab7a5bfc6e2ec1909de96eabb9c3258593aea4e0e21955f9ec190ff23779deb4efcd SHA512 ac19312f3e552bd867eab9dd192a9140c891016423a1f40d14b35935961348959c1fb60ad278ede23c38b3afcc95e7a4a8e7a6f9c533cdf8ef7ac04e390d85a4
+EBUILD gnome-shell-extension-applications-overview-tooltip-7.ebuild 1259 BLAKE2B f67489ce0d5bb6ab6f01fec03f30d6b9b50fc48b220e910c7f93055bd945629cd7d2345d1d9c7b491965d59a1b30e728ac1faf33b05b708e74d9dce1fb01a110 SHA512 49caa780b4898dc9849617fdfc17edd4c6aaa164b749dd9b4833a27c7749bd823d9cd3e1cd783c2078a54d7c2515275771cf78941b99e1e1f31399994d5c5629
MISC metadata.xml 216 BLAKE2B 0fbfa16661345362ff89f87adc0bb42fc5f5c9145cdedb36f3f537b39af4023b91c4dfb0d8e83a4f9ac963141f594ba8ae678371c338d992a96e02c11fd84195 SHA512 628a69805356b7458edaa2297901224178b016477a937f77e692a78ce3e7a0b6d2d7b4c4b7e70d0185d7112e6a59a5131e07d8c950e90b9c8722471d7511afc6
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-7.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-7.ebuild
new file mode 100644
index 000000000000..8d4ffa583955
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Workaround until https://bugzilla.gnome.org/show_bug.cgi?id=663725 is fixed
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-3.20
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+
+src_install() {
+ einstalldocs
+ rm -f README.md || die
+ insinto /usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet
+ doins -r *
+ glib-compile-schemas "${ED}"/usr/share/gnome-shell/extensions/applications-overview-tooltip@RaphaelRochet/schemas || die
+}
+
+pkg_postinst() {
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}