summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-appindicator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-29 17:37:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-29 17:37:53 +0100
commitca2977e80c0b29d0e6ce6ff178b6e0043442262b (patch)
treec5285532adb7e0d3cec1f7e04c2cfb49e8f1575f /gnome-extra/gnome-shell-extension-appindicator
parent172f211c978ad5a44d673a147d1db4bb4677d60d (diff)
gentoo auto-resync : 29:09:2023 - 17:37:53
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/Manifest2
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-57.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/Manifest b/gnome-extra/gnome-shell-extension-appindicator/Manifest
index 943455ed229e..8587a67bb758 100644
--- a/gnome-extra/gnome-shell-extension-appindicator/Manifest
+++ b/gnome-extra/gnome-shell-extension-appindicator/Manifest
@@ -1,4 +1,6 @@
AUX gnome-shell-extension-appindicator-53-41a8e9c.patch 1087 BLAKE2B 8b23162f3210044f1bab144248b8e7ca3f3ab5c4bf08686497402341e4e5fc167e13b279950054bdf577d48f3d3c7e29462d518181ced3093980990d989e77c0 SHA512 bf4ebb6bca0f721f5c488a41395082d1a3f6eb25897aa0be57705f7abbab7e40a46fd97d4cfce72395be0dbd65b7d402ef3b194a0e0ddd4765a21e005aa09b71
DIST gnome-shell-extension-appindicator-53.tar.gz 69263 BLAKE2B a8f4b2d9534bf1711ae47fdc420ac3ca1539efe3963eb4a5fbd9e0ad71e047003ac639c5620e4c849be8a9873dd2b42659dd5883f7703a1d9dd940cc319580a6 SHA512 cc6f88c1dcfaacc47184fbe6a8b7d1525623485f686033d6a817d6d9d597f1a305a75cdbc3c9e7f05145e7ffb305893b2550812b3cb2c97aaf9af7a5399f8441
+DIST gnome-shell-extension-appindicator-57.tar.gz 67246 BLAKE2B cdbfce7c2ff731732dea76ce53421424ad887ab7c95b555142f1fccb549723c9f9816cde527dd0dca6b9c6b835d9ec8d255f8350f8d772199920ac69d2d26809 SHA512 256d365a653db40490cb0d4da5ee5f7508298bc9189e0a8e98a4f1c904f5627cd0cb1b5586786005638025e3b8a31bf948d08a69a40977887b5860f8dc5ee53e
EBUILD gnome-shell-extension-appindicator-53-r1.ebuild 1045 BLAKE2B a616e79d8c30c1364cc5bba7953b3dd9a62992ab469a9f8a0351db174c1ba22a3b822578b6ecf7d1093f65934921dc7bc046162f99f4324a6be00d14023b2b57 SHA512 e0d9945395a34038758df77189c4192406182f1acec3aeef32b6ac6256810cb489768989877bed7ab07ac7e2f994fe98a989220560334a9b33097341a81a1f5b
+EBUILD gnome-shell-extension-appindicator-57.ebuild 1042 BLAKE2B d60d41e11863dc7f68a49c054c8678f606654042c2283cdfbc49f89fd2ae7f5c3d8434dc7ec3c61c64e8bece2d36384ab3809459ae51caca0aff5373990a07f4 SHA512 06d6af48c6e596ead303f19da519f63e2f447fd705db72f96854eef69ce3200d862da00184dd585e85674d2ff828ecdcbee669f60e693f92a9c4a62a2817afc0
MISC metadata.xml 347 BLAKE2B 0d4ff8478dad5f546ec84e5fd91b38ceda891a10283ad54ae7c3fa1003a633847f4f64768651987885aa35769f503db27eaa05a2e9e761762bf7d8f45ead5d02 SHA512 b48b50854f68db0f5d0396be7aedd025c011f7d226c317ccb03c0bca2a0415353f8739a8fbcda79600679163e22e90d40b5b0af15a0c23fb0a7c3fda38516b82
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-57.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-57.ebuild
new file mode 100644
index 000000000000..a339a53e1705
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-57.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils meson
+
+DESCRIPTION="Support legacy, AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-45
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_prepare() {
+ default
+ # https://github.com/ubuntu/gnome-shell-extension-appindicator/issues/419
+ eapply -R "${FILESDIR}/${PN}-53-41a8e9c.patch"
+}
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}