summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
commitb0378783c1929d283116fe183089c123dba5869c (patch)
treeefe69bfa7e38c36238f6e5a9341f6194b949e6f5 /gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
parente374e165c2ee372e9c6d10860ea6ef47f180f6b2 (diff)
gentoo auto-resync : 02:10:2022 - 13:12:50
Diffstat (limited to 'gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild')
-rw-r--r--gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
new file mode 100644
index 000000000000..e8439a3ef588
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-appindicator/gnome-shell-extension-appindicator-46.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils meson
+
+DESCRIPTION="Support Ubuntu AppIndicators and KStatusNotifierItems in Gnome"
+HOMEPAGE="https://github.com/ubuntu/gnome-shell-extension-appindicator"
+SRC_URI="https://github.com/ubuntu/gnome-shell-extension-appindicator/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ dev-libs/libappindicator:3
+ >=gnome-base/gnome-shell-3.34
+"
+BDEPEND="
+ app-misc/jq
+"
+
+src_install() {
+ meson_src_install
+ rm "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}