summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-integration-spotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/gnome-integration-spotify
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/gnome-integration-spotify')
-rw-r--r--gnome-extra/gnome-integration-spotify/Manifest3
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild48
-rw-r--r--gnome-extra/gnome-integration-spotify/metadata.xml11
3 files changed, 62 insertions, 0 deletions
diff --git a/gnome-extra/gnome-integration-spotify/Manifest b/gnome-extra/gnome-integration-spotify/Manifest
new file mode 100644
index 000000000000..59ccedf3760f
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/Manifest
@@ -0,0 +1,3 @@
+DIST gnome-integration-spotify-20140907.tar.gz 6709 BLAKE2B b66018e5d0e5da4ee2a63b4f2fe1622d1c09c63fc3f69a13a353dbec0ae862d7188d2f83016d1d12892cc69f69dc8f2d4930de494e5cfaf377cdb28af377b5ff SHA512 51e0e7fdb0912e230b0965ca05740b01633b3bc0219dd6e8c31ad5a9378b15c1b44ce1f99098900af7a478f0d6180c3ee015c1717603b6c2fb4c54769dddb874
+EBUILD gnome-integration-spotify-20140907-r1.ebuild 1088 BLAKE2B eee6fc450013734e5afd2ccde4d31d2f2aff6d9337c1b7d078dc5792ff8681ac1851d21314ce79f1e98b418225822f34695532bae9928f19bcd883d80bf9e6ab SHA512 d5426537c55a588054638d30403e6a705da7ed399f78e55c3c00f9ce134c58e33daf438b9a4d95f6b90e24c5a777ebe8736c1d20fb41eb08db68990215d644da
+MISC metadata.xml 354 BLAKE2B c924a3ff76f3b4722a0a97c8b74ee7d6dc22d45a7f968eae3c79917f3d44d2296f2747f8150ab2f320432e7428e88f369457da082873beac161369098593f00c SHA512 8c3b0f5ae534f97b3a5ba81cc5e48280b48a864ca7f161876546ba14d4733fc09e960be75741b2a97f895a46228ddd5d787e685dc83fae8943d12341418a23e9
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild
new file mode 100644
index 000000000000..6b304d8fd213
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="GNOME integration for Spotify"
+HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
+#SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ x11-misc/wmctrl
+ x11-misc/xautomation
+ x11-misc/xdotool
+ x11-apps/xwininfo"
+
+src_install() {
+ dobin spotify-dbus.py
+ python_replicate_script "${ED}"/usr/bin/spotify-dbus.py
+ mkdir -p "${D}/etc/gconf/schemas"
+ cp spotify.schemas "${D}/etc/gconf/schemas"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_prerm() {
+ gnome2_gconf_uninstall
+}
diff --git a/gnome-extra/gnome-integration-spotify/metadata.xml b/gnome-extra/gnome-integration-spotify/metadata.xml
new file mode 100644
index 000000000000..890dee3a0870
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mrpdaemon/gnome-integration-spotify</remote-id>
+ </upstream>
+</pkgmetadata>