summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-integration-spotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-extra/gnome-integration-spotify
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-extra/gnome-integration-spotify')
-rw-r--r--gnome-extra/gnome-integration-spotify/Manifest5
-rw-r--r--gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild48
-rw-r--r--gnome-extra/gnome-integration-spotify/metadata.xml11
3 files changed, 64 insertions, 0 deletions
diff --git a/gnome-extra/gnome-integration-spotify/Manifest b/gnome-extra/gnome-integration-spotify/Manifest
new file mode 100644
index 000000000000..31fb1b8a4214
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/Manifest
@@ -0,0 +1,5 @@
+DIST gnome-integration-spotify-20140907.tar.gz 6709 SHA256 f1906851329461d3e1a2a7171fd8c6be5082505b04415f2879b1f634b554bbfe SHA512 51e0e7fdb0912e230b0965ca05740b01633b3bc0219dd6e8c31ad5a9378b15c1b44ce1f99098900af7a478f0d6180c3ee015c1717603b6c2fb4c54769dddb874 WHIRLPOOL 4f0867fd2aa0d62d9e71c933541896092991ee4389a79845c2ceff2c2712935405134291024817e9039afa0b62da9538cc329e110b739db28e40c1df2a28070e
+EBUILD gnome-integration-spotify-20140907-r1.ebuild 1088 SHA256 33e426a584b2af8e15b9ce57edda091f0f4577598b2eb785da8bab27c4ad5c05 SHA512 d5426537c55a588054638d30403e6a705da7ed399f78e55c3c00f9ce134c58e33daf438b9a4d95f6b90e24c5a777ebe8736c1d20fb41eb08db68990215d644da WHIRLPOOL 71c9c8f82684a3f4253c88b5cc48e9e2416b5adc577432811cb0e5595b3a7bea15295a8c086c44e855848c67eee8ce38e81fecb29c2f2eb9ddee9303583c3897
+MISC ChangeLog 2956 SHA256 cc7fd77e0850b0d097843476272c03aa639264ad332e1c86c2699cd25a80dc22 SHA512 09468118ba777843e25b681d5e5a9a2e2507359cded6f28d67a9501dc55064a87bef886148dec67025e8cec9d2ce91de77990e3b366f7572a9ee46fdf83a967e WHIRLPOOL 257488dba61a2a88b7d1274dc36447f6e6a807c4c4c779762ca0c528a502a8c5b19fa926e76ac7cb0e6244ba5d92561979914575ae84ef8e6899cb1716ebec52
+MISC ChangeLog-2015 2101 SHA256 da0c107f7fda3740e4769de3c98bc00c9511063fb7dbb820bd48ccfb78b7ce61 SHA512 621bb00354076c25d42675c4ddf2a2f2fd46587010c708ecd2c47df48b27a034f5ab099fbadd7ff9c426538eae53529489948ee6698581a7709040b52f6a2200 WHIRLPOOL a5cfd6ae8e4541fb8fe8d6c0e21ad204e0e93b173aa701f10d12f13f8e86b1ecc77d9ca5b54e479ed7688dcd49519ef96725524594bebf906ec3723e6996e94d
+MISC metadata.xml 354 SHA256 3edb911c53ea9a7c78defa15f1e37726627bb91382b4cc6d74507d93fc0bf921 SHA512 8c3b0f5ae534f97b3a5ba81cc5e48280b48a864ca7f161876546ba14d4733fc09e960be75741b2a97f895a46228ddd5d787e685dc83fae8943d12341418a23e9 WHIRLPOOL 3bc97d05ef323d7fcf17b644776e80687b77aea80d608fb66930ca1417a1c954fb83e4469e8fb833667cfc88c63685afa0dcce2462b395899c224f33cc60d192
diff --git a/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild
new file mode 100644
index 000000000000..6b304d8fd213
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/gnome-integration-spotify-20140907-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit gnome2-utils python-r1
+
+DESCRIPTION="GNOME integration for Spotify"
+HOMEPAGE="https://github.com/mrpdaemon/gnome-integration-spotify"
+#SRC_URI="https://github.com/mrpdaemon/${PN}/tarball/${PV} -> ${PN}-git-${PV}.tgz"
+SRC_URI="https://github.com/mrpdaemon/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+#S="${WORKDIR}/mrpdaemon-${PN}-df9124d"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ media-gfx/imagemagick
+ x11-misc/wmctrl
+ x11-misc/xautomation
+ x11-misc/xdotool
+ x11-apps/xwininfo"
+
+src_install() {
+ dobin spotify-dbus.py
+ python_replicate_script "${ED}"/usr/bin/spotify-dbus.py
+ mkdir -p "${D}/etc/gconf/schemas"
+ cp spotify.schemas "${D}/etc/gconf/schemas"
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+}
+
+pkg_prerm() {
+ gnome2_gconf_uninstall
+}
diff --git a/gnome-extra/gnome-integration-spotify/metadata.xml b/gnome-extra/gnome-integration-spotify/metadata.xml
new file mode 100644
index 000000000000..890dee3a0870
--- /dev/null
+++ b/gnome-extra/gnome-integration-spotify/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mrpdaemon/gnome-integration-spotify</remote-id>
+ </upstream>
+</pkgmetadata>