summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-03 13:42:34 +0000
commit066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (patch)
tree3cb05783d73b2c33589ba305144a31c718e123cd /gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild
parent16449a80e28af2209916cc66d19c9a44ca2b90d9 (diff)
gentoo resync : 03.03.2019
Diffstat (limited to 'gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild')
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild
new file mode 100644
index 000000000000..69d2acc4a714
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.30.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="telepathy v4l"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.54
+ dev-libs/folks[vala(+)]
+ net-libs/gnome-online-accounts[vala]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+RDEPEND="
+ >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
+ >=dev-libs/folks-0.11.4:=[eds,telepathy?]
+ >=dev-libs/glib-2.44:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-base/gnome-desktop-3.0:3=
+ net-libs/gnome-online-accounts:=
+ >=x11-libs/gtk+-3.22:3
+ v4l? ( >=media-video/cheese-3.5.91:= )
+ telepathy? ( >=net-libs/telepathy-glib-0.22 )
+"
+DEPEND="${RDEPEND}
+ ${VALA_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ xdg_src_prepare
+ vala_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use v4l cheese)
+ $(meson_use telepathy)
+ -Dmanpage=true
+ -Ddocs=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}