summaryrefslogtreecommitdiff
path: root/gnome-extra/gconf-editor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /gnome-extra/gconf-editor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'gnome-extra/gconf-editor')
-rw-r--r--gnome-extra/gconf-editor/Manifest5
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch34
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch66
-rw-r--r--gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild34
-rw-r--r--gnome-extra/gconf-editor/metadata.xml8
5 files changed, 147 insertions, 0 deletions
diff --git a/gnome-extra/gconf-editor/Manifest b/gnome-extra/gconf-editor/Manifest
new file mode 100644
index 000000000000..fc80055ad9f4
--- /dev/null
+++ b/gnome-extra/gconf-editor/Manifest
@@ -0,0 +1,5 @@
+AUX gconf-editor-3.0.1-assertion-crash.patch 1194 BLAKE2B 6ce0c5d96e329a32b0632829a812cdd6fae4418f6039cddcffe17fec91c58af8cb5d749eaa2a096496580d0e8ac3daa62ce427ebb6510c626a6e7908bf9dad3d SHA512 5fbe8a51d4f678f7444cfd8683ce171280031c8870a18efea709a5f0667f7701893f6d0d65df72cc6267b01f7a34c925529c5b814ab47a9a270568b3391b6bfc
+AUX gconf-editor-3.0.1-drop-accel.patch 1383 BLAKE2B 16e3e1816c8bb7da13827dfd6579e0cbbbdf73a2b368038e347f444569abec184cc9bc48caf8e6a16925c855b3ba8c5b370c7ab6f3f0cd9840061366b3e9a91d SHA512 c50c4fbbd25170ca7a7261f590862927e5f68eb5d1529ac5252175caa28ea916484d284e307580297f23e2ee8df7822f12e75c2912f8ab808946997d032fedff
+DIST gconf-editor-3.0.1.tar.xz 1452468 BLAKE2B 775072c69f3350b009c07553d178e83885379292159ea9025831bab0f6b91f2e95e341d4f654a0fd8896c560ba99e635b68f3ff825e337ec5b7d558a366fce52 SHA512 faaf237233d94730902d7c8e231545841862451f5998ef06bc3d51f6cdf0bc16bd1cecfc6b6a9e0ccc5197a06bb4f89068bfb478f900f3272ba03a2d94ec2f49
+EBUILD gconf-editor-3.0.1-r1.ebuild 801 BLAKE2B b2e16dd5a4c5be9e614471c1875fc65d60d95ea6cc593ac2229f2e07d45c120129ee043f26d7a2a624b41840a5fe7b0b2007e302fbcaac442e52649214d614a5 SHA512 97ebb68c595795556438669de55ab6807d0004658bdca72448075c434d0ef6984c0259fc756da84edd13e96ea75a591c182c3684081d8b4c2c858d17f21d4616
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch
new file mode 100644
index 000000000000..b7df8f51007d
--- /dev/null
+++ b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch
@@ -0,0 +1,34 @@
+From 25d823099337f7ede4782f46fea46f251646dc3e Mon Sep 17 00:00:00 2001
+From: Edward Sheldrake <ejsheldrake@gmail.com>
+Date: Wed, 11 Apr 2012 07:27:16 +0000
+Subject: Fix assertion failed crash
+
+Fix "assertion failed: (last_slash != NULL)" crash while navigating the
+left tree view, fixed by having the model for the right list view emit
+all the row deleted signals before deleting any of its data.
+
+Fixes https://bugzilla.gnome.org/show_bug.cgi?id=670586
+---
+diff --git a/src/gconf-list-model.c b/src/gconf-list-model.c
+index 27e1af6..4fc60f8 100644
+--- a/src/gconf-list-model.c
++++ b/src/gconf-list-model.c
+@@ -133,11 +133,14 @@ gconf_list_model_set_root_path (GConfListModel *model, const gchar *root_path)
+
+ if (model->root_path != NULL) {
+ for (list = model->values; list; list = list->next) {
++ model->stamp++;
++ gtk_tree_model_row_deleted (GTK_TREE_MODEL (model), path);
++ }
++
++ for (list = model->values; list; list = list->next) {
+ GConfEntry *entry = list->data;
+
+ g_hash_table_remove (model->key_hash, gconf_entry_get_key (entry));
+- model->stamp++;
+- gtk_tree_model_row_deleted (GTK_TREE_MODEL (model), path);
+
+ gconf_entry_unref (entry);
+ }
+--
+cgit v0.9.2
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch
new file mode 100644
index 000000000000..0d79ec56c396
--- /dev/null
+++ b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch
@@ -0,0 +1,66 @@
+From 62e68d8e2f6e2c473820113fbf46ced9f77111d4 Mon Sep 17 00:00:00 2001
+From: William Jon McCann <jmccann@redhat.com>
+Date: Thu, 03 May 2012 18:10:53 +0000
+Subject: Drop use GTK accel maps
+
+They are confusing, weird, and stored in an obsolete location.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=675392
+---
+diff --git a/src/main.c b/src/main.c
+index 8da5ccc..9bce4b8 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -26,34 +26,6 @@
+ #include "gconf-stock-icons.h"
+ #include "gconf-editor-window.h"
+
+-static char *
+-build_accel_filename (void)
+-{
+- return g_build_filename (g_get_home_dir (), ".gnome2", "accels", PACKAGE, NULL);
+-}
+-
+-static void
+-load_accel_map (void)
+-{
+- char *map;
+-
+- map = build_accel_filename ();
+- gtk_accel_map_load (map);
+-
+- g_free (map);
+-}
+-
+-static void
+-save_accel_map (void)
+-{
+- char *map;
+-
+- map = build_accel_filename ();
+- gtk_accel_map_save (map);
+-
+- g_free (map);
+-}
+-
+ gint
+ main (gint argc, gchar **argv)
+ {
+@@ -92,7 +64,6 @@ main (gint argc, gchar **argv)
+ /* Register our stock icons */
+ gtk_icon_theme_append_search_path (gtk_icon_theme_get_default (), ICONDIR);
+ gconf_stock_icons_register ();
+- load_accel_map ();
+
+ gtk_window_set_default_icon_name ("gconf-editor");
+
+@@ -107,7 +78,6 @@ main (gint argc, gchar **argv)
+
+ gtk_main ();
+
+- save_accel_map ();
+ g_strfreev (remaining_args);
+
+ return 0;
+--
+cgit v0.9.2
diff --git a/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..46fca22ad7ea
--- /dev/null
+++ b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="An editor to the GNOME config system"
+HOMEPAGE="https://git.gnome.org/browse/gconf-editor"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/gtk+-3.0.0:3
+ >=gnome-base/gconf-2.12:2
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ ~app-text/docbook-xml-dtd-4.1.2
+"
+# gnome-common for eautoreconf
+
+PATCHES=(
+ # Fix assertion failed crash (from 'master')
+ "${FILESDIR}/${PN}-3.0.1-assertion-crash.patch"
+
+ # Drop use GTK accel maps (from 'master')
+ "${FILESDIR}/${PN}-3.0.1-drop-accel.patch"
+)
diff --git a/gnome-extra/gconf-editor/metadata.xml b/gnome-extra/gconf-editor/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/gnome-extra/gconf-editor/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>