summaryrefslogtreecommitdiff
path: root/gnome-extra/evolution-ews
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-08 00:14:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-08 00:14:55 +0000
commite3a48e635527f3e2d2254e9631f7a5758df9c3fb (patch)
tree7efda32bb4a58c3099db3e763ccaf7cc08e75a50 /gnome-extra/evolution-ews
parent7a027cd18c60d9abad83a60c98ccf27db26be067 (diff)
gentoo auto-resync : 08:01:2023 - 00:14:55
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest2
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.46.3.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index 47624b0139e3..088112dc1296 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,5 @@
DIST evolution-ews-3.46.2.tar.xz 694936 BLAKE2B 548fdcaf0e0b9964bbb8b854a7aa7cd83f52195ddf6d9ba70b35ef9ea6f6c7606a967f3a3eece36bf7af3ecc3d7d2dfb8e6a701a6c18e85fe2523c8a3f04fea8 SHA512 dd669b8d562849d588f88dd40f981e0401a046cb5489b00894082b04462fadc43581dadb0eee87077b63998a32e80cb66ae9a5c0de99c7079bb5cbc5aa8c37bd
+DIST evolution-ews-3.46.3.tar.xz 695152 BLAKE2B 2c76f5d5769c6ac610cf8ad2cb55a78374e82793ca6fde838b263759b10f9aa5bb033171001db6a18d5cd2f45744673c063a714f755613c92537e56272683303 SHA512 99259661568fee71898b29a445e87ee110c356a98e3e415d6c2f44e7f9b6f1216b87fd9772c4a006ffde49058dfae594d31ead43ed85fb0c34925f530f8d9495
EBUILD evolution-ews-3.46.2.ebuild 1567 BLAKE2B 1aa3d892b4630a0bdc82fc969865b83ff4fb6d44701bd210efcee1b49bdc4d74f41887602b3a35ea2f0acbd3b7eb976cfa15e8d6325981a6bc6a53e847a9c3bb SHA512 abe4d29d7668bea13bee0afc5f886c33854b192a6fed3f171ab1d6f93fafe7fced46ca2261f38f2b0b7b1f675feadb8599be8f157214df73779df5d79b00cc98
+EBUILD evolution-ews-3.46.3.ebuild 1569 BLAKE2B 10b98ffcaa9ea821e760802bf9e2d2e423df2c805171cb554adc8be9eef852948f4e474b7ce1d5634c3df7800b1304ff40d0aa1d3712819ec8456d3838af8d37 SHA512 86da1e7429fd37900929ce7ed4bd3462de57634cb36a9503280656625979aa8633441d9c3fdeb59eae39f5eb38412ae73db948fb4d323736cd5d0696cfabc7d9
MISC metadata.xml 354 BLAKE2B a6cf76e87956f2418a25c83542af3e5efe415943426b03750b2572129b06f977f900207a1eef805b7ae463a84204d12bf286ef9ed0a5b6990cbac2c77783260f SHA512 9f06dce58e2dfdba0a22f8a711d5fc98aba9ae1d130173bd7ef8effd0bb3c1cf046eef712f7ea7bd55c4382ca01e78d7028419ce41812d33ef38a1329978af56
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.46.3.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.46.3.ebuild
new file mode 100644
index 000000000000..675ec4ff7d00
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.46.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}