summaryrefslogtreecommitdiff
path: root/gnome-extra/evolution-ews
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-27 03:10:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-27 03:10:45 +0100
commit9e68aee0e16e4b361fe06f9566c74b4bb2a22a27 (patch)
tree419e98a8690f9f840b62b1a2013e04141d0342c0 /gnome-extra/evolution-ews
parenta20b8556104c163a81183ff983af8123e40f16c5 (diff)
gentoo auto-resync : 27:05:2023 - 03:10:45
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest2
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.48.2.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index a5272511ecf6..ea7b8185b57f 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,5 @@
DIST evolution-ews-3.48.1.tar.xz 701696 BLAKE2B ddce95682a3b4bc75755f9c3e056942c95dfb929bcb40b99d02bf51126897d83f8ef7e68dc6c77af7f82f427dcad4c4e9fb51173b1b22f5d35985a353a1b2040 SHA512 b6166f2dd10c2b5b9ca0e5d5dde0c32ca7082f1c594e8b59642b943870dc5343f1ec4d07a7563c33a1252e989ec1e9ff360f98caf0b590a21dfec42383893a45
+DIST evolution-ews-3.48.2.tar.xz 701356 BLAKE2B 8c941302f383870bacf0dd3f02b28be34105ec7f612b027a505b98be0f66099d65671808e26e86ce756fc47116d012aa1c82fff74c5a501d3778dc7aba6b2498 SHA512 deccc3b442718b03809a7c49297a3f5d7c0bd2873fddfd9f90861a102208759cb95db9bfec1b04cff6932678f58aa81467c48fd4b1e32bb49ed43b9d8c9f4f77
EBUILD evolution-ews-3.48.1.ebuild 1567 BLAKE2B 1f19649d2b04afdfd2bf6eafb90cdc9152de8644342597911fb15917a4641796d640cc814b272268093c19b6ece4722856bf9c866085d28f8ff97737222e930a SHA512 4edb825807ec6ab34fdf41c7419c8417609a7e26be719f9bf92b6edc8b1d8cad63b1bdfb4a9a4e7c0d43b0a56535326d653634b7312063eaff076ef042f31688
+EBUILD evolution-ews-3.48.2.ebuild 1569 BLAKE2B 10b98ffcaa9ea821e760802bf9e2d2e423df2c805171cb554adc8be9eef852948f4e474b7ce1d5634c3df7800b1304ff40d0aa1d3712819ec8456d3838af8d37 SHA512 86da1e7429fd37900929ce7ed4bd3462de57634cb36a9503280656625979aa8633441d9c3fdeb59eae39f5eb38412ae73db948fb4d323736cd5d0696cfabc7d9
MISC metadata.xml 354 BLAKE2B a6cf76e87956f2418a25c83542af3e5efe415943426b03750b2572129b06f977f900207a1eef805b7ae463a84204d12bf286ef9ed0a5b6990cbac2c77783260f SHA512 9f06dce58e2dfdba0a22f8a711d5fc98aba9ae1d130173bd7ef8effd0bb3c1cf046eef712f7ea7bd55c4382ca01e78d7028419ce41812d33ef38a1329978af56
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.48.2.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.48.2.ebuild
new file mode 100644
index 000000000000..675ec4ff7d00
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.48.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}