summaryrefslogtreecommitdiff
path: root/gnome-extra/evolution-ews
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /gnome-extra/evolution-ews
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest2
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.50.0.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index ee72dacb4f90..c4d1de452a84 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,5 @@
DIST evolution-ews-3.48.2.tar.xz 701356 BLAKE2B 8c941302f383870bacf0dd3f02b28be34105ec7f612b027a505b98be0f66099d65671808e26e86ce756fc47116d012aa1c82fff74c5a501d3778dc7aba6b2498 SHA512 deccc3b442718b03809a7c49297a3f5d7c0bd2873fddfd9f90861a102208759cb95db9bfec1b04cff6932678f58aa81467c48fd4b1e32bb49ed43b9d8c9f4f77
+DIST evolution-ews-3.50.0.tar.xz 707208 BLAKE2B b2137c393e3ad6f3fdcd865d7dbba8f2830fbf3f287cb5599a23837ca5b4597714deeff08dc6e69443baf96171976476302bafeccdfb0c941c5b63e9a80f69c3 SHA512 51b90c018a5aea84e2c89785edcf69fe396d10d3fe447bc3ea5207506efa6433fe7af5e35ef6e2f5c3c2b8e3218ddff12c5be000dcad50c998c914994ce95745
EBUILD evolution-ews-3.48.2.ebuild 1567 BLAKE2B 1f19649d2b04afdfd2bf6eafb90cdc9152de8644342597911fb15917a4641796d640cc814b272268093c19b6ece4722856bf9c866085d28f8ff97737222e930a SHA512 4edb825807ec6ab34fdf41c7419c8417609a7e26be719f9bf92b6edc8b1d8cad63b1bdfb4a9a4e7c0d43b0a56535326d653634b7312063eaff076ef042f31688
+EBUILD evolution-ews-3.50.0.ebuild 1569 BLAKE2B 10b98ffcaa9ea821e760802bf9e2d2e423df2c805171cb554adc8be9eef852948f4e474b7ce1d5634c3df7800b1304ff40d0aa1d3712819ec8456d3838af8d37 SHA512 86da1e7429fd37900929ce7ed4bd3462de57634cb36a9503280656625979aa8633441d9c3fdeb59eae39f5eb38412ae73db948fb4d323736cd5d0696cfabc7d9
MISC metadata.xml 354 BLAKE2B a6cf76e87956f2418a25c83542af3e5efe415943426b03750b2572129b06f977f900207a1eef805b7ae463a84204d12bf286ef9ed0a5b6990cbac2c77783260f SHA512 9f06dce58e2dfdba0a22f8a711d5fc98aba9ae1d130173bd7ef8effd0bb3c1cf046eef712f7ea7bd55c4382ca01e78d7028419ce41812d33ef38a1329978af56
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.50.0.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.50.0.ebuild
new file mode 100644
index 000000000000..675ec4ff7d00
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.50.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2 optfeature
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution https://gitlab.gnome.org/GNOME/evolution-ews"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-3.0:3.0
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( >=net-libs/uhttpmock-0.9:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}
+
+pkg_postinst() {
+ optfeature "oauth support" gnome-extra/evolution-data-server[oauth]
+}