summaryrefslogtreecommitdiff
path: root/gnome-extra/evolution-ews
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /gnome-extra/evolution-ews
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest2
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index b38209b3304a..2f22bd4df763 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,5 @@
DIST evolution-ews-3.36.5.tar.xz 558900 BLAKE2B 059a72b087287d0e553e085dc764a928d838bc8bd011c16b00f240b29d12bc7cfda98d33f8dc102866f5747313975e32506dc016435342bdb6c35f7d73749b52 SHA512 9cc40ae5d56bc86a8aa4e7aaa36fa10b0841278dd1edb075155bfe3666da4051e4fc4843398f74d00d77f550aaeb93bf576007828da4c574a17d4f17c41bfb7f
+DIST evolution-ews-3.38.2.tar.xz 650188 BLAKE2B a1e296a15269191ecc9ff02108daed90bbcaefbabdc989f919dfc25532cb31a7afa73d897bcc0f2dbaf22b0e9b250af61db9900bc2dec740b08786dad7808e8b SHA512 5f441ecbf2753243711b605e085ae8fddcfaf0f91f822b76d8a8453aca0f55c2e7788d74d726651d58b97160db3581e269e6b9f05d7c4258bd28cf13ff14efe4
EBUILD evolution-ews-3.36.5.ebuild 1408 BLAKE2B 4c50c511fc049d334447938e4e2027bc4e3b353a684f453e90d4e20c3988e113632826b9107ed5726b5cbf59991bca285512cb80ab51071d45eb9e5eb307bfd0 SHA512 b845c4d3b3cfb3760e89c2f8cb8787f5a09db8840984cbc43ab427808db7436b9d58584514b4d83c5eb8e4ad6286f86bf2014c9656e32bade0c7b5dba307b91a
+EBUILD evolution-ews-3.38.2.ebuild 1408 BLAKE2B 7740c3a35f67e3be891044153a2f8b66027fe299d57f963abed1378240eeed2ba1759143f36c07618d7464a245d005d5948906d42b65e748ae625f19f725ed2a SHA512 7225d0d716b14af8e1ab8e5c1c998dade4cfdb6bdf072a9bbc5893a4adf8bc6134575ad772a0ca0d84d7979ed011b6e1761fc63902c1e87d73c161b9f2526da1
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild
new file mode 100644
index 000000000000..422d53389b60
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.38.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.46:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}