summaryrefslogtreecommitdiff
path: root/gnome-extra/evolution-ews
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /gnome-extra/evolution-ews
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'gnome-extra/evolution-ews')
-rw-r--r--gnome-extra/evolution-ews/Manifest2
-rw-r--r--gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/Manifest b/gnome-extra/evolution-ews/Manifest
index a1771fb16267..5561d06357fa 100644
--- a/gnome-extra/evolution-ews/Manifest
+++ b/gnome-extra/evolution-ews/Manifest
@@ -1,3 +1,5 @@
DIST evolution-ews-3.42.4.tar.xz 686236 BLAKE2B f68a3c4c41419eb5d316ce8271a8c8411217e63b951230fb0151d79fca15e82e36248e3bd676518ae5f8a92d7e1d1dbf6a140bbd63dee6dca97fe48f76d502f9 SHA512 5ce1a228414d8c456962ce944a01efbeefb059bc9ff358c95bb7cec72e74ad29cd9476c9aa396b01df35d7c89fff743837dc2f9763129a5f794cbbd14557c2e3
+DIST evolution-ews-3.44.0.tar.xz 688444 BLAKE2B d563137c481dc51f9934fe44a3c563e7204d63ebdac1de7a018da27f8c05cc3d56ddc37848fb57ed909e6bc4d98e2752d401f39e92ccd20b507033404c6b7284 SHA512 0625262e485edf7dc5a0449acae3d65992d4f17dcc64196e449922e3eeb4c8ce57cf0220ecf626bcfcd81b5cea1273ccde18f0dbb9073f56ee923a3cbfb93a83
EBUILD evolution-ews-3.42.4.ebuild 1406 BLAKE2B 2efed5c1908dedf348d557257fa96afca953ca8ce5760c923e3d2ea77ccad02e23304020ea0d2e66a32837b0f177a6a910c040b5d65bc59038d2d13116c28da2 SHA512 deda632646a2586dd54fa80e06f78bd6b10cc8701b2024b4bfbd3cfcc85d76f3063285cac0eebf1d893c40f6be7c801b6f7d67726be3779687955c1b93614b16
+EBUILD evolution-ews-3.44.0.ebuild 1408 BLAKE2B 40ce3a883938c4150df2f2e4ecbc05d45ca85b9eb7549cedb6203303c00ad5723d3f529cc32ec42a9e0dbec9cc0e82110c31353adbcfd526de9ead3e544c27e4 SHA512 e9c641fe945b6adebdbeb1b7a668e7bc2434218a077875b5322e57ac77e8b8ad791931e847698f539a44454d73c15cc2ca8b12ad708e325b7ceab46be170cbad
MISC metadata.xml 250 BLAKE2B 8f7f0fe023d43e380e7861e897e6afcb5de4baefb42ea9c65a57dfc0d204c6f787a99295141832e732ebb08be218da56ba77e2dd9639e4e3aabf718ce4db1d0c SHA512 2684e772dd6d83e4b49f08f2ba22d8a0a753e7b46863489eff1b5d1f2f147ad80ffd93245ca405ac4c747249bc1b754454ec9865fe16da70f9b257051e105fd8
diff --git a/gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild b/gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild
new file mode 100644
index 000000000000..72c04608688e
--- /dev/null
+++ b/gnome-extra/evolution-ews/evolution-ews-3.44.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange Web Services"
+HOMEPAGE="https://wiki.gnome.org/Apps/Evolution"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# libical-glib currently (2020-02-29) oddly behind USE=introspection
+RDEPEND="
+ dev-db/sqlite:3
+ >=dev-libs/glib-2.62:2
+ >=dev-libs/libical-3.0.5:0=[introspection(-)]
+ >=dev-libs/json-glib-1.0.4
+ >=dev-libs/libmspack-0.4
+ dev-libs/libxml2:2
+ >=gnome-extra/evolution-data-server-${PV}:0=
+ >=mail-client/evolution-${PV}:2.0
+ >=net-libs/libsoup-2.58:2.4
+ >=x11-libs/gtk+-3.10:3
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/uhttpmock )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=dev-util/intltool-0.35.5
+ >=sys-devel/gettext-0.18.3
+ virtual/pkgconfig
+"
+
+# Unittests fail to find libevolution-ews.so
+RESTRICT="test !test? ( test )"
+
+# global scope PATCHES or DOCS array mustn't be used due to double default_src_prepare
+# call; if needed, set them after cmake_src_prepare call, if that works
+src_prepare() {
+ cmake_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_MSPACK=ON
+ -DENABLE_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_test() {
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+}