summaryrefslogtreecommitdiff
path: root/gnome-extra/evolution-ews/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /gnome-extra/evolution-ews/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'gnome-extra/evolution-ews/files')
-rw-r--r--gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch71
1 files changed, 71 insertions, 0 deletions
diff --git a/gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch b/gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch
new file mode 100644
index 000000000000..050bacd7628c
--- /dev/null
+++ b/gnome-extra/evolution-ews/files/evolution-ews-3.38.4-cmake-3.20.1.patch
@@ -0,0 +1,71 @@
+https://gitlab.gnome.org/GNOME/evolution-ews/-/commit/6d8f7d303ec319539add2f0ba5331c2dab9d23c7.patch
+https://bugs.gentoo.org/783603
+
+From 6d8f7d303ec319539add2f0ba5331c2dab9d23c7 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Wed, 14 Apr 2021 16:58:08 +0200
+Subject: [PATCH] PrintableOptions.cmake: Correct variable name comparison
+
+CMake 3.20.1 errors out with:
+
+CMake Error at cmake/modules/PrintableOptions.cmake:38 (message):
+ variable name cannot be empty
+ Call Stack (most recent call first):
+ CMakeLists.txt:152 (add_printable_variable)
+
+Change how the parameter value is compared, to fix it.
+--- a/cmake/modules/PrintableOptions.cmake
++++ b/cmake/modules/PrintableOptions.cmake
+@@ -19,40 +19,40 @@
+ # prints all the build options previously added with the above functions
+
+ macro(add_printable_variable_bare _name)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ list(APPEND _printable_options ${_name})
+ endmacro()
+
+ macro(add_printable_option _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "option name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ option(${_name} ${_description} ${_default_value})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE STRING ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_path _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "path variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE PATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+
+ macro(add_printable_variable_filepath _name _description _default_value)
+- if(_name STREQUAL "")
++ if("${_name}" STREQUAL "")
+ message(FATAL_ERROR "filepath variable name cannot be empty")
+- endif(_name STREQUAL "")
++ endif("${_name}" STREQUAL "")
+ set(${_name} ${_default_value} CACHE FILEPATH ${_description})
+ add_printable_variable_bare(${_name})
+ endmacro()
+--
+GitLab