summaryrefslogtreecommitdiff
path: root/gnome-extra/cjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-15 23:36:27 +0000
commit31c69c39a3648b52dd931a40b198714249e8a5ec (patch)
treec7bfb4db01cf185b6b8f7bde72d9cc5d14d8db22 /gnome-extra/cjs
parentdce60e5aa0a12ccc07c10a0a2c3f8f063393b32a (diff)
gentoo auto-resync : 15:02:2024 - 23:36:26
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest2
-rw-r--r--gnome-extra/cjs/cjs-6.0.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 419d50f8f60b..16faaff16283 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,4 +1,6 @@
AUX cjs-5.8.0-move_have_gtk4_to_the_appropriate_place.patch 1417 BLAKE2B 203701b5535b338283b99aad63e3577d3abb295c005d2e2ac908e2f8abdb24e8f7b9ef311bcf35889a93804583f13ac65f1d9453111b5195320aab9442237b2e SHA512 e2f7ed4c5f15cec6a6a7d3303779a217716ca3d8fa5d3128f4e7e685c47284fd95b9e416d50b28ca34bd06a9c469ebb3f317db88526cdc2ba1088381871da9a4
DIST cjs-5.8.0.tar.gz 877668 BLAKE2B e4c031631030c2a4221937d5ca04034163f70f21e6e5ff2d0ca15f31a7455e83ecb1f977c4c4fb9a57e58d266856f817446e53b86ee87460bedf5339e33461b6 SHA512 f43bda5810b90ceab24d096d884c65503b2d9b94f5c0a9e6082215a427df97fbec4a21ee3f2d4f22d98ac24a04af1dcd9064600ec191ccec96ae0869cc803a02
+DIST cjs-6.0.0.tar.gz 877404 BLAKE2B 4290f0801f715aab1387da2ce0724376912db8ff3ad16fa8ad7eff03538dfc53ecbff2b7df0e70e52d16295b23ce51024da735d0e618b995fd3d3dfe297f9e26 SHA512 4cb359bf817d22a727683fd451ad6bde19aff4409e9033a97ef9cb204b3bd4c5e86421d7c01a267c3b4d42feb9b3bc5effb6fd970b3baf733242868c09536d95
EBUILD cjs-5.8.0.ebuild 2393 BLAKE2B ef37c491778c8821a03ffc88dd82914ca9721f12fb9ade0641eeaf8793a9d848e83011ce02e40e7c100f96bd919dfbd4b44a8ed1d058881e9a35d07c3aadd6b8 SHA512 760f674ec14ec6eab030ee38db457386af61e3dc23a9b1aa04c799170d4f786038c0ce2cfcfdebb3b392cd67ec187bbe164bca418014b378b2d1df47c7126c2c
+EBUILD cjs-6.0.0.ebuild 2310 BLAKE2B 0ffbfad44e3519203f57e3d47e7558723d0646f96f9ed2fc458bd277e08d733853af12195e144a13cd1c1d9d984d141e79643c6127a099a6668712e34220120f SHA512 ad5c489730b22728983e51d92814447b4266cf17025abae64a8fa40009a90c91ff9c227c409e690e0c5e7aa0fb5dc6d8a92db84067f57741e4b7a626d33e060d
MISC metadata.xml 608 BLAKE2B 7cc55145357fc7b4b46e1a77f19570b60f5dc6207c81efc3b92adf7d5fdb025296d4e6b8b927f193ed7bd0a929274e61c9bdddad2371ca78a497b94fdbe87737 SHA512 672923005e936fd3d08367a8db65318f63217841e6f841623d469c21ce354724f6c2cea853ecca928280b21011d6aa0e133a7830841c9fa44dd8c36402b28066
diff --git a/gnome-extra/cjs/cjs-6.0.0.ebuild b/gnome-extra/cjs/cjs-6.0.0.ebuild
new file mode 100644
index 000000000000..ea5027ca2add
--- /dev/null
+++ b/gnome-extra/cjs/cjs-6.0.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit flag-o-matic meson pax-utils python-any-r1 virtualx
+
+DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
+HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
+SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
+SLOT="0"
+IUSE="+cairo examples readline sysprof test"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-lang/spidermonkey:102
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gobject-introspection-1.71.0:=
+ >=dev-libs/libffi-3.3:0=
+
+ cairo? (
+ x11-libs/cairo[glib,svg(+),X]
+ x11-libs/libX11
+ )
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
+ test? (
+ sys-apps/dbus
+ x11-libs/gtk+:3[introspection]
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ python_fix_shebang build
+}
+
+src_configure() {
+ append-cppflags -DG_DISABLE_CAST_CHECKS
+
+ # On musl, it's required that either gjs, pixman or gnome-shell to be built
+ # with a larger stack otherwise librsvg fails to render a particular SVG, as
+ # a result we fail to get gdm or gnome-shell running (greeted with a fail
+ # whale screen). The bug has been reported to librsvg. This is ideally just
+ # a temporary workaround until we understand what exactly needs a larger
+ # stack size, as it's not sufficient to do just librsvg.
+ #
+ # Please refer to:
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
+ # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
+ #
+ # TODO: Find an actual fix instead of increasing the stack
+ use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
+
+ local emesonargs=(
+ $(meson_feature cairo)
+ $(meson_feature readline)
+ $(meson_feature sysprof profiler)
+ -Dinstalled_tests=false
+ $(meson_use !test skip_dbus_tests)
+ $(meson_use !test skip_gtk_tests)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+src_install() {
+ meson_src_install
+
+ if use examples; then
+ docinto examples
+ dodoc "${S}"/examples/*
+ fi
+
+ # Required for cjs-console to run correctly on PaX systems
+ pax-mark mr "${ED}/usr/bin/cjs-console"
+}