summaryrefslogtreecommitdiff
path: root/gnome-base/libgtop/libgtop-2.34.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /gnome-base/libgtop/libgtop-2.34.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'gnome-base/libgtop/libgtop-2.34.2.ebuild')
-rw-r--r--gnome-base/libgtop/libgtop-2.34.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnome-base/libgtop/libgtop-2.34.2.ebuild b/gnome-base/libgtop/libgtop-2.34.2.ebuild
new file mode 100644
index 000000000000..acafa2277c42
--- /dev/null
+++ b/gnome-base/libgtop/libgtop-2.34.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A library that provides top functionality to applications"
+HOMEPAGE="https://git.gnome.org/browse/libgtop"
+
+LICENSE="GPL-2"
+SLOT="2/10" # libgtop soname version
+KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}