summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-shell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-04 21:35:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-04 21:35:21 +0100
commit64ae9c18e99cfcf94f587b8adc9bf9aae3f6d1fb (patch)
treede7ceb1d046ef65ab7bd35b7eca8da219395a4be /gnome-base/gnome-shell
parentbb8c9132545ddf1e366b0b478c0dc89c56cf6dcd (diff)
gentoo auto-resync : 04:06:2023 - 21:35:20
Diffstat (limited to 'gnome-base/gnome-shell')
-rw-r--r--gnome-base/gnome-shell/Manifest2
-rw-r--r--gnome-base/gnome-shell/gnome-shell-44.2.ebuild182
2 files changed, 184 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index 185e82c01076..902dccf0d397 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -1,4 +1,6 @@
AUX 40.0-defaults.patch 1412 BLAKE2B e36f7215cf756586479b8bdc71339beb3bbde53ca9745ddc4ef1c3feb59c720e4920e8aa4aadd7912874c386e7495a4b5d554e0d0616db17a81c4ec52a2baa6b SHA512 d82cf1e329d5974755738e29e6366bb10452620021a5db6c2ec63c4ee38e87a65dada34d57026e9510dbffa78c7060ae6f2ccec1739e3026bb0c67dab95f94a9
DIST gnome-shell-44.1.tar.xz 1994844 BLAKE2B fa268b7c98db881dc3b397405128d001d354c9b67c7cf8b129c49ac9bb44a80b79fbdb0fcaca286e14b1bc58df72f722ff293104817b636aff97e5578849b985 SHA512 f21211e5e5146b885345d3e1a99702a3119e4dfc25860fe4f7bdbc3a04db2480f03f4e9898e46e4485048035584cbbcf6ef17c396b857c194ad5645aa7d78be7
+DIST gnome-shell-44.2.tar.xz 1995456 BLAKE2B 05c75e8c01395c81065206cc74ea80e2aff906c4b2fca618696a7972ca45da0e8e39cd099f91eb2d18fdb411f1efdc8c5008b8678617b347164c557f5b61874c SHA512 10301a1bfd00011867e4b810d8baf7b3ac4aeeff8b1e0e7cc3384bbfe30d26ac335e110e5e3a5c954976030ac1e12835fb581a728e23945587a0689e95ae0aa2
EBUILD gnome-shell-44.1.ebuild 6412 BLAKE2B 6ddba2ccc82c218e364888acb44155cb79c82c311b65fc5b5fb35ffe7e43c3ff861ac5549ba07af2e225a40ad506708d7c141f85faa37c0ca6a83fa3230f801b SHA512 ba3e5b091bd03e294af73e92386a2fc10815525d642e38b2e409152a141e2fa9f41ba93b0dba00e7e6e191b22fec508d2097e8f99239ed5b2775693bdd6b904c
+EBUILD gnome-shell-44.2.ebuild 6415 BLAKE2B 8335fef603026a081ad10347bd88b6e5457b6544b0121b800924a21a1d70a5e75f60412a93e2fe5b93eeb626b6ded2b159ac35d58237c3e7a8c214b16e88cad8 SHA512 b9a18319c29bcdddf69b6d9d729e77b164242a14e9656bb9d09a537b62d4d0e5ed289d34e889a552114fd0e8e54e52959478a9803a505991cdc903221147423b
MISC metadata.xml 957 BLAKE2B d2325c60974cb52f548436df192a77963b5353cbda67f65b9966829d2d5c4159c73bfc8f686255050546a9b384864d3ce9b6c9cd9d26d2d301fa78d50d5c8d9d SHA512 abe6d6768f8c4e090c0fc8d494c00551e76dd2b7409a99c8bf59d8353966dde305ce9fc0c1712d87c2e342a5e7b75b1f9ad7972e2a2bd0a6c0cb598a859cd13e
diff --git a/gnome-base/gnome-shell/gnome-shell-44.2.ebuild b/gnome-base/gnome-shell/gnome-shell-44.2.ebuild
new file mode 100644
index 000000000000..638f1c5e3c69
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-44.2.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome.org gnome2-utils meson optfeature python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell https://gitlab.gnome.org/GNOME/gnome-shell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind gtk-doc +ibus +networkmanager systemd test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+DEPEND="
+ >=gnome-extra/evolution-data-server-3.46.0:=
+ >=app-crypt/gcr-3.90.0:4=[introspection]
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.73.1[cairo]
+ >=x11-libs/gtk+-3.15.0:3[introspection]
+ >=x11-wm/mutter-44.0:0/12[introspection,test?]
+ >=sys-auth/polkit-0.120_p20220509[introspection]
+ >=gnome-base/gsettings-desktop-schemas-42_beta[introspection]
+ >=x11-libs/startup-notification-0.11
+ >=app-i18n/ibus-1.5.19
+ >=gnome-base/gnome-desktop-40.0:4
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4[introspection]
+ net-libs/libnma[introspection]
+ >=app-crypt/libsecret-0.18
+ dev-libs/dbus-glib
+ )
+ systemd? (
+ >=sys-apps/systemd-242:=
+ >=gnome-base/gnome-desktop-3.34.2:3=[systemd]
+ )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ app-arch/gnome-autoar
+ dev-libs/json-glib
+
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-libs/libpulse-2[glib]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ gui-libs/gtk:4[introspection]
+
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ media-libs/libglvnd[X]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated from inspection of the output of:
+# for i in `rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- |sort -u`; do echo $i ;done |cut -d, -f1 |sort -u
+# or
+# rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- | sed -e 's:[{}]::g' | awk '{$1=$1; print}' | awk -F',' '{$1=$1;print}' | tr ' ' '\n' | sort -u | sed -e 's/://g'
+# These will give a lot of unnecessary things due to greedy matching (TODO), and `(?s).*?` doesn't seem to work as desired.
+# Compare with `grep -rhI 'imports.gi.versions' |sort -u` for any SLOT requirements
+# Each block:
+# 1. Introspection stuff needed via imports.gi (those that build time check may be listed above already)
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. xdg-utils needed for xdg-open, used by extension tool
+# 5. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 6. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 7. IBus is needed for nls integration
+# 8. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 9. xdg-desktop-portal-gtk for various integration, e.g. #764632
+# 10. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue[introspection]
+ media-libs/graphene[introspection]
+ x11-libs/pango[introspection]
+ net-libs/libsoup:3.0[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ gnome-base/librsvg:2[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data
+ )
+ ibus? ( >=app-i18n/ibus-1.5.26[gtk3,gtk4,introspection] )
+ media-fonts/cantarell
+
+ sys-apps/xdg-desktop-portal-gnome
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection(+)]
+ >=gnome-base/gnome-control-center-3.26[networkmanager(+)?]
+"
+BDEPEND="
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17
+ app-text/docbook-xml-dtd:4.5 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( x11-wm/mutter[test] )
+"
+# These are not needed from tarballs, unless stylesheets or manpage get patched with patchset:
+# dev-lang/sassc
+# app-text/asciidoc
+
+PATCHES=(
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/40.0-defaults.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # Hack in correct python shebang
+ sed -e "s:python\.full_path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dextensions_tool=true
+ -Dextensions_app=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use test tests)
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration and desktop file user services related property only as of 3.34.4
+ # (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ -Dsoup2=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ optfeature "Bluetooth integration" gnome-base/gnome-control-center[bluetooth] net-wireless/gnome-bluetooth:3[introspection]
+ optfeature "Browser extension integration" gnome-extra/gnome-browser-connector
+ optfeature "Screencast/capture support" media-video/pipewire media-libs/gstreamer[introspection] media-libs/gst-plugins-base[introspection] media-libs/gst-plugins-good media-plugins/gst-plugins-vpx
+ optfeature "Weather support" dev-libs/libgweather:4[introspection]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}