summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-light
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /gnome-base/gnome-light
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'gnome-base/gnome-light')
-rw-r--r--gnome-base/gnome-light/Manifest1
-rw-r--r--gnome-base/gnome-light/gnome-light-3.36.5.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/gnome-base/gnome-light/Manifest b/gnome-base/gnome-light/Manifest
index 382b321c8877..ac703925a9ee 100644
--- a/gnome-base/gnome-light/Manifest
+++ b/gnome-base/gnome-light/Manifest
@@ -1,2 +1,3 @@
EBUILD gnome-light-3.34.4.ebuild 2060 BLAKE2B 1b60f2198f285e4c5bf9682aec0cf2bffcd95e349c0e24cc82b1b3f16be506c4322c1acf1d5d63c53b6256f5f4bb256da67133f53ce0affbb49ed30b97b2cbbb SHA512 5593d45f556ad1761cc8039c0b2a412485f1bd5eeec4df6bbd69afe11e3215a7d6adc52aad0757f4c6fdab49568ebf1a7d882f48cf4191f7dbe2f46b443bf7fa
+EBUILD gnome-light-3.36.5.ebuild 1972 BLAKE2B 01ea614087906c40900dbea6692b0689a32e6e19b65e1abb0d593c762b5a2a0b9cf8cb085a9421aeb41694631da72775ef562c45f48ce5e4d2ceefd7e689a717 SHA512 52b32c5e225a4de4ef9be2bc4360bda328142745382702aca20bf3a8604e7e9bd844a82132e2e4b29802369e6e77fdea729f77677d87bc6fe87ef9e342fa9331
MISC metadata.xml 406 BLAKE2B 562a281deb064ec0aa74ffebe4e38c864746809724acc4522df8c9cc0590d80937836923a029e521c5a0eec83adda11f169fa554e9760128408b78e87d916f26 SHA512 04875558c048cf102d8e5ffb17cb363808ca84c350f9b03958536cc5185cfd109b4653bbb4de202f47d092f8fc6d15173d3453a3bc62aa431b0c83cbb699a047
diff --git a/gnome-base/gnome-light/gnome-light-3.36.5.ebuild b/gnome-base/gnome-light/gnome-light-3.36.5.ebuild
new file mode 100644
index 000000000000..c3b29d3732c8
--- /dev/null
+++ b/gnome-base/gnome-light/gnome-light-3.36.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+P_RELEASE="$(ver_cut 1-2)"
+
+DESCRIPTION="Meta package for GNOME-Light, merge this package to install"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="2.0"
+IUSE="cups +gnome-shell"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+
+# XXX: Note to developers:
+# This is a wrapper for the 'light' GNOME 3 desktop, and should only consist of
+# the bare minimum of libs/apps needed. It is basically gnome-base/gnome without
+# any apps, but shouldn't be used by users unless they know what they are doing.
+# cantarell minimum version is ensured here as gnome-shell depends on it.
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}[cups?]
+
+ >=gnome-base/gnome-session-3.36.0
+ >=gnome-base/gnome-settings-daemon-3.36.1[cups?]
+ >=gnome-base/gnome-control-center-3.36.4[cups?]
+
+ >=gnome-base/nautilus-3.36.3
+
+ gnome-shell? (
+ >=x11-wm/mutter-${PV}
+ >=dev-libs/gjs-1.64.4
+ >=gnome-base/gnome-shell-${PV}
+ >=media-fonts/cantarell-0.201 )
+
+ >=x11-themes/adwaita-icon-theme-3.36.1
+ >=x11-themes/gnome-themes-standard-3.28
+ >=x11-themes/gnome-backgrounds-${P_RELEASE}
+
+ >=x11-terms/gnome-terminal-3.36.2
+"
+# adwaita-icon-theme kept back on purpose due to brokenness without rust librsvg,
+# in the hope that the old icon package version is good enough for everything too
+# until librsvg gets updated. This dep should be raised to 3.34 with 3.34.5 meta.
+DEPEND=""
+PDEPEND=">=gnome-base/gvfs-1.44.1"
+BDEPEND=""
+S="${WORKDIR}"
+
+pkg_pretend() {
+ if ! use gnome-shell; then
+ # Users probably want to use gnome-flashback, e16, sawfish, etc
+ ewarn "You're not installing GNOME Shell"
+ ewarn "You will have to install and manage a window manager by yourself"
+ fi
+}
+
+pkg_postinst() {
+ # Remember people where to find our project information
+ elog "Please remember to look at https://wiki.gentoo.org/wiki/Project:GNOME"
+ elog "for information about the project and documentation."
+}