summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-25 19:33:39 +0100
commita5b65c81168c90928784a1e92cda84ed5d6b9eb3 (patch)
tree4aa7483cd0ad7de54338afc8e7971417abe1dd81 /gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild
parente8f81810baa21f490d6910e8e2d424546b72a333 (diff)
gentoo resync : 25.09.2019
Diffstat (limited to 'gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild')
-rw-r--r--gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild b/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild
new file mode 100644
index 000000000000..5fdcc803674c
--- /dev/null
+++ b/gnome-base/gnome-core-libs/gnome-core-libs-3.32.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Sub-meta package for the core libraries of GNOME 3"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="cups python"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Note to developers:
+# This is a wrapper for the core libraries used by GNOME 3
+RDEPEND="
+ >=dev-libs/glib-2.60.2:2
+ >=x11-libs/gdk-pixbuf-2.38.1:2
+ >=x11-libs/pango-1.42.4
+ >=x11-libs/gtk+-3.24.8:3[cups?]
+ >=dev-libs/atk-2.32.0
+ >=gnome-base/librsvg-2.40.20
+ >=gnome-base/gnome-desktop-${PV}:3
+ >=x11-libs/startup-notification-0.12
+
+ >=gnome-base/gvfs-1.40.1
+ >=gnome-base/dconf-0.32.0
+
+ >=media-libs/gstreamer-1.14.4:1.0
+ >=media-libs/gst-plugins-base-1.14.4:1.0
+ >=media-libs/gst-plugins-good-1.14.4:1.0
+
+ python? ( >=dev-python/pygobject-3.32.1:3 )
+"
+DEPEND=""
+BDEPEND=""
+
+# >=x11-libs/libwnck-3.24.1:3 - not used by core packages anymore
+# librsvg kept back on non-rust version; should move on at some point for non-exotic arches.
+
+S="${WORKDIR}"