summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-applets
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
commitad75ca50360f9590325f0f709c091832b70eab1d (patch)
tree8a0b109f05da2a3728e461abf6e31347c2e8b0b2 /gnome-base/gnome-applets
parent7b5e4e1f63da7fb63fba5f1a9fc41866c8ae5b2f (diff)
gentoo auto-resync : 08:10:2022 - 01:28:43
Diffstat (limited to 'gnome-base/gnome-applets')
-rw-r--r--gnome-base/gnome-applets/Manifest2
-rw-r--r--gnome-base/gnome-applets/gnome-applets-3.46.0.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/gnome-base/gnome-applets/Manifest b/gnome-base/gnome-applets/Manifest
index fb7b66249982..f467a18ee6cf 100644
--- a/gnome-base/gnome-applets/Manifest
+++ b/gnome-base/gnome-applets/Manifest
@@ -1,3 +1,5 @@
DIST gnome-applets-3.44.0.tar.xz 9396928 BLAKE2B 03fb970e4ebe7747aed9241e7512c6fe945650ac789cac5c5bc1e49958b1636f43b59c56caaf24a01785c84617cef4c9b3fa76931ed46d6f3ea8c4b74335ca1b SHA512 8a9a75590e96d0ef6af4775d261337b41b23779b86d38080014f49666fdaee68bc9ef58eeae94e87c43bd07b0b0720b867f03f2c2d0f2d8b7daea3c66251fc7e
+DIST gnome-applets-3.46.0.tar.xz 9248780 BLAKE2B 5bc61dbbb2f6a7c96a9ad6895936996025bfc6d99ac29ff552e62e5061866b1ef30384d6adecefee933cbb533184a47cb6c40c5c8c7562d4892817aa73628dab SHA512 826abf56f76925f0246b49194b09ec9ae43963c43e3f861269ab839c08823bb2b8b1b47cd20a93495bfef0d4220ef579190f0dd491c3cb2ed70fdd0483b1f007
EBUILD gnome-applets-3.44.0-r1.ebuild 1381 BLAKE2B 07bacca2ce92f025ded74c9d8c879f56a4be2f7298a3b55071c7ecc527a3fc619729bfa0a247bdf71117fcc8be25eb4a8f556d60ea3796c391f23a0fe18c87fd SHA512 31bd90e4b209df51dcace443651885faf577ed084c4e29af9749555d1664bbae8b55fc800e7b3f66da484c00984e6d1ca3749abe6bf9d9027b1d57031d5e320c
+EBUILD gnome-applets-3.46.0.ebuild 1293 BLAKE2B bd323cf001c8e5e043cee866fd73db854c260d18d1ea8887e49546a6ef91b0b4c3aa92595b8f442f8afcc6c6f50a6f1191aa0b80b3a5046d26f7a651df6ca729 SHA512 4989c59c3849fcb217f5e761c6b4779e4c8490c2681ebfc9a8a45b761d1a0799b31956bde4b7115a3186602e4d7fc816988dc11596bf5919f9341bdcb630708b
MISC metadata.xml 328 BLAKE2B 23e54626993373e58fbb0718c51e2b9c4eafcd7a0f2cd3968d05b72bc6a3cebeec386d96ab317cc92a17f08d17f8cb9091d6c47d4e6af49993451dd98b8aa04c SHA512 b4936e6332bbd5de094ec96060c84aa6eecc737260a093dc01da4687f68994a5a622eec0b3fce353abfb851b90c31ce7b0ee93e330d6ae2f4b288ab104655463
diff --git a/gnome-base/gnome-applets/gnome-applets-3.46.0.ebuild b/gnome-base/gnome-applets/gnome-applets-3.46.0.ebuild
new file mode 100644
index 000000000000..071ee2a00c9e
--- /dev/null
+++ b/gnome-base/gnome-applets/gnome-applets-3.46.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="Applets for the GNOME Flashback Panel"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-applets/"
+
+LICENSE="GPL-2+ FDL-1.1"
+SLOT="0"
+IUSE="tracker"
+KEYWORDS="~amd64 ~riscv"
+
+# FIXME: automagic wireless-tools
+# TODO: gucharmap could be optional, but no knob
+# TODO: libgweather could be optional, but no knob
+RDEPEND="
+ >=x11-libs/gtk+-3.20.0:3[X]
+ >=dev-libs/glib-2.44.0:2
+ >=gnome-base/gnome-panel-3.41.1
+ >=gnome-base/libgtop-2.11.92:=
+ >=x11-libs/libwnck-43.0:3
+ >=x11-libs/libnotify-0.7
+ >=sys-power/upower-0.99.8:=
+ >=x11-themes/adwaita-icon-theme-3.14.0
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/libgweather-4.2.0:4=
+ >=gnome-extra/gucharmap-2.33.0:2.90
+ >=sys-auth/polkit-0.97
+ x11-libs/libX11
+ tracker? ( app-misc/tracker:3 )
+ >=x11-libs/pango-1.50.0
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+" # yelp-tools and autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-cpufreq \
+ $(use_enable tracker tracker-search-bar)
+}