summaryrefslogtreecommitdiff
path: root/gnome-base/dconf-editor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /gnome-base/dconf-editor
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'gnome-base/dconf-editor')
-rw-r--r--gnome-base/dconf-editor/Manifest2
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 1999166c058e..b96dd657a011 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1,3 +1,5 @@
DIST dconf-editor-3.36.4.tar.xz 583084 BLAKE2B 7d7f5164a4917d13372a2bcf7f9fe7b82d630693601bba33da1c4f3afffa58e4589ff90c3e5ca3039351a681eac6584b335171f4dce9d0bfedaed52cc25d505c SHA512 a24fa44830fb0e83834cf912267de6597c1d6bf02e063af4255409d3c9a135fae409116d91751d00ee8d2319e7130606f007af76d3ec9f1380cda98ab2329eff
+DIST dconf-editor-3.38.2.tar.xz 593428 BLAKE2B 6adb53cf2326d25b31d483645df9c2883658d525a32d1eb0ea13d410724911fbeb2ba17a948e4cca5e6a19e187d3cabf0a5722f7aae4dc70bc6699c13be9adc0 SHA512 64bcf7c5cea2c70f2c4ee08832490495c8c2dfee805d6fc27583e1369444f81ef9818f83de7c71228c88322f32c258c4550cc908263f1bb3032ab67e514efb2b
EBUILD dconf-editor-3.36.4.ebuild 813 BLAKE2B e65391c443fecf58357d0a5e4af977e1dc6f62112bb19304613a6c34f41277962c1141053dfbb2fb5f9f0911e119c1238a1a0d8249763164f058e5334de161e9 SHA512 ac96d459b704a45e856a9a1cab563a00996079cf004f197b4b5aad65d3e64f1587918844ea87a8f0642322d8566838b686eab6af309aabf84160ba313be96a22
+EBUILD dconf-editor-3.38.2.ebuild 815 BLAKE2B d1cca311a344ba79f7a4f74a65e01ddc31fb5d6116e2d30459dd42d702b3fc769aa77f94f34fccf06d8fc18c52994b662e6e5d2472066acd9e7308456c00c972 SHA512 828b65a4d05469af3b279638fe0d0b1d48b8d4eecb45e311a69cb5fd5f795255a432349d7f0e8d009087888cf44ad30224f1215b7356f316ea19a4cb39226ee7
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild b/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild
new file mode 100644
index 000000000000..21fa99568f71
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}