summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-13 11:36:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-13 11:36:00 +0000
commitc06ab4b7bc60f01a7bd8c233ba4697157f30315f (patch)
tree85da2c94693d575c9324ab8f1616170ef5c928a9 /games-util
parent9e166f0fa8bc64fb267aaba88d9a55f8393e15a0 (diff)
gentoo auto-resync : 13:02:2024 - 11:36:00
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin8234 -> 8236 bytes
-rw-r--r--games-util/xpadneo/Manifest4
-rw-r--r--games-util/xpadneo/xpadneo-0.9.6.ebuild54
-rw-r--r--games-util/xpadneo/xpadneo-9999.ebuild21
4 files changed, 58 insertions, 21 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 24080f43b369..9430c27b5e13 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
index 6b493e8c9022..b696d3457465 100644
--- a/games-util/xpadneo/Manifest
+++ b/games-util/xpadneo/Manifest
@@ -1,4 +1,6 @@
DIST xpadneo-0.9.5.tar.gz 1341366 BLAKE2B d04a3e1b626af1f1a9ec114f0a8ed44c50ec8cde9da71483491d1afd7688611fd7548186ea68ef8a144aecec06acba816e81e9f0708c8dceb96fa1d40985bb44 SHA512 e7e299faf78c139d4cd189c4adc9bcbd52e1e1011ff90513cc09fc3e6cac1961018883933ad1db23dc02c8d5006f3166fbb42ae66150dff71138f2ed95f4576c
+DIST xpadneo-0.9.6.tar.gz 1344171 BLAKE2B 22a85732de2894d310e0994c101ed62b7358f1b6b8ba5b389fc273bfd48a1ce619ebc04f3699818290f61833234d4c444fff25ea852d9dcf420b99ab28687a03 SHA512 f423fb89cf911c727917591d79909acaecc9fdb68ca10c5cc2a128bd66174799f3efb2b9a87e43bb315ab92ddb7513f79300f06d347fabc9de11e63fc1d25689
EBUILD xpadneo-0.9.5-r1.ebuild 2241 BLAKE2B 8359f50c4143116978da5e7d9bbdf4d8ce42dbc1bb3ded72f999bde09dad4386f2aa1d26cc55e64e7babe08d0214ee0a8ad7c138851d7820e7b9b868228613ab SHA512 f6b97dfcd40da83b30ed7d79fbf228b0c1a6b547c543fb8843df0686b1e09569100e9aab72eb86cc7f11f246d7e11db2984a72cbce1714689bef44adc8fb19e6
-EBUILD xpadneo-9999.ebuild 2242 BLAKE2B adc4ea5a8027aa7d49e6eabd3f753bc1fb927cf5fe96cbada7b5308606b241a35debd6bce3d08f91f8d18cd7eb5c99c0b9d078503c7f0f3fc41b65c56dd9acd6 SHA512 e90ac03fcde8a74038e7c49c3d3a932b5107ded519351002534917beaa6451751c3d13ac48862e143de875aed817561ccaeb931dec787ff54e281adeec68d615
+EBUILD xpadneo-0.9.6.ebuild 1222 BLAKE2B 6b2a1f8faaaeebc3f406f53bc9b5eb6ce6fd8a00c5d15c7ddc2bd4a44cd49dd44d26a7cb1bbacba54872ea61018680e211c00135dcf2e727e5e9b73b9a949631 SHA512 5a0fb0b032dbc825fdffec1298614de19027900d6c38ce7eb5c0f4ecb1716108462ca3ec5a0cf862cf1f824c066c72e73405d760e82c2b2985b55868afc84e77
+EBUILD xpadneo-9999.ebuild 1222 BLAKE2B 6b2a1f8faaaeebc3f406f53bc9b5eb6ce6fd8a00c5d15c7ddc2bd4a44cd49dd44d26a7cb1bbacba54872ea61018680e211c00135dcf2e727e5e9b73b9a949631 SHA512 5a0fb0b032dbc825fdffec1298614de19027900d6c38ce7eb5c0f4ecb1716108462ca3ec5a0cf862cf1f824c066c72e73405d760e82c2b2985b55868afc84e77
MISC metadata.xml 328 BLAKE2B 6511430d43b855d83d42dc94ea83bf20867568e9dbf642240ac279179d9f26d0a315f3fb90bebd4a564d4bc63beefcb8aa24af7acf25a60f9b25f732265de41b SHA512 defbfc601b6b61d10edf8947e2251f96416787a1141fccff1e017a6110eb4d8e8801fcd72cc678f816064eb5a5dc796c9c895ca9f74ad288f1338ccaaf3ee5c8
diff --git a/games-util/xpadneo/xpadneo-0.9.6.ebuild b/games-util/xpadneo/xpadneo-0.9.6.ebuild
new file mode 100644
index 000000000000..d57edd3bce17
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-0.9.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 udev
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
+ EGIT_MIN_CLONE_TYPE="single"
+else
+ SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_compile() {
+ local modlist=( hid-${PN}=kernel/drivers/hid:hid-${PN}:hid-${PN}/src )
+ local modargs=( KERNEL_SOURCE_DIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ local DOCS=( docs/{[^i]*.md,descriptors,reports} NEWS.md )
+ linux-mod-r1_src_install
+
+ insinto /etc/modprobe.d
+ doins hid-${PN}/etc-modprobe.d/${PN}.conf
+
+ udev_dorules hid-${PN}/etc-udev-rules.d/60-${PN}.rules
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+ udev_reload
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}/"
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/games-util/xpadneo/xpadneo-9999.ebuild b/games-util/xpadneo/xpadneo-9999.ebuild
index c1de2e3d642d..d57edd3bce17 100644
--- a/games-util/xpadneo/xpadneo-9999.ebuild
+++ b/games-util/xpadneo/xpadneo-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -43,25 +43,6 @@ pkg_postinst() {
linux-mod-r1_pkg_postinst
udev_reload
- local disable_ertm=/sys/module/bluetooth/parameters/disable_ertm
- if kernel_is -ge 5 12; then
- if [[ $(<${disable_ertm}) == Y ]]; then
- elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is disabled."
- elog "This is no longer recommended with kernel >=5.12 to use ${PN}."
- elog "Can remove ${EROOT}/etc/modprobe.d/no-ertm.conf if it exists, and run:"
- elog " echo N > ${disable_ertm}"
- elog "After changing, may need to re-pair the gamepad with bluetooth."
- fi
- elif [[ $(<${disable_ertm}) == N ]]; then
- elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is enabled."
- elog "While keeping enabled is recommended for rumble usage stability, it can"
- elog "cause connection issues without a fix included in kernel >=5.12"
- elog "If needed, this mode can be disabled by running:"
- elog " echo Y > ${disable_ertm}"
- elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
- elog "After changing, may need to re-pair the gamepad with bluetooth."
- fi
-
if [[ ! ${REPLACING_VERSIONS} ]]; then
elog "To pair the gamepad and view module options, see documentation in:"
elog " ${EROOT}/usr/share/doc/${PF}/"