summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /games-util
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7856 -> 7861 bytes
-rw-r--r--games-util/gamemode/Manifest3
-rw-r--r--games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch39
-rw-r--r--games-util/gamemode/gamemode-1.6.1.ebuild2
4 files changed, 43 insertions, 1 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index a2f3d89dc372..cd66a63a324f 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
index 50f9701b7c8d..0873559efbcf 100644
--- a/games-util/gamemode/Manifest
+++ b/games-util/gamemode/Manifest
@@ -1,4 +1,5 @@
+AUX gamemode-1.6.1-signal_h-musl.patch 1401 BLAKE2B 5bb5ad906fdb2b08aff804986c97396f1886009ce6603ffc9fdeaac4c4470f0937cc4abda04e084ccdd1245e942d456c1efc98a7a8e7ab6914d2ef1ff9d97fe9 SHA512 0c0059c8e19b564e6228def6485522e66338e23ecd981644e72f92a5e5962d269235d92606ef13680820fce389552e6a23ba93fc9126c794d5da7fee0b670013
DIST gamemode-1.6.1.tar.xz 71224 BLAKE2B aafa3123a2c672197d28fafbc7331004b6e4c87808e831f5e0341fd9a690acda8305da114651391fe39e6702bac805cede9d696280d03d4cc3d03d6f4d782efd SHA512 99403a68675522d3b412424591ab7f0cef54968a699f8f68aa59a42a43df73db4bc8a84ee8f97b9f78f329ecd1ed2f3a50e3cb539458f23e7c5fbe28f7978e47
-EBUILD gamemode-1.6.1.ebuild 3968 BLAKE2B 33ec5cfbbecf4efd06696a6401fc87549cb9a12e796555647754148c50091a2beebebe70d257489f2991339a8da39799d628571668a2488fecae0f48f7399aaf SHA512 76b58596849cbafc891881c6d439b3e707db7e09baf76662dec59cda397666632f7621324d8e6d87638088a5d1412df2f654d6aeed35d8806a6a347df6f6701f
+EBUILD gamemode-1.6.1.ebuild 4027 BLAKE2B 9518f7a6b66a6f7f18cfb2a4e9795c148ee1c1da01c14210b2ad590b066bef1ce5c003f82b52d49035682de18022f1fcb9c0c0ef0f188c92bef4ab43e3841d25 SHA512 36e4e09521633239399131640e6f87e0f387073a36284ac79d6bb69ce578f132937c08cad7c48afa782c3b2427cfce539a37dac4fd7387e2876d18b77099d39b
EBUILD gamemode-9999.ebuild 3968 BLAKE2B 33ec5cfbbecf4efd06696a6401fc87549cb9a12e796555647754148c50091a2beebebe70d257489f2991339a8da39799d628571668a2488fecae0f48f7399aaf SHA512 76b58596849cbafc891881c6d439b3e707db7e09baf76662dec59cda397666632f7621324d8e6d87638088a5d1412df2f654d6aeed35d8806a6a347df6f6701f
MISC metadata.xml 561 BLAKE2B c4e2e040e853956f7c587f9933a6791d1742027d9291512c1073fb143b315056cd1c173c517213d62a2169149ae9079fed014c54d2bfff81d946f2c7987511c9 SHA512 a1020dc2ae103ef138f6de356fbc47772bf7ab256d4dfe3cad2880b49b7cffdb9894fc2d40f9996bb64a5c88b00779584b8e6976338f9c9f4d835ea15d0460f8
diff --git a/games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch b/games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch
new file mode 100644
index 000000000000..8689157969bc
--- /dev/null
+++ b/games-util/gamemode/files/gamemode-1.6.1-signal_h-musl.patch
@@ -0,0 +1,39 @@
+https://github.com/FeralInteractive/gamemode/pull/368
+
+From 4079d246805e9ce6c1f5ee49116013eb9f5225d7 Mon Sep 17 00:00:00 2001
+From: Alfred Persson Forsberg <cat@catcream.org>
+Date: Tue, 5 Jul 2022 17:18:19 +0000
+Subject: [PATCH] Fix build on musl libc
+
+This simple patch includes signal.h in daemon/gamemode-context.c to fix building gamemode on musl
+libc.
+
+This has been tested Gentoo musl and Alpine (also Gentoo glibc to
+ensure no multiple defined symbols/other errors for glibc).
+
+> ../daemon/gamemode-context.c: In function 'game_mode_context_auto_expire':
+> ../daemon/gamemode-context.c:421:29: error: implicit declaration of function 'kill' [-Werror=implicit-function-declaration]
+> 421 | if (kill(client->pid, 0) != 0) {
+> | ^~~~
+> ../daemon/gamemode-context.c:421:29: warning: nested extern declaration of 'kill' [-Wnested-externs]
+
+Signed-off-by: Alfred Persson Forsberg <cat@catcream.org>
+---
+ daemon/gamemode-context.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/daemon/gamemode-context.c b/daemon/gamemode-context.c
+index 3b5a61b..feba2b1 100644
+--- a/daemon/gamemode-context.c
++++ b/daemon/gamemode-context.c
+@@ -45,6 +45,7 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include <assert.h>
+ #include <fcntl.h>
+ #include <pthread.h>
++#include <signal.h>
+ #include <stdatomic.h>
+ #include <stdlib.h>
+ #include <sys/time.h>
+--
+2.35.1
+
diff --git a/games-util/gamemode/gamemode-1.6.1.ebuild b/games-util/gamemode/gamemode-1.6.1.ebuild
index 1c2a2df1c374..1db1b4752c61 100644
--- a/games-util/gamemode/gamemode-1.6.1.ebuild
+++ b/games-util/gamemode/gamemode-1.6.1.ebuild
@@ -42,6 +42,8 @@ DOCS=(
example/gamemode.ini
)
+PATCHES=( "${FILESDIR}/${PN}-1.6.1-signal_h-musl.patch" )
+
pkg_pretend() {
elog
elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"