summaryrefslogtreecommitdiff
path: root/games-util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /games-util
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'games-util')
-rw-r--r--games-util/Manifest.gzbin7388 -> 7378 bytes
-rw-r--r--games-util/springlobby/Manifest2
-rw-r--r--games-util/springlobby/springlobby-0.267.ebuild54
-rw-r--r--games-util/xboxdrv/Manifest11
-rw-r--r--games-util/xboxdrv/files/github-144.patch15
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch16
-rw-r--r--games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch13
-rw-r--r--games-util/xboxdrv/files/xboxdrv.udev-rules2
-rw-r--r--games-util/xboxdrv/metadata.xml10
-rw-r--r--games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild (renamed from games-util/xboxdrv/xboxdrv-0.8.8.ebuild)58
10 files changed, 105 insertions, 76 deletions
diff --git a/games-util/Manifest.gz b/games-util/Manifest.gz
index 41f524a161eb..923ed7f45ee9 100644
--- a/games-util/Manifest.gz
+++ b/games-util/Manifest.gz
Binary files differ
diff --git a/games-util/springlobby/Manifest b/games-util/springlobby/Manifest
index 3b5e9aabd0fd..03373294acef 100644
--- a/games-util/springlobby/Manifest
+++ b/games-util/springlobby/Manifest
@@ -1,3 +1,5 @@
DIST springlobby-0.266.tar.bz2 2642384 BLAKE2B 93444df4e139a657dc5d87b0ea9e796bd025259663693de9dcb04760ee611674546170813d71406e94aa456834cc96c8bc811ee5cf65b0bd0199cf66b4a51a50 SHA512 dc1a5e408515cb82004bf66bc014ebdd451eaea07d3543094cec494beb6d87165bdc0ac3672d6474a13d1918b1405507ee97ead05b9f1663789416b072aa6d6b
+DIST springlobby-0.267.tar.bz2 2642229 BLAKE2B 591eddda344ea4ce4ed7cad433bd7d46c7b2e727d7f97c07541cc00c6991fb1a9a62e8980f6a0249e6a509e475fe300aeb040ff1886f2da77b176b52d196db90 SHA512 6127bd7377f9a843b23df6dae7a07af1122f6ec5fa13cd8d16c0c7a3cc84e1f7af2fb7df929f904ee0b4e3abf12ae1e525ffb39b2afa0215433209054cf0de5f
EBUILD springlobby-0.266.ebuild 1069 BLAKE2B 1c7652169a03cc51e5d7891ecf1d2fc9b7afa0d58b1c6b5fe94dd65992971d269a499b7951f689635a1e91e8f26e5e28c9f2e6fd4621ec1eb869b09ce12a04b0 SHA512 73cb9f0389d2a354ca7b6f620900f0798db6b94ae9aaffef9c47ea22b9843557795d9b8ae3ca1443ace21237fad463bec6cfce14400fd49df62d80b8bae04ad8
+EBUILD springlobby-0.267.ebuild 1069 BLAKE2B 1c7652169a03cc51e5d7891ecf1d2fc9b7afa0d58b1c6b5fe94dd65992971d269a499b7951f689635a1e91e8f26e5e28c9f2e6fd4621ec1eb869b09ce12a04b0 SHA512 73cb9f0389d2a354ca7b6f620900f0798db6b94ae9aaffef9c47ea22b9843557795d9b8ae3ca1443ace21237fad463bec6cfce14400fd49df62d80b8bae04ad8
MISC metadata.xml 1168 BLAKE2B 52a394c332bed809d549cf76a750a35cb0c0bcb6af1cf2276d81958abafa6272e58d59d07762929ef05ccece16d5465d5c353dd71974b4ec2657ae99e3d607a5 SHA512 901e3865f60e798625d59085e38e191a256819e5aa0778210190ebc0a08f183b263c3391409079c499a2e2cb6740503371642f0c13eec1e59a8699060c00b59c
diff --git a/games-util/springlobby/springlobby-0.267.ebuild b/games-util/springlobby/springlobby-0.267.ebuild
new file mode 100644
index 000000000000..cd52d8460241
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.267.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils gnome2-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.info"
+SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+ sound? ( media-libs/alure
+ media-libs/openal
+ )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-util/xboxdrv/Manifest b/games-util/xboxdrv/Manifest
index e28e31338358..edf5bf1bd221 100644
--- a/games-util/xboxdrv/Manifest
+++ b/games-util/xboxdrv/Manifest
@@ -1,11 +1,8 @@
-AUX github-144.patch 491 BLAKE2B d644c7af466ee4c0e661292509b614f6a36f69a2bdf2919a4fd26baf07571655f52681eb9787adaefb1f853fd31c71e8156a0df5e65d9e92e72ae531aa93c768 SHA512 058eb9515a74742d6aef1de3acc76b8731947fe4a3aa1179243d0b14cab5f978aef98d9b140371dd03a5165f96e167b1dc7297378545f266e887ea0b3188c79e
AUX org.seul.Xboxdrv.conf 247 BLAKE2B 0829d1e65203f56efc0442c798070cf8c9f6b53792b5eb4fd8cc0671068d5d66d281b2c53c5cdb06474b635c2c9c5076d3a64364afdffc87a0c1bf052015f9ff SHA512 1416e80d326481e224ce3381a8feeacf304107f945d787183c74118aae955e191cc89269e8de44d6ce4efc2502def6957b690e9bad70072fcf0bbd47c8ab12cc
-AUX xboxdrv-0.8.8-fix-c++14.patch 337 BLAKE2B 5fc250da71e11432c215fa42751be07a5eef37036a4a406601619f8b07554d9b349ba66196b84090e23d807687379b64710218d8b0b6c63036e189c2331a14c0 SHA512 97b504a0acf7fd52ef0f4accacd89e9211136809c7559bd8958d2b235d732df2659fb5b794512e2ff3aaf33f22d97e2f4b42187eab9406a36e7b6cb9fd651832
-AUX xboxdrv-0.8.8-scons.patch 584 BLAKE2B cbe8d12773b2f5c6051291fda2c8df23811d12c5440d7dd7f50777bdc01f474f971713ec513a245787a2b113e32cb03b202bf28619e96315fa2992edc21083cb SHA512 25b7b1e57f7ad9b48ad566c81b97b9354a353535564462e8c4b550190c920718165044508d28b3d5fee6155bb41752afbd8038fab59239c58e1aee82d62c5910
AUX xboxdrv.confd 211 BLAKE2B 7a79059b29edbfbde33fe3daf9c89346246ac4323d7053ea4b26b6dd1fff07d731f8f7faa6a79f152f76eb1722606655f1d8d1026a3a83b0520e1909915039db SHA512 4c8a784a18979746a45653244e451fe1ba9e7cbb14301cc18f58e474e51f7569177364c5a96cbe0275db2b359424febd27c040ede5820148aadb80e90ebf8178
AUX xboxdrv.initd 446 BLAKE2B f78cf4af5cca703efc0a480c2ba34b0189d2b86a64aa89533e59a4d325ca03592bc911a9c85ff1fe5801ef2ade537dcfcc7266052a77f64ff05dad5f43630167 SHA512 e87d4b4b4313cb4ae983aef4ab7fa799f6b466e0f504eb15905b82f5b8bca2f0ff6f3d9a7d9963c048b6189e2a4c4b862a3f39d4201c2f5f02234362ad7b3af1
AUX xboxdrv.service 371 BLAKE2B afd5f5397f4ae15af69d8e12865201fe159691ba2a36c00fe207304afe5126814fafd0394e7618e9f4d27611bd2c0dd7371717c7a07a57d27c3a4ab8e6e40140 SHA512 80e7657edae9c771740628ef5f9752b79d50288ead33afe97e71ffc6e7d7c24343eeb213668cdc823b28742976e2e56f4defdcd823716897f3262be1fc7832e9
-AUX xboxdrv.udev-rules 225 BLAKE2B 0f027c332b58d7ec3c289d23192355dae8d44f50c7cbf9de42a2023a2db6c29943fc7eecc85a0e802f5925ffdfc145584909140df8c030a120fe3da79c91641e SHA512 eb9e535bb18077e4c61db8fa5020a779b856a6df29eb4daa72a2ab9675720f809a981b0e4706fbbc6bf5a368cc162c7151cd6ae10399d091f10d2f75b1c48a3e
-DIST xboxdrv-linux-0.8.8.tar.bz2 267919 BLAKE2B b6f09fc929ba561f0c18a777ca94f6972f366d29709d5fdcb168988311ca53eb813761df0f87d148795aa14d2d89b200e8123502c0b255ebe20e5f9caa18f8f1 SHA512 2978b33d23636431ee0cc393ea32d3d26ebe9f2b914f0bf8bc0e096f98202726768142e653bc5765ac55084b105ff3a6214bdf6e745fdd8aa167260c54c10494
-EBUILD xboxdrv-0.8.8.ebuild 1405 BLAKE2B 5636721b89c91b62ac51695148920a0cd1641e5a8f847225a627dc71009a7480fbb02fa884ca590a1f375aca820fe3d3266c814afd1723717cf0b486b8eeffc2 SHA512 f91abd7d9370f4d2e6c79ed38da4eb93592e672dbe0ed2eac377da6fb927ed83e8ffb6eecff29a45926258950ea4da52f53bf619deb9ebedbb383495ca9b5e1a
-MISC metadata.xml 252 BLAKE2B 1b951d2e730631865ae5f379b19ed9de2c8adf2f2786da3f75d0871d967374198ddd9106433f388bdc7050c37063fb28cda4320ae7bdc9a03854838693d9f952 SHA512 90798aff93ec7e3881b882e7b10bb1680e8cb7d82b0ef4280e562ab0c9e8a2daba8afe57333dc64697322267a4b651c00ee9b4fdeb56278ff70c073da7b91638
+AUX xboxdrv.udev-rules 251 BLAKE2B 5a3af6d378b2d6ad5bb2da0dfa356c6939a274b194f075281bbfc3dcaee1c5b9fc63740bbfec2ecd0c8245065262a0449c47fad6c522e4773ef2e193018dc95f SHA512 131c90bee6ac4da5e3d51c7212abb362a540092db97af56332cdfe14e836c84c97727823462ea378da6e5544fda2fb4d36fbe00b6210e5663316f914eaa3f4ad
+DIST xboxdrv-0.8.8_p20190118.tar.gz 322541 BLAKE2B ffa1021f974414ab9efebccf89e8be9137647ba7e1adf3bc9dad3b17b362b340f087fdac42c9b91a29a4cfe13295df6d3861fe953d9f96e80df08d4a6b1ce754 SHA512 ede650090c67642dc4729acc37630ae807f354d76f9bf31e23357668b6ae2b8d0261d2cf6e33090ab2120083b0664332dab22f1ed682bcdcbf1cac88b97e67af
+EBUILD xboxdrv-0.8.8_p20190118.ebuild 1542 BLAKE2B 078df484f8ef2f0e5ab7379f86b5406f5697dd4038d11f727982816292c94cdb63bd70ea765c6a27ae55e5a018f61f86e030d82f832afcefa39a5197de7317ad SHA512 636b22ff49f95f9c05e6c154e61a268cb132d8b7783eaddedfa7ee5b6bb1362c1235c449283e632bf7283894aa75da23c4ad527e5d4287df0b7dea738cad6725
+MISC metadata.xml 494 BLAKE2B 365b4d5cc3a91765b96e4e206c9beb261e318798e90437e39ae7c2c437f1df07100233f0458acca702e1efadd092a4f788c81ddcdc40b8997cc91a1041047997 SHA512 dec2bdb2eb9d7cab3cb481d9694a805175a4004f0be5956b6711acb833732d7bc8ec3dc9b2c61d00b724bc7986ec186e7b36aa0327337bdab9241d45ee5f1f0e
diff --git a/games-util/xboxdrv/files/github-144.patch b/games-util/xboxdrv/files/github-144.patch
deleted file mode 100644
index 5782e1a8cd52..000000000000
--- a/games-util/xboxdrv/files/github-144.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Naur xboxdrv-linux-0.8.5.orig/src/usb_gsource.cpp xboxdrv-linux-0.8.5/src/usb_gsource.cpp
---- xboxdrv-linux-0.8.5.orig/src/usb_gsource.cpp 2013-04-07 18:27:49.000000000 +0100
-+++ xboxdrv-linux-0.8.5/src/usb_gsource.cpp 2016-07-02 12:35:41.692355904 +0100
-@@ -174,7 +174,10 @@
- gboolean
- USBGSource::on_source()
- {
-- libusb_handle_events(NULL);
-+ struct timeval to;
-+ to.tv_sec = 0;
-+ to.tv_usec = 0;
-+ libusb_handle_events_timeout_completed(NULL, &to, NULL);
- return TRUE;
- }
-
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch
deleted file mode 100644
index 80a8d8f550e1..000000000000
--- a/games-util/xboxdrv/files/xboxdrv-0.8.8-fix-c++14.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-Cast boost::shared_ptr explicitly for C++14.
-See also: https://bugs.gentoo.org/show_bug.cgi?id=594674
-
---- a/src/controller_slot.cpp
-+++ b/src/controller_slot.cpp
-@@ -67,9 +67,9 @@ ControllerSlot::disconnect()
- }
-
- bool
- ControllerSlot::is_connected() const
- {
-- return m_thread;
-+ return static_cast<bool>(m_thread);
- }
-
- /* EOF */
diff --git a/games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch b/games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch
deleted file mode 100644
index d6df8d99e32e..000000000000
--- a/games-util/xboxdrv/files/xboxdrv-0.8.8-scons.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://dev.gentoo.org/~vapier/scons-blows.txt
-
-diff -Naur xboxdrv-linux-0.8.8.orig/SConstruct xboxdrv-linux-0.8.8/SConstruct
---- xboxdrv-linux-0.8.8.orig/SConstruct 2015-11-09 10:19:35.000000000 +0000
-+++ xboxdrv-linux-0.8.8/SConstruct 2016-07-02 16:13:52.560961836 +0100
-@@ -84,6 +84,7 @@
- opts.Add('CXXFLAGS', 'C++ Compiler flags')
- opts.Add('LINKFLAGS', 'Linker Compiler flags')
- opts.Add('AR', 'Library archiver')
-+opts.Add('RANLIB', 'Archive indexer')
- opts.Add('CC', 'C Compiler')
- opts.Add('CXX', 'C++ Compiler')
- opts.Add('BUILD', 'Build type: release, custom, development')
diff --git a/games-util/xboxdrv/files/xboxdrv.udev-rules b/games-util/xboxdrv/files/xboxdrv.udev-rules
index c571b2b5ab02..85b1d57dd26b 100644
--- a/games-util/xboxdrv/files/xboxdrv.udev-rules
+++ b/games-util/xboxdrv/files/xboxdrv.udev-rules
@@ -1,5 +1,5 @@
SUBSYSTEM=="usb", ACTION=="add",\
- ENV{ID_MODEL_FROM_DATABASE}=="Xbox*Controller|Xbox*Controller S",\
+ ENV{ID_MODEL_FROM_DATABASE}=="Xbox*Controller|Xbox*Controller S|Xbox 360 Wireless Adapter",\
TAG+="systemd",\
ENV{SYSTEMD_ALIAS}="/sys/subsystem/usb/xbox/controller$number",\
ENV{SYSTEMD_WANTS}+="xboxdrv.service"
diff --git a/games-util/xboxdrv/metadata.xml b/games-util/xboxdrv/metadata.xml
index 3c186688e265..fe838d30a8ff 100644
--- a/games-util/xboxdrv/metadata.xml
+++ b/games-util/xboxdrv/metadata.xml
@@ -1,8 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <maintainer type="project">
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">chewi/xboxdrv</remote-id>
+ <remote-id type="gitlab">xboxdrv/xboxdrv</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
index a9324ad2dffe..e72f053eabff 100644
--- a/games-util/xboxdrv/xboxdrv-0.8.8.ebuild
+++ b/games-util/xboxdrv/xboxdrv-0.8.8_p20190118.ebuild
@@ -1,38 +1,50 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit linux-info scons-utils toolchain-funcs systemd udev
+EAPI=7
-MY_P=${PN}-linux-${PV}
-DESCRIPTION="Userspace Xbox 360 Controller driver"
-HOMEPAGE="https://pingus.seul.org/~grumbel/xboxdrv/"
-SRC_URI="https://pingus.seul.org/~grumbel/xboxdrv/${MY_P}.tar.bz2"
+PYTHON_COMPAT=( python2_7 python3_6 )
+
+inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev
+COMMIT="6e5e8a57628095d8d0c8bbb38187afb0f3a42112"
+DESCRIPTION="Userspace Xbox 360 Controller driver"
+HOMEPAGE="https://xboxdrv.gitlab.io"
+SRC_URI="https://github.com/chewi/xboxdrv/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="dev-libs/boost:=
- dev-libs/dbus-glib:=
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/dbus-glib
+ dev-libs/glib:2
+ sys-apps/dbus
virtual/libudev:=
- sys-apps/dbus:=
- dev-libs/glib:2=
- virtual/libusb:1=
- x11-libs/libX11:="
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/libusb:1
+ x11-libs/libX11
+"
+
+DEPEND="
+ ${RDEPEND}
+"
-S=${WORKDIR}/${MY_P}
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
-PATCHES=(
- "${FILESDIR}"/${P}-scons.patch
- "${FILESDIR}"/github-144.patch
- "${FILESDIR}"/${P}-fix-c++14.patch
-)
+S="${WORKDIR}/${PN}-${COMMIT}"
CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"
+src_prepare() {
+ default
+
+ # Make it clearer that this is a patched fork.
+ echo -n "${PV%_*}.${PV#*_p}-gentoo" > VERSION || die
+}
+
src_compile() {
escons \
BUILD=custom \
@@ -51,8 +63,8 @@ src_install() {
newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv
- insinto /etc/dbus-1/system.d/
- doins "${FILESDIR}/org.seul.Xboxdrv.conf"
+ insinto /etc/dbus-1/system.d
+ doins "${FILESDIR}"/org.seul.Xboxdrv.conf
udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
systemd_dounit "${FILESDIR}"/xboxdrv.service