summaryrefslogtreecommitdiff
path: root/games-util/xpadneo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 15:17:30 +0100
commit662f71ae67cd775d7fbb79b5091676c0e07a992b (patch)
tree74c7cb80b79b8886cd7466cf262878d1e8b9d546 /games-util/xpadneo
parentb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (diff)
gentoo auto-resync : 29:05:2023 - 15:17:30
Diffstat (limited to 'games-util/xpadneo')
-rw-r--r--games-util/xpadneo/Manifest3
-rw-r--r--games-util/xpadneo/xpadneo-0.9.5-r1.ebuild73
-rw-r--r--games-util/xpadneo/xpadneo-9999.ebuild29
3 files changed, 89 insertions, 16 deletions
diff --git a/games-util/xpadneo/Manifest b/games-util/xpadneo/Manifest
index 029740cb4541..85fe40a7790b 100644
--- a/games-util/xpadneo/Manifest
+++ b/games-util/xpadneo/Manifest
@@ -1,4 +1,5 @@
DIST xpadneo-0.9.5.tar.gz 1341366 BLAKE2B d04a3e1b626af1f1a9ec114f0a8ed44c50ec8cde9da71483491d1afd7688611fd7548186ea68ef8a144aecec06acba816e81e9f0708c8dceb96fa1d40985bb44 SHA512 e7e299faf78c139d4cd189c4adc9bcbd52e1e1011ff90513cc09fc3e6cac1961018883933ad1db23dc02c8d5006f3166fbb42ae66150dff71138f2ed95f4576c
+EBUILD xpadneo-0.9.5-r1.ebuild 2242 BLAKE2B adc4ea5a8027aa7d49e6eabd3f753bc1fb927cf5fe96cbada7b5308606b241a35debd6bce3d08f91f8d18cd7eb5c99c0b9d078503c7f0f3fc41b65c56dd9acd6 SHA512 e90ac03fcde8a74038e7c49c3d3a932b5107ded519351002534917beaa6451751c3d13ac48862e143de875aed817561ccaeb931dec787ff54e281adeec68d615
EBUILD xpadneo-0.9.5.ebuild 2302 BLAKE2B 812746fd441bf7c61ff665082e2cf07cd97ed48e6586679b127da8759b80c5a31db68a4322a78b3a20ec7716aa586e0ffab6b2dabb9fb5d9831ca427439020c1 SHA512 545bdcaedef3ea8152a8a1cca1a90b6ae5baaa92530b7e8c3975668185c43d405c1965eb6fc1a8e3842f934418ae8dc5cbd10632d90fc1d0c97710ddb1dcf49b
-EBUILD xpadneo-9999.ebuild 2303 BLAKE2B d2fb6917074519884902d2037c2d07259ef1e9c65199f0734c0265d29f432712157e1d2ec7e8aa97e005be8b7c7691d8015ef584111afa2a5f284135c6eae858 SHA512 f63983701cd920e01526a7f01d318dc0d66365b1d79628bcf9e3d88ca65d1d4de324b69e904f179e7d0107dd5a60302ef8168d2ad63bb29a94b5d6673d822552
+EBUILD xpadneo-9999.ebuild 2242 BLAKE2B adc4ea5a8027aa7d49e6eabd3f753bc1fb927cf5fe96cbada7b5308606b241a35debd6bce3d08f91f8d18cd7eb5c99c0b9d078503c7f0f3fc41b65c56dd9acd6 SHA512 e90ac03fcde8a74038e7c49c3d3a932b5107ded519351002534917beaa6451751c3d13ac48862e143de875aed817561ccaeb931dec787ff54e281adeec68d615
MISC metadata.xml 328 BLAKE2B 6511430d43b855d83d42dc94ea83bf20867568e9dbf642240ac279179d9f26d0a315f3fb90bebd4a564d4bc63beefcb8aa24af7acf25a60f9b25f732265de41b SHA512 defbfc601b6b61d10edf8947e2251f96416787a1141fccff1e017a6110eb4d8e8801fcd72cc678f816064eb5a5dc796c9c895ca9f74ad288f1338ccaaf3ee5c8
diff --git a/games-util/xpadneo/xpadneo-0.9.5-r1.ebuild b/games-util/xpadneo/xpadneo-0.9.5-r1.ebuild
new file mode 100644
index 000000000000..c1de2e3d642d
--- /dev/null
+++ b/games-util/xpadneo/xpadneo-0.9.5-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 udev
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/atar-axis/xpadneo.git"
+ EGIT_MIN_CLONE_TYPE="single"
+else
+ SRC_URI="https://github.com/atar-axis/xpadneo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Advanced Linux Driver for Xbox One Wireless Controller"
+HOMEPAGE="https://atar-axis.github.io/xpadneo/"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+CONFIG_CHECK="INPUT_FF_MEMLESS"
+
+src_compile() {
+ local modlist=( hid-${PN}=kernel/drivers/hid:hid-${PN}:hid-${PN}/src )
+ local modargs=( KERNEL_SOURCE_DIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
+src_install() {
+ local DOCS=( docs/{[^i]*.md,descriptors,reports} NEWS.md )
+ linux-mod-r1_src_install
+
+ insinto /etc/modprobe.d
+ doins hid-${PN}/etc-modprobe.d/${PN}.conf
+
+ udev_dorules hid-${PN}/etc-udev-rules.d/60-${PN}.rules
+}
+
+pkg_postinst() {
+ linux-mod-r1_pkg_postinst
+ udev_reload
+
+ local disable_ertm=/sys/module/bluetooth/parameters/disable_ertm
+ if kernel_is -ge 5 12; then
+ if [[ $(<${disable_ertm}) == Y ]]; then
+ elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is disabled."
+ elog "This is no longer recommended with kernel >=5.12 to use ${PN}."
+ elog "Can remove ${EROOT}/etc/modprobe.d/no-ertm.conf if it exists, and run:"
+ elog " echo N > ${disable_ertm}"
+ elog "After changing, may need to re-pair the gamepad with bluetooth."
+ fi
+ elif [[ $(<${disable_ertm}) == N ]]; then
+ elog "Warning: bluetooth ERTM (Enhanced ReTransmission Mode) is enabled."
+ elog "While keeping enabled is recommended for rumble usage stability, it can"
+ elog "cause connection issues without a fix included in kernel >=5.12"
+ elog "If needed, this mode can be disabled by running:"
+ elog " echo Y > ${disable_ertm}"
+ elog " echo 'options bluetooth disable_ertm=y' > ${EROOT}/etc/modprobe.d/no-ertm.conf"
+ elog "After changing, may need to re-pair the gamepad with bluetooth."
+ fi
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "To pair the gamepad and view module options, see documentation in:"
+ elog " ${EROOT}/usr/share/doc/${PF}/"
+ fi
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/games-util/xpadneo/xpadneo-9999.ebuild b/games-util/xpadneo/xpadneo-9999.ebuild
index b193e5517951..c1de2e3d642d 100644
--- a/games-util/xpadneo/xpadneo-9999.ebuild
+++ b/games-util/xpadneo/xpadneo-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-# pkgcheck note: toolchain-funcs is not unused
-inherit linux-mod toolchain-funcs udev
+inherit linux-mod-r1 udev
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -21,26 +20,27 @@ HOMEPAGE="https://atar-axis.github.io/xpadneo/"
LICENSE="GPL-3"
SLOT="0"
-S="${WORKDIR}/${P}/hid-${PN}"
-MODULE_NAMES="hid-${PN}(kernel/drivers/hid::src)"
-BUILD_PARAMS='V=1 LD="$(tc-getLD)" KERNEL_SOURCE_DIR="${KV_OUT_DIR}"'
-BUILD_TARGETS="modules"
-
CONFIG_CHECK="INPUT_FF_MEMLESS"
+src_compile() {
+ local modlist=( hid-${PN}=kernel/drivers/hid:hid-${PN}:hid-${PN}/src )
+ local modargs=( KERNEL_SOURCE_DIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}
+
src_install() {
- linux-mod_src_install
+ local DOCS=( docs/{[^i]*.md,descriptors,reports} NEWS.md )
+ linux-mod-r1_src_install
insinto /etc/modprobe.d
- doins etc-modprobe.d/${PN}.conf
-
- udev_dorules etc-udev-rules.d/60-${PN}.rules
+ doins hid-${PN}/etc-modprobe.d/${PN}.conf
- dodoc -r ../docs/{[^i]*.md,descriptors,reports} ../NEWS.md
+ udev_dorules hid-${PN}/etc-udev-rules.d/60-${PN}.rules
}
pkg_postinst() {
- linux-mod_pkg_postinst
+ linux-mod-r1_pkg_postinst
udev_reload
local disable_ertm=/sys/module/bluetooth/parameters/disable_ertm
@@ -69,6 +69,5 @@ pkg_postinst() {
}
pkg_postrm() {
- linux-mod_pkg_postrm
udev_reload
}