summaryrefslogtreecommitdiff
path: root/games-util/uz2unpack/uz2unpack-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/uz2unpack/uz2unpack-0.1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/uz2unpack/uz2unpack-0.1.ebuild')
-rw-r--r--games-util/uz2unpack/uz2unpack-0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/games-util/uz2unpack/uz2unpack-0.1.ebuild b/games-util/uz2unpack/uz2unpack-0.1.ebuild
new file mode 100644
index 000000000000..494df27d5a68
--- /dev/null
+++ b/games-util/uz2unpack/uz2unpack-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="UZ2 Decompressor for UT2003/UT2004"
+HOMEPAGE="http://icculus.org/cgi-bin/ezmlm/ezmlm-cgi?42:mss:1013:200406:kikgppboefcimdbadcdo"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDLIBS=-lz ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README
+}