summaryrefslogtreecommitdiff
path: root/games-util/springlobby
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /games-util/springlobby
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'games-util/springlobby')
-rw-r--r--games-util/springlobby/Manifest3
-rw-r--r--games-util/springlobby/metadata.xml26
-rw-r--r--games-util/springlobby/springlobby-0.264.ebuild54
3 files changed, 83 insertions, 0 deletions
diff --git a/games-util/springlobby/Manifest b/games-util/springlobby/Manifest
new file mode 100644
index 000000000000..6336cd6381b3
--- /dev/null
+++ b/games-util/springlobby/Manifest
@@ -0,0 +1,3 @@
+DIST springlobby-0.264.tar.bz2 2626180 BLAKE2B 01ff51703c3c10c1aaeb342d2644012a6037b1271ba7e36ab7663cde7646d1c9c6bd823fe65c91a8a9e754bbcf1000ce486eeab2d1641c64fad08773c491f9a6 SHA512 f8024a98be7d6ea755c4380494415813084aadb6dcf72ed0aaeba0ddf9fbaf992ccd5455713c807c0d6feb7db606068be62d4bb2cfcb4697f0406a2ec4f404eb
+EBUILD springlobby-0.264.ebuild 1071 BLAKE2B 0e04cf3827794b354dabf9708ffe96f4de7b73bc06340429b048c794ba65d4647a3368d911eed2f277c754431a68949e6a6cb8833f6d5f64a3947d058d5c137c SHA512 88c5161c566ad511db04ea36253fa46facc06731611addc385ed8c8fd906a4456f33ad3996086aae39ce8f66ad907324c602d5d1189226375be62e64cdc80794
+MISC metadata.xml 1168 BLAKE2B 52a394c332bed809d549cf76a750a35cb0c0bcb6af1cf2276d81958abafa6272e58d59d07762929ef05ccece16d5465d5c353dd71974b4ec2657ae99e3d607a5 SHA512 901e3865f60e798625d59085e38e191a256819e5aa0778210190ebc0a08f183b263c3391409079c499a2e2cb6740503371642f0c13eec1e59a8699060c00b59c
diff --git a/games-util/springlobby/metadata.xml b/games-util/springlobby/metadata.xml
new file mode 100644
index 000000000000..eabc7ba13bca
--- /dev/null
+++ b/games-util/springlobby/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+The official lobby client for SpringRTS community games: Balanced Annihilation; Journeywar; Metal Factions; Spring:1944 World War II; Star Wars: Imperial Winter; Tech Annihilation; The Cursed; Evolution RTS; ...
+ </longdescription>
+ <longdescription lang="fr">
+Le client officiel du lobby pour les jeux de la communauté SpringRTS : Balanced Annihilation; Journeywar; Metal Factions; Spring:1944 World War II; Star Wars: Imperial Winter; Tech Annihilation; The Cursed; Evolution RTS; ...
+ </longdescription>
+ <maintainer type="person">
+ <email>totocoq@yahoo.fr</email>
+ <name>Thomas Coquelin</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>fedja@protonmail.ch</email>
+ <name>Fedja Beader</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">springlobby/springlobby</remote-id>
+ <bugs-to>https://github.com/springlobby/springlobby/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/games-util/springlobby/springlobby-0.264.ebuild b/games-util/springlobby/springlobby-0.264.ebuild
new file mode 100644
index 000000000000..510738cb07bd
--- /dev/null
+++ b/games-util/springlobby/springlobby-0.264.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+inherit cmake-utils gnome2-utils wxwidgets
+
+DESCRIPTION="The official lobby client for SpringRTS community games"
+HOMEPAGE="https://springlobby.info"
+SRC_URI="https://www.springlobby.info/tarballs/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +libnotify +nls +sound"
+
+RDEPEND="
+ >=dev-libs/boost-1.35:=
+ dev-libs/openssl:=
+ sound? ( media-libs/alure
+ media-libs/openal
+ )
+ net-misc/curl
+ sys-libs/zlib[minizip]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXext
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ libnotify? ( x11-libs/libnotify )
+"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ setup-wxwidgets
+ local mycmakeargs=(
+ -DOPTION_NOTIFY=$(usex libnotify)
+ -DOPTION_SOUND=$(usex sound)
+ -DOPTION_TRANSLATION_SUPPORT=$(usex nls)
+ -DAUX_VERSION="(Gentoo,${ARCH})"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}