summaryrefslogtreecommitdiff
path: root/games-util/slade
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-09 01:31:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-09 01:31:00 +0100
commitc956c264bdc853972b72016b752683468881af25 (patch)
treed6305ce3422074c4aaf3159ddd7a23bba7682e45 /games-util/slade
parent541eca7cf7b9950f0adaaf9158f94c76ba0aedc9 (diff)
gentoo auto-resync : 09:10:2022 - 01:31:00
Diffstat (limited to 'games-util/slade')
-rw-r--r--games-util/slade/Manifest2
-rw-r--r--games-util/slade/files/slade-3.2.0-bundled-libs.patch32
2 files changed, 17 insertions, 17 deletions
diff --git a/games-util/slade/Manifest b/games-util/slade/Manifest
index 9b832e5ec5ab..71b6c3ea3497 100644
--- a/games-util/slade/Manifest
+++ b/games-util/slade/Manifest
@@ -1,4 +1,4 @@
-AUX slade-3.2.0-bundled-libs.patch 5490 BLAKE2B 567cacdb298c1d2183d507fdf8349a79f6856d6464254b6ece42a441be32796b6fe499f70d43c25c38864a8eaab515571b1b5935deb40d04264c81eda037f2a6 SHA512 b195290fa9229dc2da9488c85b377d0206ffe93a2db4a551bfe4ee9cc5f903af4c50a9a9cd2eee9a1bc5f4cbe894d567fc4070cc9021030527692f7e47fd2d68
+AUX slade-3.2.0-bundled-libs.patch 5507 BLAKE2B 963e1b8b128acbe34ddaee537b32e047ab72f5555860ebabedf35891cae5a0c992d5bcb7cf69defb176b4b2980ec9a027e8684b3125129d1adf628af0afd1e13 SHA512 70cbd8953bea56b82b8741f0bd283c1770498386f637405ccfd73d3eb80113a6a5c312e36a769c4d0158dc7e87835a526593ac93a21af3e4c7f2f80816013958
AUX slade-3.2.0_beta2-fluidsynth-driver.patch 790 BLAKE2B ea84ff6515b4b80cbce021624c27dbd4c067758b7e5861402d42628ddee85385a260396163838b1504e2196c3b275977ad5ddde3d684e49de600270d7990a1c0 SHA512 3de05beafc060891d674d388cbb07107ead138ef2a89812dfffabfc8c9de2beb939290b1064b75e14d3cc42621c8ee66ced06eacdcb2afd376a9539fa74c54c8
DIST slade-3.2.1.tar.gz 6471666 BLAKE2B 17a4f2ec23699a56d4fd970605d7141d3f4593f7ced6fff205c87d9ecddc7b90e6da2991aeea32bd008e24cdfee95b7c16946f78b2701c94e51266afd78863d6 SHA512 b7d5a91c759c5a68af63aa9a8412452a5b2986e70f7189ca92ee99ce4953ef47381be907c8ce1166e479f24679904bf5f0e0b1a5da846fe7873c5b97f4315449
EBUILD slade-3.2.1-r1.ebuild 1692 BLAKE2B fe4206570d58759ff61cd899c3fc896f55e41452bb3430d28e02b7a895329c3e55e92a6d2663392e9327e71048115ee69bfa395f06df2f80c17242b9648a9463 SHA512 3ddbb9e5640f2e6d5700c9594d9baf5e2038eed6f0102b312906220cd9381ea1c3cd8a869c2932063e9d664a4b77913fbd4e531febe52499861a841e578eb806
diff --git a/games-util/slade/files/slade-3.2.0-bundled-libs.patch b/games-util/slade/files/slade-3.2.0-bundled-libs.patch
index c543f09e3fae..c2efc8ca3496 100644
--- a/games-util/slade/files/slade-3.2.0-bundled-libs.patch
+++ b/games-util/slade/files/slade-3.2.0-bundled-libs.patch
@@ -11,7 +11,7 @@ index dddaf875..ede8d73c 100644
-#include "thirdparty/dumb/dumb.h"
+#include <dumb.h>
#include <filesystem>
-
+
using namespace slade;
diff --git a/src/Audio/ModMusic.cpp b/src/Audio/ModMusic.cpp
index cc4b60cf..6d54516d 100644
@@ -23,7 +23,7 @@ index cc4b60cf..6d54516d 100644
#include "ModMusic.h"
-#include "thirdparty/dumb/dumb.h"
+#include <dumb.h>
-
+
using namespace slade;
using namespace audio;
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
@@ -42,7 +42,7 @@ index fef3d009..00dbb018 100644
install(FILES "${SLADE_OUTPUT_DIR}/slade.pk3"
DESTINATION share/slade3
)
--
+-
+
install(FILES "${PROJECT_SOURCE_DIR}/dist/res/logo_icon.png"
DESTINATION share/icons/
@@ -57,9 +57,9 @@ index 460a7852..5e171446 100644
#include "Utility/StringUtils.h"
-#include "thirdparty/fmt/include/fmt/format.h"
+#include <fmt/format.h>
-
+
using namespace slade;
-
+
diff --git a/src/General/Log.cpp b/src/General/Log.cpp
index 9ad0718f..8d39f644 100644
--- a/src/General/Log.cpp
@@ -73,7 +73,7 @@ index 9ad0718f..8d39f644 100644
+#include <fmt/chrono.h>
+#include <fmt/format.h>
#include <fstream>
-
+
using namespace slade;
diff --git a/src/TextEditor/TextStyle.cpp b/src/TextEditor/TextStyle.cpp
index 09f4e405..ad51ec0a 100644
@@ -85,9 +85,9 @@ index 09f4e405..ad51ec0a 100644
#include "Utility/Tokenizer.h"
-#include "thirdparty/fmt/include/fmt/format.h"
+#include <fmt/format.h>
-
+
using namespace slade;
-
+
diff --git a/src/UI/Browser/BrowserItem.cpp b/src/UI/Browser/BrowserItem.cpp
index 89c0f39c..3f056f71 100644
--- a/src/UI/Browser/BrowserItem.cpp
@@ -98,7 +98,7 @@ index 89c0f39c..3f056f71 100644
text_box_ = std::make_unique<TextBox>(
- fmt::format("{}\n{}", index_, name_.c_str()), font, ui::scalePx(144), ui::scalePx(16));
+ fmt::format("{}\n{}", index_, name_.mb_str()), font, ui::scalePx(144), ui::scalePx(16));
-
+
int top = y;
top += ((size - text_box_->height()) * 0.5);
diff --git a/src/UI/SToolBar/SToolBar.cpp b/src/UI/SToolBar/SToolBar.cpp
@@ -106,7 +106,7 @@ index f38710ad..c002bf97 100644
--- a/src/UI/SToolBar/SToolBar.cpp
+++ b/src/UI/SToolBar/SToolBar.cpp
@@ -219,7 +219,7 @@ void SToolBarGroup::hide(bool hide)
-
+
// Update 'hidden toolbars' cvar
string tb_hidden = toolbars_hidden;
- auto name = fmt::format("[{}]", name_.c_str());
@@ -120,11 +120,11 @@ index 8c3c4b3b..d66cbc04 100644
+++ b/src/common.h
@@ -129,7 +129,7 @@
#endif
-
+
// fmt
-#include "thirdparty/fmt/include/fmt/core.h"
+#include <fmt/core.h>
-
+
// Sigslot
#include "thirdparty/sigslot/signal.hpp"
diff --git a/thirdparty/CMakeLists.txt b/thirdparty/CMakeLists.txt
@@ -134,7 +134,7 @@ index f84cfc8a..6cb9e0af 100644
@@ -6,20 +6,33 @@ find_package(BZip2 REQUIRED)
set(ZLIB_LIBRARY ${ZLIB_LIBRARY} PARENT_SCOPE)
set(BZIP2_LIBRARIES ${BZIP2_LIBRARIES} PARENT_SCOPE)
-
+
+option(USE_SYSTEM_DUMB "Use system DUMB library" OFF)
+if(USE_SYSTEM_DUMB)
+ pkg_check_modules(DUMB REQUIRED IMPORTED_TARGET dumb>=1.0)
@@ -154,7 +154,7 @@ index f84cfc8a..6cb9e0af 100644
+ ${DUMB_SOURCES}
${SLADE_HEADERS}
)
-
+
# Add fmt
-add_subdirectory(fmt)
+option(USE_SYSTEM_FMT "Use system fmt library" OFF)
@@ -164,12 +164,12 @@ index f84cfc8a..6cb9e0af 100644
+ add_subdirectory(fmt)
+ target_include_directories(fmt INTERFACE ${CMAKE_CURRENT_LIST_DIR}/fmt/include)
+endif()
-
+
# Add lunasvg
add_library(lunasvg STATIC)
@@ -29,5 +42,11 @@ add_subdirectory(lunasvg/3rdparty/software)
add_subdirectory(lunasvg/3rdparty/plutovg)
-
+
add_library(external STATIC ${EXTERNAL_SOURCES})
-target_link_libraries(external ${ZLIB_LIBRARY} lunasvg fmt ${CMAKE_DL_LIBS})
+target_link_libraries(external ${ZLIB_LIBRARY} lunasvg fmt::fmt ${CMAKE_DL_LIBS})