summaryrefslogtreecommitdiff
path: root/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild')
-rw-r--r--games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild
new file mode 100644
index 000000000000..a58f94b84142
--- /dev/null
+++ b/games-util/pogo-manager-bin/pogo-manager-bin-0.1.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin}"
+
+DESCRIPTION="Pokemon Go manager"
+HOMEPAGE="https://github.com/Wolfsblvt/BlossomsPokemonGoManager"
+SRC_URI="https://github.com/Wolfsblvt/BlossomsPokemonGoManager/releases/download/v${PV}/BPGM_v${PV}.zip -> ${P}.zip"
+
+LICENSE="CC-BY-NC-SA-4.0"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( dev-java/oracle-jdk-bin:1.8[javafx] dev-java/oracle-jre-bin:1.8[javafx] )"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/BPGM_v${PV}"
+
+src_install()
+{
+ insinto /opt/${MY_PN}
+ newins BlossomsPogoManager.jar ${MY_PN}.jar
+
+ dobin "${FILESDIR}/pogo-manager"
+}
+
+pkg_postinst()
+{
+ ewarn "Use of this tool is not sanctioned by Niantic and could get you banned."
+ ewarn "You have been warned!"
+}