summaryrefslogtreecommitdiff
path: root/games-util/mcrcon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/mcrcon
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/mcrcon')
-rw-r--r--games-util/mcrcon/Manifest3
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5-r1.ebuild26
-rw-r--r--games-util/mcrcon/metadata.xml12
3 files changed, 41 insertions, 0 deletions
diff --git a/games-util/mcrcon/Manifest b/games-util/mcrcon/Manifest
new file mode 100644
index 000000000000..a309b006c5ea
--- /dev/null
+++ b/games-util/mcrcon/Manifest
@@ -0,0 +1,3 @@
+DIST mcrcon-0.0.5-src.zip 9748 BLAKE2B 27f209a51e0131f00a1d84b859301a5e0440c9fb857c9112c98c34749c9ab1dda3065d7d748e7a6385e034d3d349a9394cf547a42d2bf5ae3376276695c60994 SHA512 590da8007d630a9ff5332b5fda9e2498e949b4085e16fd00a4b1f693251980bc2d91736ea8ca7c649ee34b28484d165c8b5f45b1830e9fb661bec3a10af080d2
+EBUILD mcrcon-0.0.5-r1.ebuild 564 BLAKE2B c927d344ac0b18430605b6d12c199c9d292bd0676c02051df3be2569490acf7c3065b893af226aee90d5bdaf29a616a38762daa8f5a0d4eebc3a1556e5cc83e6 SHA512 9dd2b75ed31a5f16855152e9a8e0c9d92d877e14c9c9963054503adf5ff11fbcc392dd067d89392c6ef8bdd694bccf6abdb763355362711f37399274f8665b09
+MISC metadata.xml 641 BLAKE2B c49d0cee907fab7f95d8161935dde49ba43d9fcc115f98f909b35f505ed593822bc9f3666f2efc339cffd7f7b3d01b6700bb893e22d9d4c8b45f9d0dffa12dcb SHA512 adb906c501126b769de78c11ebb7bc36555327696f9d68ecdf6d8a311b4ddc89fdc370640eea04591349087e9d386e5ed99e95b71bc1380fa04f9a0072387bf4
diff --git a/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..01c42e501eda
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ default
+ dobin "${PN}"
+}
diff --git a/games-util/mcrcon/metadata.xml b/games-util/mcrcon/metadata.xml
new file mode 100644
index 000000000000..e7f8f4b0d06d
--- /dev/null
+++ b/games-util/mcrcon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>mcrcon is an IPv6 compliant Minecraft rcon client with Bukkit coloring support. It is well suited for remote administration and to be used as part of automated server maintenance scripts. Does not trigger the "IO: Broken pipe" or "IO: Connection reset" spam bug on the server side.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mcrcon</remote-id>
+ </upstream>
+</pkgmetadata>