summaryrefslogtreecommitdiff
path: root/games-util/mcrcon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/mcrcon
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/mcrcon')
-rw-r--r--games-util/mcrcon/Manifest6
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5-r1.ebuild26
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5.ebuild26
-rw-r--r--games-util/mcrcon/metadata.xml12
4 files changed, 70 insertions, 0 deletions
diff --git a/games-util/mcrcon/Manifest b/games-util/mcrcon/Manifest
new file mode 100644
index 000000000000..933bd385a2ac
--- /dev/null
+++ b/games-util/mcrcon/Manifest
@@ -0,0 +1,6 @@
+DIST mcrcon-0.0.5-src.zip 9748 SHA256 14cdbc00d5e2c4e877ea82fef3aeb94c2e258b3539c47a7f2b015cab12f98a74 SHA512 590da8007d630a9ff5332b5fda9e2498e949b4085e16fd00a4b1f693251980bc2d91736ea8ca7c649ee34b28484d165c8b5f45b1830e9fb661bec3a10af080d2 WHIRLPOOL 5cfb116cdf7c4a600f7cc3475e868081ea4674807edc360e87c27af7777a3423be1763a743d0d655039b4a8b1f0206fa829ecb1adbc9504a68976204b01091f7
+EBUILD mcrcon-0.0.5-r1.ebuild 564 SHA256 203171ad7102e8c10209d4ccfec5aac6f0259fbb5f7df7a3ac8f7088ceb40948 SHA512 9dd2b75ed31a5f16855152e9a8e0c9d92d877e14c9c9963054503adf5ff11fbcc392dd067d89392c6ef8bdd694bccf6abdb763355362711f37399274f8665b09 WHIRLPOOL d5917eb94ac271b4d62c2f7e171591d1c77712d3ddeca69a0453b8520fb76dd3566d1dc8685fdcaeb8aa6291e35b80d81d0ad3946d63510a0cb87121aa34d383
+EBUILD mcrcon-0.0.5.ebuild 584 SHA256 dbf8ae6e6c4d97fd65e8fbfaa8b960c5ba6b1bc2ddf16f602eee8eb8edee071f SHA512 416683aa2a4032b93139ef90514a73bba18885859d908cb87fa5880f2f40d39a8c84db1537db3eb83c24112c683f4c24259058e7fc6425fdb482e44630629dec WHIRLPOOL 20e32672996aba752e0a6bb1a3b3acaa3c9a323c703fa3d0df5e2750dc9a3fcf05cb7f4ac3fb04f30731a8d767ec00cf8ba6cb71522e068ee22f0c27760f6795
+MISC ChangeLog 2563 SHA256 4dbc921fdc263eadf79c1818c3daca648d2b9613f230e0a9d3130e4236bce394 SHA512 779bc4b673d9f39c4ca23406d4e30378133bd3367fd5383671f2b147064928010e85201e2e6b8672fb1dd1c0783f388e7717a783ca795c6d4104cb465fda8f26 WHIRLPOOL b24555da486de76f1a91f612834639d2594591039ad8350e5a850611402b8ec74cb6ca5aa781c21104e3dab18cc5ad7b36ccb750b2b4da03b3afafc4cace4890
+MISC ChangeLog-2015 342 SHA256 e6938abc6c88cf3de82e8fc06f2ce0af7f35aab9ff841084ce23207fee8b472f SHA512 fde42d427043b11c286135692b674b87d8b61e33f17e9139f5e7ecbceebbf632b9d5582e76372d06467185fa00e8505a5aae34d272898736b5ac241577ea330b WHIRLPOOL 90092ef30055073d60573d62e5ba5487ffcda6b0428611957d43a1e9eda30e4e33db389d95ba09d694e6504cf8af7ac92e5810856ea7b0750998de36c94be234
+MISC metadata.xml 641 SHA256 ad1fbb6f2df4ebbe03f1670a5c95d5768462e1213049e13d3d97fe92e43e66ee SHA512 adb906c501126b769de78c11ebb7bc36555327696f9d68ecdf6d8a311b4ddc89fdc370640eea04591349087e9d386e5ed99e95b71bc1380fa04f9a0072387bf4 WHIRLPOOL 815002c8ff343d8297b1e43be63ee86efd2b59b92962aa2e7afbaec3605338ee7252a8ce7e804766b29a9ca818d4d76443ea64c1a9f43fcc52ccef001cd075a2
diff --git a/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..01c42e501eda
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ default
+ dobin "${PN}"
+}
diff --git a/games-util/mcrcon/mcrcon-0.0.5.ebuild b/games-util/mcrcon/mcrcon-0.0.5.ebuild
new file mode 100644
index 000000000000..ad05389b005a
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs games
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="https://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ dogamesbin "${PN}"
+ dodoc README.txt
+}
diff --git a/games-util/mcrcon/metadata.xml b/games-util/mcrcon/metadata.xml
new file mode 100644
index 000000000000..e7f8f4b0d06d
--- /dev/null
+++ b/games-util/mcrcon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <longdescription>mcrcon is an IPv6 compliant Minecraft rcon client with Bukkit coloring support. It is well suited for remote administration and to be used as part of automated server maintenance scripts. Does not trigger the "IO: Broken pipe" or "IO: Connection reset" spam bug on the server side.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">mcrcon</remote-id>
+ </upstream>
+</pkgmetadata>