summaryrefslogtreecommitdiff
path: root/games-util/lutris/lutris-0.5.9_beta1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-30 19:43:03 +0100
commit162945d2a91899b637bbb9e163b406350de12906 (patch)
tree49cc2cc66f724a7c6f033f93aaba4ae3be1f2259 /games-util/lutris/lutris-0.5.9_beta1.ebuild
parentf660c6de84558324d784218831d8f0782ee41e2e (diff)
gentoo resync : 30.10.2021
Diffstat (limited to 'games-util/lutris/lutris-0.5.9_beta1.ebuild')
-rw-r--r--games-util/lutris/lutris-0.5.9_beta1.ebuild87
1 files changed, 0 insertions, 87 deletions
diff --git a/games-util/lutris/lutris-0.5.9_beta1.ebuild b/games-util/lutris/lutris-0.5.9_beta1.ebuild
deleted file mode 100644
index 4ca63a7a2a1f..000000000000
--- a/games-util/lutris/lutris-0.5.9_beta1.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-PYTHON_REQ_USE="sqlite,threads(+)"
-DISTUTILS_SINGLE_IMPL="1"
-
-inherit distutils-r1 virtualx xdg
-
-DESCRIPTION="An open source gaming platform for GNU/Linux"
-HOMEPAGE="https://lutris.net/"
-
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://github.com/lutris/lutris.git"
- inherit git-r3
-else
- if [[ ${PV} == *_beta* ]] ; then
- SRC_URI="https://github.com/lutris/lutris/archive/refs/tags/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/${P/_/-}
- else
- SRC_URI="https://lutris.net/releases/${P/-/_}.tar.xz"
- S="${WORKDIR}/${PN}"
-
- KEYWORDS="~amd64 ~x86"
- fi
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-
-RDEPEND="
- app-arch/cabextract
- app-arch/p7zip
- app-arch/unzip
- $(python_gen_cond_dep '
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/python-evdev[${PYTHON_USEDEP}]
- dev-python/python-magic[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- ')
- gnome-base/gnome-desktop:3[introspection]
- media-sound/fluid-soundfont
- net-libs/libsoup
- net-libs/webkit-gtk:4[introspection]
- x11-apps/mesa-progs
- x11-apps/xgamma
- x11-apps/xrandr
- x11-libs/gtk+:3[introspection]
- x11-libs/libnotify[introspection]
-"
-
-distutils_enable_tests nose
-
-src_prepare() {
- default
-
- # Avoid test failure:
- # "ERROR: Failure: OSError (data_path can't be found at : /usr/share/lutris)"
- sed -i -e "s:sys.path\[0\]:\"${S}/share\":" lutris/util/datapath.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- virtx nosetests -v
-}
-
-python_install_all() {
- local DOCS=( AUTHORS README.rst docs/installers.rst )
- distutils-r1_python_install_all
- python_fix_shebang "${ED}"/usr/share/lutris/bin/lutris-wrapper #740048
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- # Quote README.rst
- elog "Lutris installations are fully automated through scripts, which can"
- elog "be written in either JSON or YAML. The scripting syntax is described"
- elog "in ${EROOT}/usr/share/doc/${PF}/installers.rst.bz2, and is also"
- elog "available online at lutris.net."
-}