summaryrefslogtreecommitdiff
path: root/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild')
-rw-r--r--games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
new file mode 100644
index 000000000000..c7a78635c82d
--- /dev/null
+++ b/games-util/linux-wbfs-manager/linux-wbfs-manager-0.1.12.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+if [[ "${PV}" == "9999" ]]; then
+ ESVN_REPO_URI="https://linux-wbfs-manager.googlecode.com/svn/trunk/"
+ inherit toolchain-funcs subversion
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ inherit toolchain-funcs
+ SRC_URI="https://linux-wbfs-manager.googlecode.com/files/${P}.tar.gz"
+ KEYWORDS="amd64 x86"
+fi;
+
+DESCRIPTION="WBFS manager for Linux using GTK+"
+HOMEPAGE="https://code.google.com/p/linux-wbfs-manager/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${PN}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]]; then
+ subversion_src_unpack
+ else
+ default
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin wbfs_gtk
+ dodoc README
+}