summaryrefslogtreecommitdiff
path: root/games-util/lgogdownloader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/lgogdownloader
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/lgogdownloader')
-rw-r--r--games-util/lgogdownloader/Manifest4
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.3.ebuild26
-rw-r--r--games-util/lgogdownloader/lgogdownloader-9999.ebuild25
-rw-r--r--games-util/lgogdownloader/metadata.xml33
4 files changed, 88 insertions, 0 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
new file mode 100644
index 000000000000..0e172b46e3b5
--- /dev/null
+++ b/games-util/lgogdownloader/Manifest
@@ -0,0 +1,4 @@
+DIST lgogdownloader-3.3.tar.gz 73873 BLAKE2B c2c4c56d6afcc4c103cc32a308be25252888f7668d7488d3aa2eec860f8e2694c62fe25a27e1f24132895d0a8683a226ca95667dac4e7837886b07cfd0821855 SHA512 7af67c440e88bcfbbd6f59b44b8cfd81fe9cee041715d4da968be3aedfe4301a5377ce61354a5cc093588d89300c88c862d9228672a2d79613419dce3619f4c9
+EBUILD lgogdownloader-3.3.ebuild 617 BLAKE2B fcc5b4667ea14cb9ed71edcec85a67778a4f8a26c4c2cbb0bd6db7d4236b1679605286d6cb4de5c7d8f640b98bf4934cefc11b4ef90f331e9c9ec9e8d4643ccc SHA512 1ba1653d7b228c0d30496209bc422d57cc08af72cb978e69f95e5caebf97ec080b8d2cecc99f491040d54c40c8b0cf507d60b3c70c7ef628e40d2ba98f2d0537
+EBUILD lgogdownloader-9999.ebuild 595 BLAKE2B 6952d20f49e8de4192580f817ed40ed75e9b4b4350ca4386d3ae833d7754ce64229dad443d65c8bbf16e97d5cce5aef9bdcb0e9b78f5e58c26d90f052ac82051 SHA512 96abd62dd1be6f345ea2aeae400c843eff0e68caa38bfed0e38b7fdd09957dfa170b988886a2144066c545e05845604d54af31d05f622ea1346c520f80f048ac
+MISC metadata.xml 1009 BLAKE2B 4a7828bf14d896ea37cc6091c2d019bb96e4c97e0ae3f2b48045a92aa9ec2a648058fe817b5cc0fc2bb98379365b9d94f9529ba5de1b3f5dca67dcb313f87cb9 SHA512 cc64f740c4b3ab4a5c4d87b60b2146b6b5a64869d19f6283428d365c7a6f79a6697b8bd63bd31c2cad63bb065d32ac751c643ff794adf966edfc8663debdd4af
diff --git a/games-util/lgogdownloader/lgogdownloader-3.3.ebuild b/games-util/lgogdownloader/lgogdownloader-3.3.ebuild
new file mode 100644
index 000000000000..0ac33eae5786
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://sites.google.com/site/gogdownloader/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+debug"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ net-libs/liboauth:0=
+ >=net-misc/curl-7.32:0=[ssl]"
+
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig"
diff --git a/games-util/lgogdownloader/lgogdownloader-9999.ebuild b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
new file mode 100644
index 000000000000..478ab0eee166
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils git-r3
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+EGIT_REPO_URI="https://github.com/Sude-/lgogdownloader.git"
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="+debug"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ net-libs/liboauth:0=
+ >=net-misc/curl-7.32:0=[ssl]"
+
+DEPEND="${RDEPEND}
+ sys-apps/help2man
+ virtual/pkgconfig"
diff --git a/games-util/lgogdownloader/metadata.xml b/games-util/lgogdownloader/metadata.xml
new file mode 100644
index 000000000000..8a63172d961f
--- /dev/null
+++ b/games-util/lgogdownloader/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Sude-/lgogdownloader</remote-id>
+ </upstream>
+ <longdescription>
+ LGOGDownloader is open source downloader to GOG.com for Linux
+ users using the same API as the official GOGDownloader.
+
+ Features:
+ * List available games
+ * Resume downloads
+ * Batch downloading
+ * Repair downloaded files
+ * Read/create XML files used by the official GOG Downloader
+ * Download cover art
+ * Check for orphaned files
+ * Check status of files
+ * Download individual files by id number
+ * List/download updated files
+ * Blacklist unwanted files
+ * Perl regular expressions for filtering games
+ </longdescription>
+</pkgmetadata>