summaryrefslogtreecommitdiff
path: root/games-util/lgogdownloader
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /games-util/lgogdownloader
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'games-util/lgogdownloader')
-rw-r--r--games-util/lgogdownloader/Manifest2
-rw-r--r--games-util/lgogdownloader/lgogdownloader-3.9.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/games-util/lgogdownloader/Manifest b/games-util/lgogdownloader/Manifest
index 2c7d0dda65e4..9ecdceaf59ae 100644
--- a/games-util/lgogdownloader/Manifest
+++ b/games-util/lgogdownloader/Manifest
@@ -1,4 +1,6 @@
DIST lgogdownloader-3.8.tar.gz 85271 BLAKE2B ff8e9f80dbec849649b4074ab5890f833a5bfaf120246e7ca5eae83f414af469da29302323dc22632eb0a7259e49e9cf3660ea8953adda75fc7a5308204767bd SHA512 ccc6116f22a5c0bff5e4ef650f6386d5bfc507cc667b7154b021ecdbd45e7553ac33ae6b81531e2cea52a5022ee9c810033518a07374d4e9f7c672344e7ccad3
+DIST lgogdownloader-3.9.tar.gz 86351 BLAKE2B 4ba1a39e2c040910cb3fdef908c229ce8a7def70ba430167977ab4eaa7fdcdfd132a314d256300904dd14052aecffceec92652cfa3eba3c2a54d83b1920ed2b7 SHA512 5ac15776c0ab7416013782652fead180f75e3bd075a3b67c9cb672122c13401ebc91e785daa9e7d332011474240dbb4d8383ddadea2abf0d3bddfc13d6892066
EBUILD lgogdownloader-3.8.ebuild 824 BLAKE2B 8f66e5a1761eda13849def434d2bfe95d4c06ef0ca222f8b8b986178a59f7c7ce04e7f8c1b73acdaff6dcd58129d5b0376d74e75045f44393e44d1a68f0c1f66 SHA512 6360c6238d29c2033ec40196a4bcbe5c939dfd280107c776108d77b6b9e4fd479c127b7bb16ac3e7a05595b89965abc3f24f8c616ee5111bce9e1b0791aa2f37
+EBUILD lgogdownloader-3.9.ebuild 836 BLAKE2B 9562b45e361db27b3ad1885776f1a78995f7756ff115d9f7aae0133cc138e9d2f88fc6e1af3fdecb17568c5f4a22f43a9df52f8bfc14eeeaff35dd0cb5427a9d SHA512 fdde01bfa79c7930686183830657ab48be929e8f6672cb2935a58634717aea864ce5738240409c21a1dd2b9cb77b302dffdf9cccc689c1b5876e89545ef18bb9
EBUILD lgogdownloader-9999.ebuild 802 BLAKE2B 7b58e8cdf6ed1e69e9b6d1dd05c23170c5d92d1a70f72b7d3034990cdb3531b106dbc35a71e98ad2da95b9f7fb6c53556d16caa204144c1f5048d887d919aa01 SHA512 239b12971fff5743930a2780327f43b8a9d6ff7396b331fec0001a5ab850d03909ac662c506cf6c49f351a265969a154100230afcb4d8f755eb915648805e723
MISC metadata.xml 1098 BLAKE2B 154a5ed56c5e935723180acca12ae6e0a14ee2353b1a1626e16e1932922121b8d4b5eb6b5e1f2ade2f707eff696f744677e7d8f9059cdfd6f1357c77a6dc3196 SHA512 b28a6adab900d56756f206983b4fc39f5b0158702cc7a053d4c6a60f926d0dfd5d2853e0df7e99684891d7b6451829b3908c3fe9ff6a320d4fcf51c0910d417e
diff --git a/games-util/lgogdownloader/lgogdownloader-3.9.ebuild b/games-util/lgogdownloader/lgogdownloader-3.9.ebuild
new file mode 100644
index 000000000000..6e34f09c1bc1
--- /dev/null
+++ b/games-util/lgogdownloader/lgogdownloader-3.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Unofficial GOG.com downloader for Linux"
+HOMEPAGE="https://sites.google.com/site/gogdownloader/"
+SRC_URI="https://github.com/Sude-/${PN}/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gui"
+
+RDEPEND=">=app-crypt/rhash-1.3.3-r2:0=
+ dev-cpp/htmlcxx:0=
+ dev-libs/boost:0=[zlib]
+ >=dev-libs/jsoncpp-1.7:0=
+ dev-libs/tinyxml2:0=
+ >=net-misc/curl-7.32:0=[ssl]
+ gui? ( dev-qt/qtwebengine:5=[widgets] )"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_QT_GUI=$(usex gui)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ gunzip "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}