summaryrefslogtreecommitdiff
path: root/games-util/gamepick/gamepick-0.35-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/gamepick/gamepick-0.35-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/gamepick/gamepick-0.35-r1.ebuild')
-rw-r--r--games-util/gamepick/gamepick-0.35-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/gamepick/gamepick-0.35-r1.ebuild b/games-util/gamepick/gamepick-0.35-r1.ebuild
new file mode 100644
index 000000000000..0929757f8c47
--- /dev/null
+++ b/games-util/gamepick/gamepick-0.35-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Launch opengl games with custom graphic settings"
+HOMEPAGE="http://www.rillion.net/gamepick/index.html"
+SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/-O2//' \
+ src/Makefile.in || die
+}
+
+src_install() {
+ default
+ newicon ${PN}-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN}
+}