summaryrefslogtreecommitdiff
path: root/games-util/gamepick/gamepick-0.35-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /games-util/gamepick/gamepick-0.35-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'games-util/gamepick/gamepick-0.35-r1.ebuild')
-rw-r--r--games-util/gamepick/gamepick-0.35-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/games-util/gamepick/gamepick-0.35-r1.ebuild b/games-util/gamepick/gamepick-0.35-r1.ebuild
new file mode 100644
index 000000000000..0929757f8c47
--- /dev/null
+++ b/games-util/gamepick/gamepick-0.35-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils
+
+DESCRIPTION="Launch opengl games with custom graphic settings"
+HOMEPAGE="http://www.rillion.net/gamepick/index.html"
+SRC_URI="http://www.rillion.net/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's/-O2//' \
+ src/Makefile.in || die
+}
+
+src_install() {
+ default
+ newicon ${PN}-48x48.xpm ${PN}.xpm
+ make_desktop_entry ${PN} ${PN}
+}