summaryrefslogtreecommitdiff
path: root/games-util/fteqcc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/fteqcc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/fteqcc')
-rw-r--r--games-util/fteqcc/Manifest4
-rw-r--r--games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch93
-rw-r--r--games-util/fteqcc/fteqcc-2501.ebuild41
-rw-r--r--games-util/fteqcc/metadata.xml11
4 files changed, 149 insertions, 0 deletions
diff --git a/games-util/fteqcc/Manifest b/games-util/fteqcc/Manifest
new file mode 100644
index 000000000000..f615138f3b66
--- /dev/null
+++ b/games-util/fteqcc/Manifest
@@ -0,0 +1,4 @@
+AUX fteqcc-2501-cleanup-source.patch 2655 BLAKE2B 3c0af9e2663e9f18aee250f79b1315744fe8aaf818d3b7aaa590a6dbe2eaf62d44280507d5a4a4796b6ede78ed76c89f4153998cca4a0cca2f3b4553763f1db1 SHA512 978f3fc8238383ba63be4095fb7ebe30b0a6a0220b2d0f28033ab61ed23251de3757414fecdda2d987996094e3953797d0d89f3b4cc812c4ce7e15335f06035c
+DIST qclibsrc2501.zip 204047 BLAKE2B 3e9b6aeeaadf44adf8ea32c7f1f627082cc5e98f6ea84f339d44a6e34adda5dbf01add1fb2957866323ab93b8f07393bb79d94cf0d5819cc8b48376d68fefc0d SHA512 60740e55c470dcb8deb235b49b5e8bd56f3c932fd9290808224b4d0ff2d6d8eb95302fdd1c972f36c992ac046fdbbc6a34c6de2fc67e1e7de54f23fd10de89d7
+EBUILD fteqcc-2501.ebuild 770 BLAKE2B b88373414e91d51c179faa8bc2b872ededd31446d12d1028bf0e598478207635c8a87324330df9ad6483e218bf85f074d42d129eaf346ef2ad18b5d939752bb9 SHA512 3528807c8d81e5243f16ee5c605e4c780b3a1e1fdcba05d9c29e8a64e3dcfa8da613beb162855433be1a786e7d64b84bd7586acdf25cf49050cda904972ca888
+MISC metadata.xml 328 BLAKE2B 3cf3ef53d251c16dbdf4dac64df6b6f61d39259def9e37191d28449b1eb733c89f1496a69eca590c536541e3763b5870880eec8f4b27e0a370d430c75dda9712 SHA512 9a114bb9f7d3e6d5995830c71662bc58b78bee8a1d104399b9f7a53efaf3410a6da94486e8a5a9a2b25677eb79327b1fad4b135c8ed63429e21fee500853a78f
diff --git a/games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch b/games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch
new file mode 100644
index 000000000000..35f3dcf100ae
--- /dev/null
+++ b/games-util/fteqcc/files/fteqcc-2501-cleanup-source.patch
@@ -0,0 +1,93 @@
+--- qcc_pr_comp.c
++++ qcc_pr_comp.c
+@@ -7322,7 +7322,7 @@
+ QCC_def_t *def, *d;
+ QCC_function_t *f;
+ QCC_dfunction_t *df;
+- int i;
++ int i = 0;
+ pbool shared=false;
+ pbool externfnc=false;
+ pbool isconstant = false;
+@@ -8541,8 +8545,6 @@
+ struct qcc_includechunk_s *oldcurrentchunk;
+ extern struct qcc_includechunk_s *currentchunk;
+
+- extern char qccmsourcedir[];
+-
+ ocompilingfile = compilingfile;
+ os_file = s_file;
+ os_file2 = s_file2;
+--- hash.h
++++ hash.h
+@@ -19,12 +19,12 @@
+ int Hash_Key(char *name, int modulus);
+ void *Hash_Get(hashtable_t *table, char *name);
+ void *Hash_GetInsensative(hashtable_t *table, char *name);
+-void *Hash_GetKey(hashtable_t *table, int key);
++void *Hash_GetKey(hashtable_t *table, long key);
+ void *Hash_GetNext(hashtable_t *table, char *name, void *old);
+ void *Hash_GetNextInsensative(hashtable_t *table, char *name, void *old);
+ void *Hash_Add(hashtable_t *table, char *name, void *data, bucket_t *buck);
+ void *Hash_AddInsensative(hashtable_t *table, char *name, void *data, bucket_t *buck);
+ void Hash_Remove(hashtable_t *table, char *name);
+ void Hash_RemoveData(hashtable_t *table, char *name, void *data);
+-void Hash_RemoveKey(hashtable_t *table, int key);
+-void *Hash_AddKey(hashtable_t *table, int key, void *data, bucket_t *buck);
++void Hash_RemoveKey(hashtable_t *table, long key);
++void *Hash_AddKey(hashtable_t *table, long key, void *data, bucket_t *buck);
+--- hash.c
++++ hash.c
+@@ -68,7 +68,7 @@
+ }
+ return NULL;
+ }
+-void *Hash_GetKey(hashtable_t *table, int key)
++void *Hash_GetKey(hashtable_t *table, long key)
+ {
+ int bucknum = key%table->numbuckets;
+ bucket_t *buck;
+@@ -77,7 +77,7 @@
+
+ while(buck)
+ {
+- if ((int)buck->keystring == key)
++ if ((long)buck->keystring == key)
+ return buck->data;
+
+ buck = buck->next;
+@@ -168,7 +168,7 @@
+
+ return buck;
+ }
+-void *Hash_AddKey(hashtable_t *table, int key, void *data, bucket_t *buck)
++void *Hash_AddKey(hashtable_t *table, long key, void *data, bucket_t *buck)
+ {
+ int bucknum = key%table->numbuckets;
+
+@@ -237,14 +237,14 @@
+ }
+
+
+-void Hash_RemoveKey(hashtable_t *table, int key)
++void Hash_RemoveKey(hashtable_t *table, long key)
+ {
+ int bucknum = key%table->numbuckets;
+ bucket_t *buck;
+
+ buck = table->bucket[bucknum];
+
+- if ((int)buck->keystring == key)
++ if ((long)buck->keystring == key)
+ {
+ table->bucket[bucknum] = buck->next;
+ return;
+@@ -253,7 +253,7 @@
+
+ while(buck->next)
+ {
+- if ((int)buck->next->keystring == key)
++ if ((long)buck->next->keystring == key)
+ {
+ buck->next = buck->next->next;
+ return;
diff --git a/games-util/fteqcc/fteqcc-2501.ebuild b/games-util/fteqcc/fteqcc-2501.ebuild
new file mode 100644
index 000000000000..c03aa1ac4ee1
--- /dev/null
+++ b/games-util/fteqcc/fteqcc-2501.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils flag-o-matic
+
+DESCRIPTION="QC compiler"
+HOMEPAGE="http://fteqw.sourceforge.net/"
+SRC_URI="mirror://sourceforge/fteqw/qclibsrc${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cleanup-source.patch
+ sed -i \
+ -e '/^CC/d' \
+ -e "s: -O3 : :g" \
+ -e "s: -s : :g" \
+ -e 's/-o fteqcc.bin/$(LDFLAGS) -o fteqcc.bin/' \
+ Makefile || die "sed failed"
+ edos2unix readme.txt
+ append-flags -DQCCONLY
+}
+
+src_compile() {
+ emake BASE_CFLAGS="${CFLAGS} -Wall"
+}
+
+src_install() {
+ newbin fteqcc.bin fteqcc
+ dodoc readme.txt
+}
diff --git a/games-util/fteqcc/metadata.xml b/games-util/fteqcc/metadata.xml
new file mode 100644
index 000000000000..c93ba6816bc6
--- /dev/null
+++ b/games-util/fteqcc/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fteqw</remote-id>
+ </upstream>
+</pkgmetadata>