summaryrefslogtreecommitdiff
path: root/games-util/biounzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /games-util/biounzip
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'games-util/biounzip')
-rw-r--r--games-util/biounzip/Manifest4
-rw-r--r--games-util/biounzip/biounzip-1.1a.ebuild21
-rw-r--r--games-util/biounzip/files/biounzip-1.1a-64bit.patch4
3 files changed, 14 insertions, 15 deletions
diff --git a/games-util/biounzip/Manifest b/games-util/biounzip/Manifest
index c5868f86b8e5..df7b192a0296 100644
--- a/games-util/biounzip/Manifest
+++ b/games-util/biounzip/Manifest
@@ -1,4 +1,4 @@
-AUX biounzip-1.1a-64bit.patch 462 BLAKE2B 2c762b12ad665f48657419534307319d27efbc91929bd0795ea738f5f8214cc1b2ba3df6c00e8bd8f5eee9db9ada6bd14dd71165e6eb1666d90bb766ad80f901 SHA512 751078079fb663f7f229ccfbbb8e8ea2f779f6739144a75415d73937559ef08886156c8a9ae6e354269b4e0363b34b06bd2979400d671c6c4f7c646abc2b5328
+AUX biounzip-1.1a-64bit.patch 364 BLAKE2B c807463035b36aa86f61f6787ffbf7f37b6cd402db1a727d85c149a7aa114d28c140e3a37e011c8241dbfde23bff71f7d8641a7c0e4c28781390e7bf91d2a497 SHA512 661c1327521917c5b2b9c4388fb6a4babc4535ed63b464b169dc04b3cc32d3bb841a1d33b5f47a039460ed7d581668798dea6e5adffe137b05117c20974a013e
DIST biounzip-1.1a.tar.bz2 9894 BLAKE2B 950216a1b0b994b2ec271d836c7cf86471a2eca5ac0c259885e21a4df7b20425b74ae2ffb08610ed0841caced5d8b6783c448857df3a2a9030c788ee9b88db3b SHA512 4eaea5459cf6edaf289951f9048123496a4eb83fcfc39b3efcd2a81894f877d5db843d7448e2c0e3b797b09a70f6f3c133c53525d4f83408306089bd37796a8c
-EBUILD biounzip-1.1a.ebuild 588 BLAKE2B 1f1790eda791a50f937995da2854e80c8d4838146b963152b9df016e444b406b07fe9a89eae56031aa25302ecbc9ce507a51c60774e177438f85438f1dccd8fc SHA512 19df79ea2fdaf16e6b27016fc1624c0a83739165c7770ef34a64d8b5a20ffc45d0f3d581d9f9c3df293e7179f06750733474fe52b87a887f2eed2bc4ba70dd95
+EBUILD biounzip-1.1a.ebuild 573 BLAKE2B 76ef1bce3a15e9347717116e54b59ce05b19aec8cd0bb0550d2962040a5ee922793b077e189136bf4fcad1f32d2327d854cbdc678e468bff86befbff11000fe1 SHA512 1bd3d0869709dfd7cc34fb1c211453b0066acd91904599e2159eee12da0cc3ff982b3ea3680628ab44dd1927c957a3dae003492bc0f91d6de3af4bb8bdf58154
MISC metadata.xml 331 BLAKE2B 0a7243a32e0bc9b5e20d89b4b62c0199413de7c1f0c11dab9b32d925ac1dce7f65e7b74ca0d7ba78fa02a0faaf5e651fe9e6319a240189a7f934bbad8e700118 SHA512 2cb5bc86ab42d6bacdf6a1991c9c54cb3c313dd3a7dd8a2aee4d25ab899dd20d88c5db6a340e2c56e21dc1725fc6b24c55ba212e23ec2ca03230e9a6ac023b53
diff --git a/games-util/biounzip/biounzip-1.1a.ebuild b/games-util/biounzip/biounzip-1.1a.ebuild
index 8864926d8034..fa6925259af0 100644
--- a/games-util/biounzip/biounzip-1.1a.ebuild
+++ b/games-util/biounzip/biounzip-1.1a.ebuild
@@ -1,29 +1,28 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Unpacks BioZip archives"
HOMEPAGE="http://biounzip.sourceforge.net/"
SRC_URI="mirror://sourceforge/biounzip/${P}.tar.bz2"
+S="${WORKDIR}"/${P/a/}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND="sys-libs/zlib"
-RDEPEND=${DEPEND}
-
-S=${WORKDIR}/${P/a/}
+RDEPEND="${DEPEND}"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-64bit.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit.patch
+)
src_compile() {
- $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} *.c -lz || die
}
src_install() {
diff --git a/games-util/biounzip/files/biounzip-1.1a-64bit.patch b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
index a8522189d31f..860261641ed4 100644
--- a/games-util/biounzip/files/biounzip-1.1a-64bit.patch
+++ b/games-util/biounzip/files/biounzip-1.1a-64bit.patch
@@ -1,5 +1,5 @@
---- biounzip-1.1-old/biounzip.c 2007-03-08 02:06:16.000000000 +0200
-+++ biounzip-1.1/biounzip.c 2007-03-08 02:06:50.000000000 +0200
+--- a/biounzip.c
++++ b/biounzip.c
@@ -127,7 +127,7 @@
void writefile(bzfile *ptr, FILE *fp, char *destdir)
{