summaryrefslogtreecommitdiff
path: root/games-util/basis_universal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-28 08:51:03 +0000
commit21dbcce41990b13f301240313be05c8d013a9258 (patch)
tree933b3c51d46dc15fefe62b03a4f41c85b7e9bb44 /games-util/basis_universal
parente53aa6b4fbe5a0c6db75d893829f7a6a37a14180 (diff)
gentoo auto-resync : 28:01:2023 - 08:51:03
Diffstat (limited to 'games-util/basis_universal')
-rw-r--r--games-util/basis_universal/Manifest5
-rw-r--r--games-util/basis_universal/basis_universal-1.16.3.ebuild43
-rw-r--r--games-util/basis_universal/files/basis_universal-1.16.3-fix-RPATH.patch10
-rw-r--r--games-util/basis_universal/files/basis_universal-1.16.3-respect-CFLAGS.patch11
-rw-r--r--games-util/basis_universal/metadata.xml14
5 files changed, 83 insertions, 0 deletions
diff --git a/games-util/basis_universal/Manifest b/games-util/basis_universal/Manifest
new file mode 100644
index 000000000000..a68a52bf284f
--- /dev/null
+++ b/games-util/basis_universal/Manifest
@@ -0,0 +1,5 @@
+AUX basis_universal-1.16.3-fix-RPATH.patch 332 BLAKE2B 46349fb09343dfd28dfb383a7d21a5abbb64245f4ba85012f3bc97084740bb8dcbbbb2432902f27863c5a80cc04e3f2b3569dc13ee97b498932fd75182c7a6a2 SHA512 0ab6e03146c5e924644112200b6c0b6cce3f9ab5797be4a052994ee553814c128b74a1e91f66f248af21c496a4407267d0b27c46bc6c29bb1554a66581da3f58
+AUX basis_universal-1.16.3-respect-CFLAGS.patch 556 BLAKE2B b9e099ddcca8a5902da78faf293b953f231c2d05c746f6ff105a0db5dcab07009276c76f8a034a22aa42ac063850fbfaba905ce1c5022aff4e0889b9f2546123 SHA512 5eaa8339b853fb14fd5efd2596ae7221c648203fb253678c0791d7b6278e3ea55ab3d275ee28c2c9a704a5d23dc52e7f54e825c2d8de86874f79ecaced37e3be
+DIST basis_universal-1.16.3.tar.gz 29151155 BLAKE2B e3ef3ead6223aa73012bd74e51dae269746cfcf2720c524be8096ce8643777723888f98a140d2e28c881ed60ab54b7ea6fef4205b72757d72e766f85806b4484 SHA512 3dca02ad6c14e74df7a89d3b2a59b970635cf5e268b96eb91b10033e2b8e635c83aca6b8e9b34a1b689ed5ffe7c8348d15b8524385f6d07a51cc34a46246a0b7
+EBUILD basis_universal-1.16.3.ebuild 1049 BLAKE2B b9cc79ffff04195f5c2cb66bbbf70565e4be2537bce3780cdcf2e4ab0d58bf41d29d7c2af8af1927a9cabae3ec29e6e9e927aed9b2a19c977b32ba83ff8c7bd9 SHA512 b80b6cfdab06d9c94d909fdf8a761f480cab07883c7aeb92dbba37e7741666668fcb74d038bf28ca599d8c22d910e84ac475c3eca8f491a2295cf706b26331a5
+MISC metadata.xml 412 BLAKE2B 00c914af265ebe97107ee3ed185ae7693348de4902d557beb6590efae0b1ec351baed1fd02facb6605b390fff36ddc40aa49ff1786472ccd5376d16abd522540 SHA512 1a971517dc0b642e254f2acab248d9364b510b16b80fe095c320d552869f6e8909343fd6e62a1896c344d57d7f4624e10f193c3b4f3b7689eb5b669b85517998
diff --git a/games-util/basis_universal/basis_universal-1.16.3.ebuild b/games-util/basis_universal/basis_universal-1.16.3.ebuild
new file mode 100644
index 000000000000..d89b78821f60
--- /dev/null
+++ b/games-util/basis_universal/basis_universal-1.16.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Basis Universal GPU Texture Codec"
+HOMEPAGE="https://github.com/BinomialLLC/basis_universal"
+# dist .zip is just a exe for windows
+SRC_URI="https://github.com/BinomialLLC/basis_universal/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 zstd? ( BSD )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="cpu_flags_x86_sse4_1 opencl zstd"
+
+# zstd is bundled, see https://github.com/BinomialLLC/basis_universal/pull/228
+DEPEND="
+ opencl? ( virtual/opencl )
+"
+RDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.16.3-respect-CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.16.3-fix-RPATH.patch
+)
+
+src_configure() {
+ local x64=ON
+ if $(tc-getCC) -dM -E -x c - < <(echo 'int main() { }') | grep -qi "#define __PTRDIFF_WIDTH__ 32" ; then
+ x64=OFF
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_X64=${x64}
+ -DOPENCL=$(usex opencl)
+ -DSSE=$(usex cpu_flags_x86_sse4_1)
+ -DZSTD=$(usex zstd)
+ )
+
+ cmake_src_configure
+}
diff --git a/games-util/basis_universal/files/basis_universal-1.16.3-fix-RPATH.patch b/games-util/basis_universal/files/basis_universal-1.16.3-fix-RPATH.patch
new file mode 100644
index 000000000000..d15ba0d4ddfb
--- /dev/null
+++ b/games-util/basis_universal/files/basis_universal-1.16.3-fix-RPATH.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -103,7 +103,6 @@ if (NOT MSVC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DBASISU_SUPPORT_SSE=0")
+ endif()
+
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} ${GCC_LINK_FLAGS} -Wl,-rpath .")
+ endif()
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${GCC_COMPILE_FLAGS}")
diff --git a/games-util/basis_universal/files/basis_universal-1.16.3-respect-CFLAGS.patch b/games-util/basis_universal/files/basis_universal-1.16.3-respect-CFLAGS.patch
new file mode 100644
index 000000000000..e7c1db7ea2bf
--- /dev/null
+++ b/games-util/basis_universal/files/basis_universal-1.16.3-respect-CFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -72,7 +72,7 @@ if (NOT MSVC)
+ set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -fsanitize=address -fno-omit-frame-pointer -fsanitize=undefined")
+ endif()
+
+- set(CMAKE_CXX_FLAGS -std=c++11)
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+ set(GCC_COMPILE_FLAGS "-fvisibility=hidden -fPIC -fno-strict-aliasing -D_LARGEFILE64_SOURCE=1 -D_FILE_OFFSET_BITS=64 -Wall -Wextra -Wno-unused-local-typedefs -Wno-unused-value -Wno-unused-parameter -Wno-unused-variable")
+
+ if (NOT BUILD_X64)
diff --git a/games-util/basis_universal/metadata.xml b/games-util/basis_universal/metadata.xml
new file mode 100644
index 000000000000..20e5846d4192
--- /dev/null
+++ b/games-util/basis_universal/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <use>
+ <flag name="opencl">Enable OpenCL support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">BinomialLLC/basis_universal</remote-id>
+ </upstream>
+</pkgmetadata>