summaryrefslogtreecommitdiff
path: root/games-util/atlas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-util/atlas
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-util/atlas')
-rw-r--r--games-util/atlas/Manifest5
-rw-r--r--games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild67
-rw-r--r--games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch27
-rw-r--r--games-util/atlas/files/atlas-0.5.1_beta_pre20160907-simgear-compilation.patch273
-rw-r--r--games-util/atlas/metadata.xml15
5 files changed, 387 insertions, 0 deletions
diff --git a/games-util/atlas/Manifest b/games-util/atlas/Manifest
new file mode 100644
index 000000000000..fa8e46e4cffb
--- /dev/null
+++ b/games-util/atlas/Manifest
@@ -0,0 +1,5 @@
+AUX atlas-0.5.1_beta_pre20160907-jpeg-9.patch 746 BLAKE2B 686bf154fd43d68f42c97d65ce0c0207cf65a206e9f931f0b5280149768d07a589248209e8286e9b80387c1af6e9d0a8d86d0f2213d640c828daba0ed58243d1 SHA512 0291dd266d23f6a5963a5095dac79cd001e16449fbbb5f5b3113253f3d252932be915f7afc0e4efa52f0e65f9117c446dabe9850ca9d8550219657916c3efd7a
+AUX atlas-0.5.1_beta_pre20160907-simgear-compilation.patch 8125 BLAKE2B f5b0b2e27e191ff32a6006b4d2d4f200d4a1a6f387adace607a9e421cf16c55a15d2182691d3bbb5994de9870176da80b520d8de70d2532a11b9febb9a10245a SHA512 871e576cb95565b658379d76c285067c820f591f97bd1826a11f396742651aa7e783f85b9278039ab4bd2c8e6f9f0268323185a8219408c8f01fa67db65f856f
+DIST atlas-hgcode-e183e3b3a0412b504edcb3664445b3e04fd484a2.zip 530005 BLAKE2B 3069f743ee83a1892283eebe27698c6360a90f67a05999f3f5cab8b786d976a4cd15151cbe8c7c1165b43cfb9e3265868a5b55b9364a82c5f78b1fe5f69dffcc SHA512 5f4453c81b01451ce69f4f1340a7c34736be3a9ecf638aa340455d0bb0af7a5d1a7e05d0b51e8b75f5c3acef4787d208ace75d4c686e8be7eafb8f81c71df360
+EBUILD atlas-0.5.1_beta_pre20160907.ebuild 1428 BLAKE2B 69a8ba0ea8f52eed8ec772f6c9b814cf1723d130a7c379bd52a651a9acce94214219fb85b2fd6ae455023034adc220bcd9af545744e34dd6c8d1232df6815083 SHA512 b9b3d336c011fdade103dbdf978a74bd9b280750bd51d5b24aa377c00f60bc6f06277497d8f91a9615d87b63e5fb9c3a03867bb4981170fe1ade0e5c5d626fd1
+MISC metadata.xml 440 BLAKE2B b07c76b0e7d3866e8a6f6e7ef2d73ea39a29e81c57cab9e77945124bf3817182434b504e9ec5022c40a764ce8d63e034b59eb92829e982c28db4d849f006d912 SHA512 761058431181d1ca1367ef68e464e7ee1a19a69576b46768a652be280ce7d161bcdf8f5d8b993a7d8a7ababe4a8e436f11ff3ee4ad1661b50e8a8c6edbf62158
diff --git a/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild b/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild
new file mode 100644
index 000000000000..4fed6a08e4a1
--- /dev/null
+++ b/games-util/atlas/atlas-0.5.1_beta_pre20160907.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+MY_PN=atlas-hgcode
+MY_PV=e183e3b3a0412b504edcb3664445b3e04fd484a2
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~reavertm/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/freeglut
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ net-misc/curl
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg:0
+ virtual/opengl
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-3.0.0
+ media-libs/plib
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-3.0.0
+"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}/${P}-simgear-compilation.patch"
+ "${FILESDIR}/${P}-jpeg-9.patch"
+)
+
+src_prepare() {
+ default
+
+ # -Wnarrowing failure, #612986
+ sed -i -e 's:0x:(char)0x:g' src/tiles.h || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --datadir="${EPREFIX}"/usr/share/flightgear \
+ --enable-simgear-shared \
+ --with-fgbase="${EPREFIX}"/usr/share/flightgear
+}
+
+pkg_postinst() {
+ elog "To run Atlas concurrently with FlightGear use the following:"
+ elog "Atlas --path=[path of map images] --udp=[port number]"
+ elog "and start fgfs with the following switch (or in .fgfsrc):"
+ elog "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+}
diff --git a/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch b/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch
new file mode 100644
index 000000000000..639ff8217546
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-jpeg-9.patch
@@ -0,0 +1,27 @@
+Fix build with jpeg-9. Bug # 520908
+
+--- a/src/Image.cxx 2018-02-07 03:19:18.538699623 +0100
++++ b/src/Image.cxx 2018-02-07 03:20:15.105160934 +0100
+@@ -29,11 +29,12 @@
+
+ // Other libraries' include files
+ #include <png.h>
+-#include <jpeglib.h>
+
+ // Our project's include files
+ #include "misc.hxx"
+
++#include <jpeglib.h>
++
+ // This is a constant representing "Not an Elevation" - it is
+ // guaranteed to be less than any possible real elevation value.
+ static const float NanE = -std::numeric_limits<float>::max();
+@@ -266,7 +267,7 @@
+ cinfo.in_color_space = JCS_RGB;
+
+ jpeg_set_defaults(&cinfo);
+- jpeg_set_quality(&cinfo, quality, true);
++ jpeg_set_quality(&cinfo, quality, TRUE);
+
+ jpeg_start_compress(&cinfo, TRUE);
+
diff --git a/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-simgear-compilation.patch b/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-simgear-compilation.patch
new file mode 100644
index 000000000000..f6e4d58bf3b2
--- /dev/null
+++ b/games-util/atlas/files/atlas-0.5.1_beta_pre20160907-simgear-compilation.patch
@@ -0,0 +1,273 @@
+diff -r e183e3b3a041 configure.ac
+--- a/configure.ac Tue Sep 06 22:12:05 2016 -0700
++++ b/configure.ac Sat Mar 18 05:09:04 2017 +0100
+@@ -10,6 +10,8 @@
+ AC_PREREQ(2.52)
+ AM_INIT_AUTOMAKE
+
++CXXFLAGS="-std=c++11"
++
+ dnl Checks for programs.
+ AC_PROG_MAKE_SET
+ AC_PROG_CC
+diff -r e183e3b3a041 src/FlightTrack.cxx
+--- a/src/FlightTrack.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/FlightTrack.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -81,7 +81,7 @@
+ throw runtime_error("flight file open failure");
+ }
+
+- _file.set(filePath);
++ _file = SGPath(filePath);
+
+ _port = -1;
+ _device = "";
+@@ -101,7 +101,7 @@
+ _input_channel = new SGSocket("", portStr.str(), "udp");
+ _input_channel->open(SG_IO_IN);
+
+- _file.set("");
++ _file = SGPath();
+
+ _port = port;
+ _device = "";
+@@ -123,7 +123,7 @@
+ _input_channel = new SGSerial(device, baudStr.str());
+ _input_channel->open(SG_IO_IN);
+
+- _file.set("");
++ _file = SGPath();
+
+ _port = -1;
+ _device = device;
+@@ -399,11 +399,11 @@
+ return _name.str();
+ }
+
+-void FlightTrack::setFilePath(char *path)
++void FlightTrack::setFilePath(const char *path)
+ {
+ // EYE - check for existing name? overwriting?
+ // EYE - call this (and other accessors) from constructors?
+- _file.set(path);
++ _file = SGPath(path);
+ // We count this as a change.
+ _version++;
+ _versionAtLastSave = 0;
+diff -r e183e3b3a041 src/FlightTrack.hxx
+--- a/src/FlightTrack.hxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/FlightTrack.hxx Sat Mar 18 05:09:04 2017 +0100
+@@ -141,7 +141,7 @@
+ const char *fileName(); // File name
+ const char *filePath(); // Full path, including file
+ const char *niceName(); // Nicely formatted name
+- void setFilePath(char *path);
++ void setFilePath(const char *path);
+ void save();
+ bool modified();
+
+diff -r e183e3b3a041 src/Geographics.cxx
+--- a/src/Geographics.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/Geographics.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -25,6 +25,7 @@
+ #include "Geographics.hxx"
+
+ // C++ system files
++#include <cmath>
+ #include <stdexcept>
+
+ // Our project's include files
+@@ -431,11 +432,11 @@
+ bool AtlasCoord::_geodValid() const
+ {
+ // Note: this has to agree with the value set in invalidate()!
+- return !isnan(_geod.getLatitudeDeg());
++ return !std::isnan(_geod.getLatitudeDeg());
+ }
+
+ bool AtlasCoord::_cartValid() const
+ {
+ // Note: this has to agree with the value set in invalidate()!
+- return !isnan(_cart.x());
++ return !std::isnan(_cart.x());
+ }
+diff -r e183e3b3a041 src/Map.cxx
+--- a/src/Map.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/Map.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -168,13 +168,13 @@
+ bool parse_arg(char* arg)
+ {
+ if (strncmp(arg, "--fg-root=", 10) == 0) {
+- fg_root.set(arg + 10);
++ fg_root = SGPath(arg + 10);
+ } else if (strncmp(arg, "--fg-scenery=", 13) == 0) {
+- scenery.set(arg + 13);
++ scenery = SGPath(arg + 13);
+ } else if (strncmp(arg, "--atlas=", 8) == 0) {
+- atlas.set(arg + 8);
++ atlas = SGPath(arg + 8);
+ } else if (strncmp(arg, "--palette=", 10) == 0) {
+- palette.set(arg + 10);
++ palette = SGPath(arg + 10);
+ } else if (strcmp(arg, "--png") == 0) {
+ imageType = TileMapper::PNG;
+ } else if (strcmp(arg, "--jpeg") == 0) {
+@@ -272,23 +272,14 @@
+ // Read the FG_ROOT and FG_SCENERY environment variables before
+ // processing .atlasmaprc and command args, so that we can
+ // override them if necessary.
+- char *env = getenv("FG_ROOT");
+- if (env == NULL) {
+- // EYE - is it possible for this to not be defined?
+- fg_root.set(FGBASE_DIR);
+- } else {
+- fg_root.set(env);
+- }
+
+- env = getenv("FG_SCENERY");
+- if (env == NULL) {
+- fg_scenery.set(fg_root.str() + "/Scenery");
+- } else {
+- fg_scenery.set(env);
+- }
++ // EYE - is it possible for this to not be defined?
++ fg_root = SGPath::fromEnv("FG_ROOT", SGPath(FGBASE_DIR));
++
++ fg_scenery = SGPath::fromEnv("FG_SCENERY", fg_root.str() + "/Scenery");
+
+ // Set a default palette.
+- palette.set("default.ap");
++ palette = SGPath("default.ap");
+
+ // Process ~/.atlasmaprc.
+ char* homedir = getenv("HOME");
+@@ -332,10 +323,10 @@
+ // 'scenery'. We're done.
+ } else if (!fg_scenery.str().empty()) {
+ // From FG_SCENERY
+- scenery.set(fg_scenery.str());
++ scenery = SGPath(fg_scenery.str());
+ } else if (!fg_root.str().empty()) {
+ // Default: $FG_ROOT/Scenery
+- scenery.set(fg_root.str());
++ scenery = SGPath(fg_root.str());
+ scenery.append("Scenery");
+ } else {
+ fprintf(stderr, "%s: No scenery directory specified.", appName);
+@@ -356,7 +347,7 @@
+ } else if (!fg_root.str().empty()) {
+ // EYE - make default $HOME/Atlas?
+ // Default: $FG_ROOT/Atlas
+- atlas.set(fg_root.str());
++ atlas = SGPath(fg_root.str());
+ atlas.append("Atlas");
+ } else {
+ fprintf(stderr, "%s: No map directory specified.", appName);
+@@ -394,11 +385,11 @@
+ SGPath palettePath;
+ palettePath.append(palette.str());
+ if ((atlasPalette = loadPalette(palettePath.c_str())) == NULL) {
+- palettePath.set(atlas.str());
++ palettePath = SGPath(atlas.str());
+ palettePath.append("Palettes");
+ palettePath.append(palette.str());
+ if ((atlasPalette = loadPalette(palettePath.c_str())) == NULL) {
+- palettePath.set(fg_root.str());
++ palettePath = SGPath(fg_root.str());
+ palettePath.append("Atlas");
+ palettePath.append("Palettes");
+ palettePath.append(palette.str());
+diff -r e183e3b3a041 src/Preferences.cxx
+--- a/src/Preferences.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/Preferences.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -317,7 +317,7 @@
+ {
+ string buf;
+ is >> buf;
+- p.set(buf);
++ p = SGPath(buf);
+
+ return is;
+ }
+@@ -638,7 +638,7 @@
+ // EYE - just get()?
+ SGPath p(fg_root.get(Pref::FACTORY));
+ if (p.isNull()) {
+- p.set(FGBASE_DIR);
++ p = SGPath(FGBASE_DIR);
+ }
+ p.append("Atlas");
+ path.set(p, Pref::FACTORY);
+@@ -770,10 +770,10 @@
+ char* homedir = getenv("HOME");
+ SGPath rcpath;
+ if (homedir != NULL) {
+- rcpath.set(homedir);
++ rcpath = SGPath(homedir);
+ rcpath.append(atlasrc);
+ } else {
+- rcpath.set(atlasrc);
++ rcpath = SGPath(atlasrc);
+ }
+
+ ifstream rc(rcpath.c_str());
+@@ -946,7 +946,7 @@
+ }
+ SGPath p;
+ while (optind < argc) {
+- p.set(argv[optind++]);
++ p = SGPath(argv[optind++]);
+ flightFiles.push_back(p);
+ }
+
+diff -r e183e3b3a041 src/Scenery.cxx
+--- a/src/Scenery.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/Scenery.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -198,7 +198,7 @@
+ data = (GLubyte *)loadJPEG(f.c_str(), &width, &height, &depth,
+ maximumElevation);
+ if (!data) {
+- f.set(f.base());
++ f = SGPath(f.base());
+ f.concat(".png");
+ data = (GLubyte *)loadPNG(f.c_str(), &width, &height, &depth,
+ maximumElevation);
+diff -r e183e3b3a041 src/Subbucket.cxx
+--- a/src/Subbucket.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/Subbucket.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -346,10 +346,10 @@
+ // http://wiki.flightgear.org/index.php/BTG_File_Format
+
+ SGBinObject btg;
+- if (!btg.read_bin(_path.c_str())) {
+- // EYE - throw an error?
+- // EYE - will the cache continue to call load() then?
+- return false;
++ if (!btg.read_bin(SGPath(_path))) {
++ // EYE - throw an error?
++ // EYE - will the cache continue to call load() then?
++ return false;
+ }
+
+ //////////////////////////////////////////////////////////////////////
+diff -r e183e3b3a041 src/Tiles.cxx
+--- a/src/Tiles.cxx Tue Sep 06 22:12:05 2016 -0700
++++ b/src/Tiles.cxx Sat Mar 18 05:09:04 2017 +0100
+@@ -464,7 +464,7 @@
+ const SGPath& TileManager::mapPath(unsigned int level)
+ {
+ static SGPath result;
+- result.set(_maps.str());
++ result = SGPath(_maps.str());
+
+ char str[3];
+ snprintf(str, 3, "%d", level);
+@@ -821,7 +821,7 @@
+ const SGPath& Tile::sceneryDir()
+ {
+ if (_sceneryIndex == TileManager::NaPI) {
+- __sceneryPath = "";
++ __sceneryPath = SGPath();
+ } else {
+ __sceneryPath = _tm->sceneryPaths()[_sceneryIndex];
+ __sceneryPath.append(chunk()->name());
diff --git a/games-util/atlas/metadata.xml b/games-util/atlas/metadata.xml
new file mode 100644
index 000000000000..2b6588a24cac
--- /dev/null
+++ b/games-util/atlas/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">atlas</remote-id>
+ </upstream>
+</pkgmetadata>