summaryrefslogtreecommitdiff
path: root/games-strategy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-17 11:36:49 +0100
commite2db47eaae00ec33f8971db44b68645c5d3b9590 (patch)
tree3ec0cf16ddb5854017e134fabebe14bf8cb94a34 /games-strategy
parent616579b5d773c50af31ee56f00105d96ce641ca2 (diff)
gentoo resync : 17.08.2021
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/0ad/0ad-0.0.25_alpha.ebuild (renamed from games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild)161
-rw-r--r--games-strategy/0ad/Manifest5
-rw-r--r--games-strategy/Manifest.gzbin8238 -> 8240 bytes
-rw-r--r--games-strategy/warzone2100/Manifest2
-rw-r--r--games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild (renamed from games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild)1
5 files changed, 80 insertions, 89 deletions
diff --git a/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild b/games-strategy/0ad/0ad-0.0.25_alpha.ebuild
index 849ecb4aaef8..c4b1cf74eb71 100644
--- a/games-strategy/0ad/0ad-0.0.24_alpha_pre20210116040036-r2.ebuild
+++ b/games-strategy/0ad/0ad-0.0.25_alpha.ebuild
@@ -5,50 +5,50 @@ EAPI=7
WX_GTK_VER="3.0-gtk3"
PYTHON_COMPAT=( python3_{7..9} )
-inherit desktop toolchain-funcs python-any-r1 wxwidgets xdg
+inherit desktop toolchain-funcs multiprocessing python-any-r1 wxwidgets xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
-
EGIT_REPO_URI="https://github.com/0ad/0ad"
- ZEROAD_GIT_REVISION=""
+ S="${WORKDIR}/${P}"
elif [[ ${PV} == *_pre* ]]; then
ZEROAD_GIT_REVISION="c7d07d3979f969b969211a5e5748fa775f6768a7"
+ SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${ZEROAD_GIT_REVISION}"
else
MY_P="0ad-${PV/_/-}"
+ SRC_URI="
+ http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz
+ https://releases.wildfiregames.com/${MY_P}-unix-data.tar.xz
+ "
+ S="${WORKDIR}/${MY_P}"
fi
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="https://play0ad.com/"
-if [[ ${PV} == 9999 ]]; then
- SRC_URI=""
-elif [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://github.com/0ad/0ad/archive/${ZEROAD_GIT_REVISION}.tar.gz -> ${P}.tar.gz"
-else
- SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"
-fi
-
-# merged with 0ad-data
-# addresses comment #3
-# bug #771147
-LICENSE="CC-BY-SA-3.0 GPL-2 LGPL-2.1 MIT ZLIB BitstreamVera LPPL-1.3c"
+LICENSE="BitstreamVera CC-BY-SA-3.0 GPL-2 LGPL-2.1 LPPL-1.3c MIT ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby nvtt pch test"
RESTRICT="test"
+CHECKREQS_DISK_BUILD="9000M" # 8779624 KiB (8.3 GiB)
+CHECKREQS_DISK_USR="3500M" # 3545840 KiB (3.3 GiB)
+# Premake adds '-s' to some LDFLAGS. Simply sed'ing it out leads to
+# build and/or startup issues.
+QA_PRESTRIPPED="/usr/lib64/0ad/libCollada.so /usr/bin/0ad"
# virtual/rust is for bundled SpiderMonkey
-# Build-time Python dependency is for SM too
+# Build-time Python dependency is for SM, too.
# TODO: Unbundle premake5
# See bug #773472 which may help (bump for it)
BDEPEND="
${PYTHON_DEPS}
+ >=dev-util/premake-5.0.0_alpha12:5
virtual/pkgconfig
virtual/rust
test? ( dev-lang/perl )
"
-# remove dependency on nvtt
-# as we use the bundled one
+# Removed dependency on nvtt as we use the bundled one
# bug #768930
DEPEND="
dev-libs/boost:=
@@ -67,24 +67,15 @@ DEPEND="
virtual/opengl
x11-libs/libX11
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
- lobby? ( >=net-libs/gloox-1.0.20 )"
-
-# add block on 0ad-data, as it is no longer needed.
-# addresses comment #3
-# bug #771147
-RDEPEND="${DEPEND}
- !games-strategy/0ad-data"
-
-if [[ ${PV} == 9999 ]]; then
- S="${WORKDIR}/${P}"
-elif [[ ${PV} == *_pre* ]]; then
- S="${WORKDIR}/${PN}-${ZEROAD_GIT_REVISION}"
-else
- S="${WORKDIR}/${MY_P}"
-fi
+ lobby? ( net-libs/gloox )
+"
+RDEPEND="
+ ${DEPEND}
+ !games-strategy/0ad-data
+"
PATCHES=(
- "${FILESDIR}/${PN}-0.0.24_alpha_pre20210116040036-build.patch"
+ "${FILESDIR}"/${PN}-0.0.24b_alpha-respect-tc.patch
)
pkg_setup() {
@@ -94,15 +85,20 @@ pkg_setup() {
src_prepare() {
default
+ # SpiderMonkey's configure no longer recognises --build for
+ # the build tuple
sed -i -e "/--build/d" libraries/source/spidermonkey/build.sh || die
- # merged from 0ad-data
- # addresses comment #3
- # bug #771147
+ # Originally from 0ad-data
rm binaries/data/tools/fontbuilder/fonts/*.txt || die
}
src_configure() {
+ # 0AD uses premake:5 to generate the Makefiles, so let's
+ # 1. configure the configure args,
+ # 2. export some toolchain args,
+ # 3. configure premake args,
+ # 4. run premake5.
local myconf=(
--minimal-flags
$(usex nvtt "" "--without-nvtt")
@@ -115,63 +111,56 @@ src_configure() {
--datadir="/usr/share/${PN}"
)
- tc-export CC CXX
-
- # stock premake5 does not work, use the shipped one
- emake -C "${S}"/build/premake/premake5/build/gmake2.unix
+ tc-export AR CC CXX RANLIB
- # regenerate scripts.c so our patch applies
- cd "${S}"/build/premake/premake5 || die
- "${S}"/build/premake/premake5/bin/release/premake5 embed || die
+ local mypremakeargs=(
+ --outpath="../workspace/gcc"
+ --os=linux
+ --verbose
+ )
- # rebuild premake again... this is the most stupid build system
- emake -C "${S}"/build/premake/premake5/build/gmake2.unix clean
- emake -C "${S}"/build/premake/premake5/build/gmake2.unix
+ cd "${S}/build/premake" || die "Could not enter premake directory"
- # run premake to create build scripts
- cd "${S}"/build/premake || die
- "${S}"/build/premake/premake5/bin/release/premake5 \
- --file="premake5.lua" \
- --outpath="../workspaces/gcc/" \
- --os=linux \
- "${myconf[@]}" \
- gmake2 || die "Premake failed"
+ /usr/bin/premake5 "${mypremakeargs[@]}" "${myconf[@]}" gmake2 \
+ || die "Premake failed"
}
src_compile() {
- tc-export AR
-
- # build 3rd party fcollada
+ # Build 3rd party fcollada
einfo "Building bundled fcollada"
emake -C libraries/source/fcollada/src
- # build bundled nvtt
- # nvtt is abandoned upstream and 0ad have forked it
- # and added fixes. Use their copy.
- # bug #768930
+ # Build bundled NVTT
+ # nvtt is abandoned upstream and 0ad has forked it and added fixes.
+ # Use their copy. bug #768930
if use nvtt ; then
cd libraries/source/nvtt || die
- elog "Building bundled nvtt (bug #768930)"
- ./build.sh || die "Failed to build bundled nvtt"
+ elog "Building bundled NVTT (bug #768930)"
+ JOBS="-j$(makeopts_jobs)" ./build.sh || die "Failed to build bundled NVTT"
cd "${S}" || die
fi
- # build bundled spidermonkey
- # We genuinely can't use the system SpiderMonkey right now.
+ # Build bundled SpiderMonkey
+ # We really can't use the system SpiderMonkey right now.
# Breakages occur even on minor bumps in upstream SM,
# e.g. bug #768840.
cd libraries/source/spidermonkey || die
elog "Building bundled SpiderMonkey (bug #768840)"
- XARGS="${EPREFIX}/usr/bin/xargs" ./build.sh || die "Failed to build bundled SpiderMonkey"
+ XARGS="${EPREFIX}/usr/bin/xargs" \
+ JOBS="-j$(makeopts_jobs)" \
+ ./build.sh \
+ || die "Failed to build bundled SpiderMonkey"
+
cd "${S}" || die
- # build 0ad
+ # Build 0ad itself!
elog "Building 0ad"
- emake -C build/workspaces/gcc verbose=1
+ JOBS="-j$(makeopts_jobs)" emake -C build/workspace/gcc verbose=1
- # merged from 0ad-data
- # addresses comment #3
- # bug #771147
+ # Build assets
+ # (We only do this if we're using a snapshot/non-release)
+ # See bug #771147 (comment 3) and the old 0ad-data ebuild
+ # Warning: fragile!
if [[ ${PV} == 9999 || ${PV} == *_pre* ]]; then
# source/lib/sysdep/os/linux/ldbg.cpp:debug_SetThreadName() tries to open /proc/self/task/${TID}/comm for writing.
addpredict /proc/self/task
@@ -182,13 +171,16 @@ src_compile() {
mod_name="${archivebuild_input##*/}"
archivebuild_output="archives/${mod_name}"
- mkdir -p "${archivebuild_output}"
+ mkdir -p "${archivebuild_output}" || die
einfo pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip"
- LD_LIBRARY_PATH="binaries/system" binaries/system/pyrogenesis -archivebuild="${archivebuild_input}" -archivebuild-output="${archivebuild_output}/${mod_name}.zip" || die
+ LD_LIBRARY_PATH="binaries/system" binaries/system/pyrogenesis \
+ -archivebuild="${archivebuild_input}" \
+ -archivebuild-output="${archivebuild_output}/${mod_name}.zip" \
+ || die "Failed to build assets"
if [[ -f "${archivebuild_input}/mod.json" ]]; then
- cp "${archivebuild_input}/mod.json" "${archivebuild_output}"
+ cp "${archivebuild_input}/mod.json" "${archivebuild_output}" || die
fi
rm -r "${archivebuild_input}" || die
@@ -203,27 +195,24 @@ src_compile() {
src_test() {
cd binaries/system || die
- ./test -libdir "${S}/binaries/system" || die "test phase failed"
+ ./test -libdir "${S}/binaries/system" || die "Failed tests"
}
src_install() {
newbin binaries/system/pyrogenesis 0ad
use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor
- # merged with 0ad-data
- # addresses comment #3
- # bug #771147
+ # Merged from 0ad-data
+ # bug #771147 (comment 3)
insinto /usr/share/${PN}
doins -r binaries/data/{l10n,config,mods,tools}
- # merged with 0ad-data
- # addresses comment #3
- # bug #771147
- # install bundled SpiderMonkey and nvtt
- # fixes comment #1
- # bug #771147
+ # Install bundled SpiderMonkey and nvtt
+ # bug #771147 (comment 1)
exeinto /usr/$(get_libdir)/${PN}
- doexe binaries/system/{libCollada,libmozjs78-ps-release,libnvtt,libnvcore,libnvimage,libnvmath}.so
+ doexe binaries/system/{libCollada,libmozjs78-ps-release}.so
+
+ use nvtt && doexe binaries/system/{libnvtt,libnvcore,libnvimage,libnvmath}.so
use editor && doexe binaries/system/libAtlasUI.so
dodoc binaries/system/readme.txt
diff --git a/games-strategy/0ad/Manifest b/games-strategy/0ad/Manifest
index b6f5c6f32f99..1038d3309513 100644
--- a/games-strategy/0ad/Manifest
+++ b/games-strategy/0ad/Manifest
@@ -2,9 +2,10 @@ AUX 0ad-0.0.24_alpha_pre20210116040036-build.patch 5971 BLAKE2B 968ab7cbfa2b8431
AUX 0ad-0.0.24b_alpha-fix-hang-on-quit-without-nvtt.patch 2594 BLAKE2B 05c84cf91c8da8258719bdacacf35e7c57e4b5dd867c76a0aa320d919b6a30d68f3334bf9fe3aaaaf13c462d5a2ddd051a610ebe7b100e2d55583a5d0871d1be SHA512 787dc9287c6856c8fa2aabbad0f996801fcf98b5447574893ffbfc39fa2c2b626e60fc48023ff9c39293977749da4841e8a44930bdfb909272ee727dab4215a1
AUX 0ad-0.0.24b_alpha-respect-tc.patch 1095 BLAKE2B c7f2747ae832de76da3711687ce8e6d52039e23cbe31ca1114d27e93ec2b3ef150f4b241a0d869ec393c9f73e702f35ce5610f9b383bbe43e958989bbcfa0c17 SHA512 00c439a086da6553b09230cf57e76c9abcf8c13093a4d439ccb5724d6dee5474c46f924c5a0c5b43cdc8572445347dcf2a77eba3fcff17b16d492ca4bef90594
AUX 0ad-0.0.24b_alpha-rust-1.50.patch 3529 BLAKE2B 0f354b806399f1cf9fc515a1f799d119fe5d53c6c48cc5de93cd3762c4df1f2e79b1d6fc34fe2c002b002c73ac2e259556d7464b665f4eb60a186820b9f40ae4 SHA512 71884811ed0c6acbc7fec4aa4f0c3700214fd325c28eb8149c9f65fe4018d968b1dfbe0746aea940aa08a0d656f866f40cfc67fcb62965fdc861583376256602
-DIST 0ad-0.0.24_alpha_pre20210116040036.tar.gz 2562395684 BLAKE2B 03d6655f7aa1f2f91a87536a7f2afa465585856c4209ddc05e666e1e5596416883596331118ac4257ff314b04d8a5c08821eaa6ae76e5d3095146ab04f8c79ed SHA512 e1239a56b184a87708c87fc03ca41190a16d813e495c5d81ee073df98761f1524a23902e5d03a21a1b1f657b496fce6eeee4a5ef22eee30f70fbe3b0dbd44510
DIST 0ad-0.0.24b-alpha-unix-build.tar.xz 75546740 BLAKE2B a724abba6bed4b580670588e9dcfe0f75f6cef0fbde6ad666356e96213c685932edd0a1daafb5dd04206870c2c8222340c9c51e83076ec2911cbb5377ca00666 SHA512 8173d393eb1bc57c38bef0076ba973ef46c877c06644365189c0887cd3152adba51d26b553e42221fd14343e9830a3a275bfcd9b28f66281e282ea3f247730ea
DIST 0ad-0.0.24b-alpha-unix-data.tar.xz 828553992 BLAKE2B 2081225d88d475ed0899648994a900677bc3280bb2ba6cf92354ece82b90ddcefddb48458fa23e2de97100e58f4db8db408d4b50d0306a8c3efe47d263064bf0 SHA512 d7804d25ddf376028f230a31c6fc1201dfa366b3d5434569a1a7852bb4c400fb14e5c8934c5d6c6295320cf2e62c64be83b1e3c4c27fd116115bfe7d01106726
-EBUILD 0ad-0.0.24_alpha_pre20210116040036-r2.ebuild 6380 BLAKE2B c3baa01f84d1527b0ecff261db42ae84b32110896b98c853c7990c2a76af405ee169710dd3817ec139a31b02a2e97f8300789262849b040040fae4d81e5c17dc SHA512 7d70dc9d942c2956bda278949b0297496be4ecf44a352c5a429eb496884461048721ea42dc3ed2fa5c7b373280b556d1aa323dc8d4c668b3aefd3fad6f7088ac
+DIST 0ad-0.0.25-alpha-unix-build.tar.xz 75788348 BLAKE2B 49b8b99a8f2fd33d4a3c2c0320375cb372d23b2f2c0f4ba56438bc8d868891c8c8c624049e3165ec84f8b98bcb1e1195b672aa7ee258ff88317af9d4da883576 SHA512 a8edae7d2dd61972b947152edda8d9ca8bafd3d435623a94de2d1297ecad3bfc73d3b30eaff98e89a6bcb0291b49f1e25bae1300fde37c8989156c895cd12730
+DIST 0ad-0.0.25-alpha-unix-data.tar.xz 1272283892 BLAKE2B 7bc08e52b44129fce6a78914d36bcb0c8bb3312645982054274e230a23edc34f9aa899d7ca8f52f3044b8c7efd0aea4b5d16fcd9d6e20e274538007885cfa1c2 SHA512 92fad341ceb1156a3facea291856ca2f719691bba1cf085de0544f3ae9300f46391efdd1c88bcf1aafd9a9c938b6bef3babbd50c850dc17fb0c9609dbabe37ad
EBUILD 0ad-0.0.24b_alpha-r1.ebuild 6651 BLAKE2B 1ffbbda9751ada13ae5cdad2d243e1bba8a4039b083c92164b465013b795128b621fe9b4556f4f7a8f13894a96289aa643d03e7061443ab5f59623479bbfc8bd SHA512 345bda0d2d1ef18f327eb158dbce6aaa18f12cf06382c1e18a7e44585c62a51a9505b0b95616bae42a45c1786e8cb98509e9f3123926ce354f29fd09aecd8868
+EBUILD 0ad-0.0.25_alpha.ebuild 6363 BLAKE2B 7007d692230753d7d36f47a3dcbc96e1cde4e843e71eab14acd8bdfe591b08571256ad5cd7fb9ec054b445cba6f395a845976f13997b62dc7338864a19d14734 SHA512 a95471413dfeeb6d8c1d72b5bdd7c75e787cd6ad4e31d985beb7f740ea084e889eb191b95afe6b8f53937d7f2fb56cfea31cebeeb2aca664ba3bfab95d5318f2
MISC metadata.xml 715 BLAKE2B b611d7f5a8ad31e43b744dec6607293165c3e60a901b3598d62859a6d65852c9369429c090e557a970320947557ab5d3e418ecd0a39b0b1ae7a77384e6202b28 SHA512 43cd54bb88313ef72649034afbbde262917d6aa390eb7dd5b1369d851d9dcbed7d0c03169edf0d156ad0351ae7a8e485a20217e6c686b9c6b266303c8ce2b481
diff --git a/games-strategy/Manifest.gz b/games-strategy/Manifest.gz
index 1ad00fbe5977..e37bb2b2e921 100644
--- a/games-strategy/Manifest.gz
+++ b/games-strategy/Manifest.gz
Binary files differ
diff --git a/games-strategy/warzone2100/Manifest b/games-strategy/warzone2100/Manifest
index 3ba55ca5fb92..e21ce24bf1b0 100644
--- a/games-strategy/warzone2100/Manifest
+++ b/games-strategy/warzone2100/Manifest
@@ -2,5 +2,5 @@ DIST warzone2100-4.1.2.tar.xz 337480924 BLAKE2B 2042aedd43a3515bf6ccfc210dd02502
DIST warzone2100-4.1.3.tar.xz 337479212 BLAKE2B 07d1788fc2f8e5073a15231d5bf0c8c50dc0413522ea1589b064190144906fb58008faab66a295cec7759a1036f4d007ef8a42cffd9ef588fde1116b6cd7a38b SHA512 64126a1a5aab8b766cdfc70b8d96465ad451bd6a31e33be963eb89664b062dfe58e195ac3cbc087a9c008519c0e13003d9750bcb428b0e0ff12c82bf9940be3f
DIST warzone2100-videos-2.2.wz 571937134 BLAKE2B 60b70a71bd920e2d72ded5d519b17db2f3db4b0289edadeb58059a21aba7038b95219dc44cb807754461d1a9bdca60f0d7698be68622b8bd64a55efa949622d3 SHA512 ca1a1af51296afdaca137114821508c5783f077090e665eae0f6df895855f57c43f84434706309e819417f5f35d1c649bd14e96dc9fbbb1252d30a4f9a223cf6
EBUILD warzone2100-4.1.2-r1.ebuild 2527 BLAKE2B 5b30a48f1bfa0fa022120923698dac9054bd77b598d3d12015be911ee1fea198c28d46e4c9d0bc9a6438845dfd237b8e2f54d37089bb37f890edb9fbd279d841 SHA512 d251b0cdc1500dbb9befe2925a4c796d893d4659a5bd932ab45955a5ecce2772154937e1dd13f488891f011c161d35a47c78b6d14e956c89425f0c956224000b
-EBUILD warzone2100-4.1.3-r1.ebuild 2738 BLAKE2B ca5b073b29ebb9d62e2cfd83725ee701c41d07408cfed81f3c4974cc3f983d9cd6efbbf2e1338fb483f5561207262290ab26eb2cfb194f698eef75e71b608105 SHA512 9578af177e8caf6daf95efd392a6e52274c20c5eb63aadf71ac61d0dc4d76f1a55bdc3754c251f421265bbee8c69f6e2a9f2a56845aa3bb805c8d29fc1f2684e
+EBUILD warzone2100-4.1.3-r2.ebuild 2765 BLAKE2B b23e35e0912b3fe841aeecada4770d698e897f8e2de01d4f549d8d8ea9a6d491d5173bac4e3cfcce7cccb345d5e620c27e0b13f5c1e0ebd04f1746a57190f2a8 SHA512 4f16ef347548f8c88c1a9da413053da897530443fbc39e2c15561d5419e3fce342d3499ef146f8f86d1b3bce1c494db3241e4236a86e3ec8cbdfaa0cda755edc
MISC metadata.xml 811 BLAKE2B 3b34613b3eeec7f6f428f9e2c48561df6fecc03566d7b9b10618aba37fd53e2f1bd1d09e46804f2c87f2504e4d91d1a289a2a22afea8c7eac01820b779a77cf3 SHA512 af44da84a5578f11e6f01e0310a7aefedf29582c90d257eaa51e64a59fd85a5e60c2f56ca401c58fb40c079c556abc400586aa74dc49d1b5b9073bf750ce1845
diff --git a/games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild b/games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild
index ab190710681b..3e39b944a707 100644
--- a/games-strategy/warzone2100/warzone2100-4.1.3-r1.ebuild
+++ b/games-strategy/warzone2100/warzone2100-4.1.3-r2.ebuild
@@ -111,6 +111,7 @@ src_install() {
"${ED}"/usr/share/doc/${PF}/copyright || die
if use videos ; then
+ insinto /usr/share/${PN}
newins "${DISTDIR}"/${VIDEOS_P} sequences.wz
fi
}