summaryrefslogtreecommitdiff
path: root/games-strategy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-16 03:02:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-16 03:02:52 +0000
commitb0735771a80a647a2ea5a03a87d5873d175bd744 (patch)
treeaed120d0dfeab57cb7f38b7a5d186b1c53ae10cd /games-strategy
parent57d1fe5ae0c56e604db5d29bf7b62d685c42e043 (diff)
gentoo auto-resync : 16:11:2024 - 03:02:52
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/Manifest.gzbin7585 -> 7582 bytes
-rw-r--r--games-strategy/widelands/Manifest4
-rw-r--r--games-strategy/widelands/widelands-1.2.1.ebuild59
-rw-r--r--games-strategy/widelands/widelands-9999.ebuild11
4 files changed, 68 insertions, 6 deletions
diff --git a/games-strategy/Manifest.gz b/games-strategy/Manifest.gz
index 316a7a83df67..09976592209f 100644
--- a/games-strategy/Manifest.gz
+++ b/games-strategy/Manifest.gz
Binary files differ
diff --git a/games-strategy/widelands/Manifest b/games-strategy/widelands/Manifest
index d04847e4af1a..28e4f4fe985c 100644
--- a/games-strategy/widelands/Manifest
+++ b/games-strategy/widelands/Manifest
@@ -1,4 +1,6 @@
+DIST widelands-1.2.1.tar.gz 457853247 BLAKE2B 8af9febc4379f52f2343bff244e7ec3c42e63792e2a93f61446df81a101201d1471d20c8c1b73d6267f5066d3861bfc802227b2abd4b0fc172b447d0b598ddfd SHA512 9a7449096dab8ff07ac12354f4fb659fcbe419381d289e869c134c5b804c8817f9fbffb854283ab0b5bca541e9649f7f0e7658fd2765bc2a8a8f705dc24f01d8
DIST widelands-1.2.tar.gz 457713595 BLAKE2B b89caef369268b31fb70c4b054f1df3651e974763c6b2d82488a662a7edaed19f525177371592f9ad28cc14194044d48862e22b38a3a449c6e7ed0023bf30d09 SHA512 e05812f93defe8b9a3da60e6ba73a65bba47abec3199298f9a778fb42655aba671cb45a2603c2936538de1e0f82892a183ea5e1df15937b9812d369d068fab81
+EBUILD widelands-1.2.1.ebuild 1277 BLAKE2B ec19713b94e657ff835a004ebbdadc46481e1a22b6a51094ba1bc59051e6912274d6091abd2622aa912334f509240a1903031c4442fde9ed0e566e300537e2bc SHA512 dadd5963f03af6df4befe16f170653464b11b0d6d433925e032dcdc1667461e1a934a46720402edcc6896c57a2ddaaaa2be8484f40f635269cca1e66a089ecd3
EBUILD widelands-1.2.ebuild 1311 BLAKE2B 39b56e6cbc7f9a598916fd1b01066f425a46fc90b4a1733bdbb2bf47a129ebd939ebf9f8702a9239006aff4f8e39b5fa851e5a5948c3563662c4c0d591f1b6e1 SHA512 0ad2b6e3a74d5d6235e000e4c460ec1a86ee0ff6dff54ab19bfab4d6198dc8217081fa57d738f019b3579dd56cf51149650d113f6e229bc603d2e8882fc88dc9
-EBUILD widelands-9999.ebuild 1311 BLAKE2B 39b56e6cbc7f9a598916fd1b01066f425a46fc90b4a1733bdbb2bf47a129ebd939ebf9f8702a9239006aff4f8e39b5fa851e5a5948c3563662c4c0d591f1b6e1 SHA512 0ad2b6e3a74d5d6235e000e4c460ec1a86ee0ff6dff54ab19bfab4d6198dc8217081fa57d738f019b3579dd56cf51149650d113f6e229bc603d2e8882fc88dc9
+EBUILD widelands-9999.ebuild 1277 BLAKE2B ec19713b94e657ff835a004ebbdadc46481e1a22b6a51094ba1bc59051e6912274d6091abd2622aa912334f509240a1903031c4442fde9ed0e566e300537e2bc SHA512 dadd5963f03af6df4befe16f170653464b11b0d6d433925e032dcdc1667461e1a934a46720402edcc6896c57a2ddaaaa2be8484f40f635269cca1e66a089ecd3
MISC metadata.xml 390 BLAKE2B 139ecbaa266c6fe37441b3e0dd05692dc9eff8301339b7ed358ff32e17c6a1a14cd52b2cf22f141381bcf76d5e9dd579575d204e5a3c1c3793b49ced61b090af SHA512 ecaa9b97ffb2302a7f356e53393f185b70b83563052066d4dd70ad7b725a9963c46b582e1a438f36d517cc52e0ff56316ea8be6c92b54fcdda1726776845f46f
diff --git a/games-strategy/widelands/widelands-1.2.1.ebuild b/games-strategy/widelands/widelands-1.2.1.ebuild
new file mode 100644
index 000000000000..c3f0df651d6b
--- /dev/null
+++ b/games-strategy/widelands/widelands-1.2.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+inherit cmake python-any-r1 xdg
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/widelands/widelands.git"
+else
+ SRC_URI="
+ https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Game similar to Settlers 2"
+HOMEPAGE="https://www.widelands.org/"
+
+LICENSE="GPL-2+ || ( Apache-2.0 GPL-3 ) BitstreamVera BSD CC-BY-SA-3.0 MIT OFL-1.1"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/icu:=
+ media-libs/glew:0=
+ media-libs/libglvnd
+ media-libs/libpng:=
+ media-libs/libsdl2[opengl,sound,video]
+ media-libs/sdl2-image[jpeg,png]
+ media-libs/sdl2-mixer[vorbis]
+ media-libs/sdl2-ttf
+ sys-libs/zlib:=[minizip]
+ virtual/libintl
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/asio
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DWL_INSTALL_BINDIR="${EPREFIX}"/usr/bin
+ -DWL_INSTALL_DATADIR="${EPREFIX}"/usr/share/${PN}
+ -DGTK_UPDATE_ICON_CACHE=OFF
+ -DOPTION_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
diff --git a/games-strategy/widelands/widelands-9999.ebuild b/games-strategy/widelands/widelands-9999.ebuild
index a573f92451d1..c3f0df651d6b 100644
--- a/games-strategy/widelands/widelands-9999.ebuild
+++ b/games-strategy/widelands/widelands-9999.ebuild
@@ -3,21 +3,24 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit cmake python-any-r1 xdg
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/widelands/widelands.git"
else
- SRC_URI="https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="
+ https://github.com/widelands/widelands/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
fi
DESCRIPTION="Game similar to Settlers 2"
HOMEPAGE="https://www.widelands.org/"
-LICENSE="GPL-2+ || ( Apache-2.0 GPL-3 ) BitstreamVera CC-BY-SA-3.0 MIT OFL-1.1"
+LICENSE="GPL-2+ || ( Apache-2.0 GPL-3 ) BitstreamVera BSD CC-BY-SA-3.0 MIT OFL-1.1"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -44,8 +47,6 @@ BDEPEND="
"
src_configure() {
- CMAKE_BUILD_TYPE=Release # disables -Werror
-
local mycmakeargs=(
-DWL_INSTALL_BASEDIR="${EPREFIX}"/usr/share/doc/${PF}
-DWL_INSTALL_BINDIR="${EPREFIX}"/usr/bin